Sorry for the stupid question but I am new with Linux (I am using Gnome classic with Ubuntu 12.04) and I cannot set compiz in order to obtain the rotating cube.

I have already installed compizconfig-setting-manager and also the extra (and fusion) plugins but:

  • even if I disable the desktop wall and enable cube and rotating cube, nothing happens;
  • even if I change into general settings the number of vertical and horizontal virtual size nothing happens.

What I need is (possibly) a step by step answer.

Thank you

Ok...I solved my problem by using the command.

compiz --replace

which I have found looking around.

Can someone explain me what I have precisely performed with this command?

Thanks in advance

  • What guidelines or instructions you followed? Edit the question to include that. – Anwar Jul 4 '12 at 9:36
  • link and other italian pages. I think also that one issue could be the fact that until few days ago I used unity and my Gnome classic "derive" from the fact that I am using Gnome Shell...could it be? – Keynesian Jul 4 '12 at 9:42
  • You can check this link for a good introduction. also do a compiz profile reset with compizconfig-settings-manager – Anwar Jul 4 '12 at 9:52
  • I've done what you have suggested and after the reset I have changed to 4 the horizontal virtual size and I have crossed Desktop Cube and Rotate Cube. Anyway, it doesn't work yet. – Keynesian Jul 4 '12 at 10:01
  • check this question askubuntu.com/q/34588/61218. then update the question if you have any other query – Anwar Jul 4 '12 at 10:07

With compiz --replace, you have replaced any existing window manager with Compiz; if you were already using Compiz, you have "reset" (or re-initialized) it -- which probably explains why this command solved your problem by finally applying your custom settings.

| improve this answer | |
  • A new problem had emerged. Now I cannot move any window from one desktop to another; moreover I cannot resize the windows. Can you tell me what to do? – Keynesian Jul 4 '12 at 11:41
  • @Keynesian: first, try rebooting. Otherwise, could you please start a new question, describing the steps you took to change Compiz from its default configuration? After that the solution should be easy (because I or others can attempt to replicate your problem if necessary). – ish Jul 4 '12 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.