Yesterday, suddenly my touchpad on my MSI Laptop started to not respond. In other words, in Login screen, touchpad is working as expected. However, in Desktop screen, after I have logged in, touchpad is not working.

How can I enable touchpad in Desktop?

  • Have you tried, the FN + function key combination? – Mitch Jul 4 '12 at 7:04
  • Which one ? I am using MSI – user8324 Jul 4 '12 at 8:58
  • @Mitch make this as answer, it works – user8324 Jul 4 '12 at 9:39

Make sure that the Touchpad is enabled. On an MSI laptop to Enable or disable the touchpad: FN+F3.

| improve this answer | |

I accidentally disabled my touchpad. This is the way I found to re-enable it.

Press the "Windows key" to open the start menu. Type "terminal" and enter, to open the command line.

Then type:

xinput list

Find the 'id' of your touchpad. For me it looks like this:

Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                     id=12   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=11   [slave  pointer  (2)]

My touchpad has id = 11.

Then type

xinput set-prop 11 "Device Enabled" 1

(but replace 11 with whatever id your touchpad had)

| improve this answer | |
  • in my case I first have to run xset set-prop ... 0 and then xset set-prop ... 1 does the job... – Dima Pasechnik Jun 28 '16 at 8:57
  • you can use this aliases alias touchpad-off='xinput set-prop xinput --list |grep -oP "Touchpad.*id=\K.*?(?=\s)" "Device Enabled" 0' alias touchpad-on='xinput set-prop xinput --list |grep -oP "Touchpad.*id=\K.*?(?=\s)" "Device Enabled" 1' – barak Oct 8 '18 at 7:08

This work for me on kali linux:

gsettings reset org.gnome.desktop.peripherals.touchpad send-events

The schemas dir can be found by:

gsettings list-schemas

Edit: This works on Ubuntu 18.04 as well.

| improve this answer | |
  • worked for my fujitsu ah512 lifebook. Thankyou – Naveed Jamali Feb 6 '18 at 4:29
  • totally saved me – grabantot Feb 25 '19 at 17:31
  • This is the only one which works for me in Ubuntu 18.04, to reset changes made to the Enable Touchpad setting in the GNOME settings GUI. – Sman789 Mar 2 '19 at 23:54
  • This worked for Pop!_OS when nothing else did – Joseph8th Jun 8 '19 at 23:04
  • This worked for me on Ubuntu 18.04 – Felix Crazzolara Oct 19 '19 at 11:48

Running Ubuntu 16.04 there is a painfully simple way to re-enable the touchpad if you disabled it via the "Mouse & Touchpad GUI":

  • ALT+TAB to select the "Mouse & Touchpad GUI" if you currently do not have it focused. (Or use the Windows key -> Search for "Mouse and touchpad" -> ENTER)
  • Use TAB to iterate through the items within the GUI until the ON/OFF slider is highlighted.
  • Hit ENTER to toggle the switch back to "ON".

I realize this is very simple, but it took me an embarrassingly long time to figure out.

| improve this answer | |
  • 1
    You sir are the real MVP. – eyeezzi Jan 19 '18 at 13:07
  • It's only obvious when you know the answer! – Chris Huang-Leaver Jul 29 '18 at 5:37
  • interestingly, my ubuntu 18 did not show this behaviour, i could not tab across the mouse and touchpoint GUI.. Had to plug a mouse in to re-activate. – Hightower May 15 '19 at 21:33
  • @Hightower that's too bad. I guess this is not something that will work with Ubuntu > 16 – BlackVegetable May 15 '19 at 22:24
  • 1
    This doesn't work with 19.04 either. Silly interface. – Andrew B. Jun 20 '19 at 17:38

You could try the following command in a terminal and see if it helps, I always used it to restart the touchpad on 11.10 when it stopped working, but I have had no problems on 12.04.

synclient Touchpadoff=0
| improve this answer | |
  • I have tried but touchpad is still not work – user8324 Jul 4 '12 at 8:53
  • This no longer works under recent Ubuntu since libinput is used. – Konrad Gajewski Aug 18 '18 at 10:23
  • 1
    I don't know how i disabled the touchpad, but this solved it and it's working again !! Thanks!. You avoid me buying a new laptop ( i was going to smash it). – bistoco Nov 28 '18 at 4:47
  • @KonradGajewski This still works under Xubuntu 18.04. – Chai T. Rex Jun 20 '19 at 22:06

I don't recall having this problem in 12.04 either but running the gpointing-device-settings command and unchecking Disable touchpad always did it for me in 11.10.

| improve this answer | |
  • I have tried but touchpad is still not work – user8324 Jul 4 '12 at 8:54

I'm using Linux Mint and disabled the touchpad, and like others before me, I noticed how hard it is to switch it back on if you don't have a mouse handy.

Using the Mint Preferences to disable the touchpad won't let you enable it again by using xinput or synclient as suggested in various places.


gsettings set org.cinnamon.settings-daemon.peripherals.touchpad touchpad-enabled true

Longer version on how I managed to get it back.

I dumped the cinnamon config to a file with:

'dconf dump /org/cinnamon/ > mysettings'

Under the heading 'settings-daemon/peripherals/touchpad' i found 'touchpad-enabled=false'

List the schemas and find something related to the touchpad

gsettings list-schemas | grep touchpad 

List the keys in the touchpad-schema

gsettings list-keys org.cinnamon.settings-daemon.peripherals.touchpad

Enable the touchpad

gsettings set org.cinnamon.settings-daemon.peripherals.touchpad touchpad-enabled true

Some useful links:

| improve this answer | |

I have had the same problem but I found the fix for mine to be very simple. I unplugged my mouse out of the USB port on the laptop and the touchpad immediately started working again. It disables the touchpad when you have a mouse plugged in. My Laptop's model is the MSI Apache Pro-012 (GE70)

| improve this answer | |

There is a little button at the bottom of your keyboard on the laptop (sometimes just above the touchpad) mine looks like a W but isn't Windows key, if you have that tiny button it enables and disables your touchpad.

| improve this answer | |