I should start out by saying that I am not very tech savvy and have done my best to understand what is going on here from reading other people's posts and have fumbled my way through several attempted fixes without getting anywhere...

I run ubuntu 12.04 on an admittedly cheap laptop from ebuyer and in spite of being cheap and not a brand laptop I have never had any major problems with it. Since updating to 12.04 when it was released the boot-up process has always been slow. Logging in takes about 30secs longer than it used to and if I closed my laptop and opened it again instead of being met with a login screen I'd be met with a black screen with a white mouse. As all of these problems had a behavior-changing fix (don't close laptop, patiently wait for login, etc.) I didn't think of reporting any of the issues.

Last night when the update manager prompted me that there were updates available I duly did them as I usually do. At the time a bug report came up and I cannot remember what it said but I reported the bug as I was prompted to do. Then this morning when I started up my laptop it went through the usual sequence, GRUB, purple screen with 'ubuntu' etc. and then when it tried to boot up it went into BusyBox and I have not been able to do anything to solve this.

I have tried going into the GRUB menu and starting previous versions but I come to the same point - busybox. I have borrowed another rather elderly laptop with Windows Vista to try and download Boot Repair and Ubuntu and burn them onto CD. I tried downloading boot repair five times, to laptop, CD and USB. Every time it would download and burn fine but then the windows laptop would tell me that 1% did not download properly and my laptop would not run the USB or CD upon booting. I then tried to download ubuntu and make a livecd, twice, but again was told that 1% did not download properly and again my laptop will not run ubuntu from the CD upon booting even if/when I went into the f2 menu and changed the menu priority (if that's what you call it) for booting up to make sure it was definitely trying the USB/CD first.

This is the message I get from busybox:

    BusyBox v1.18.5 (Ubuntu 1:1.18.5-1ubuntu4) built-in shell (ash)
    Enter 'help' for a list of built-in commands

I have tried 'exit' but it mentions things about 'kernal panic' and 'tried to quit init!' and 'can't find /root/dev/console : no such file'. I know that the problem is probably caused by a problem with a kernal caused by the update last night, but I couldn't honestly tell you exactly what was updated and without being able to boot from a livecd I'm not sure how to go about fixing this.

As I said, I am not tech savvy and have done what I can to try and find a solution to the problem but I'm starting to feel like I'm out of options. Does anyone have any ideas?

  • looks like a fall-back due to heavvy problems -- that screen is something like the "last ressort". As you already experienced, most of the programs you know are not available (as the file system probably is not (completly) mounted. I'm not sure what commands are available at this state (the indicated help should tell you). If dmesg is among the options, and either less (preferable) or more, I'd recommend trying dmesg |less or dmesg |more. This will display the boot log, where you could watch for errors/indications to let us know so we can help better. – Izzy Jul 3 '12 at 22:39
  • Also take a look at the question How do I enable verbose mode at boot -- if my previous hint won't work out, this will display similar information. – Izzy Jul 3 '12 at 22:42
  • Thank you! I'm willing to try just about anything at this stage. I will try these suggestions and see how I get on. :) – Lyra500 Jul 3 '12 at 23:14
  • @Izzy Thank you for your suggestions. When I tried dmesg it went through a series of commands with several error messages and failed commands e.g. 'Failed command: READ DMA' and 'status: { DRDY ERR } and 'error: { UNC }' which I don't understand but might mean something to you. It won't let me look back over all the output, but at the bottom it has a series of lines including '[sda] Sense Key: Medium Error [current] ] – Lyra500 Jul 3 '12 at 23:52
  • @Izzy Here are the errors I can see 'Failed command: READ DMA' and 'status: { DRDY ERR } and 'error: { UNC }' It won't let me look back over all the output, but at the bottom it has a series of lines including '[sda] Sense Key: Medium Error [current] [descriptor]' 'Descriptor sense data with sense descriptors (in hex): 72 03 11 04 00 00 0c 00 0a 80 00 00 00 00 00 0e 01 6b 71' then the next line says '[sda Add. Sense: Unrecovered read error - auto relocate failed.' It then fails to read something several times and finally it says 'EXT3-fs (sda1): error loading journal' – Lyra500 Jul 3 '12 at 23:59

I keep getting same problem and finally I got the solution which works every time for me:

boot your system with LIVE CD or Pendrive open terminal and execute sudo fsck /dev/sdal (sda1 is generally used, if you have a different drive on which ubuntu is installed then give that) It may prompt you several times asking "y or n", in that case keep pressing Y. after process is over , reboot the system and remove the pendrive

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.