1

When I log in, either Unity loads perfectly or it just doesn't; all I see is my desktop background. Commands don't seem to work and I can't switch to the terminal view. No matter how long I wait, Unity doesn't start. I never had this issue with Oneiric Ocelot.

Other GUIs such as GNOME 3.4 don’t seem to be having that issue. I've got MyUbuntu, Ubuntu Tweaks, CompizConf and other tweaking tools installed. Could they be causing the problem? If not, what should I do? I'd really like to use Unity again.

Thanks in advance!

3
  • Have you tried unity --reset?
    – Mitch
    Jul 3, 2012 at 13:20
  • No, I haven't tried that before but I just did. Unity launched properly twice after I reset it but I'm not sure if that's a permanent fix or not. I'll get back here if I still experienced problems. Thank you! :)
    – Vagrant232
    Jul 3, 2012 at 16:57
  • unity --reset did not fix the issue. Starting unity is still a gamble.
    – Vagrant232
    Jul 4, 2012 at 13:59

1 Answer 1

2

The issue was fixed by updating to a newer Nvidia driver then resetting Unity. The issue seemingly was a conflict between Compiz and the recommended Nvidia driver. I hope this helps other people.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.