I am trying to install ubuntu onto my flash drive using the instructions from this website: http://www.ubuntu.com/download/help/create-a-usb-stick-on-mac-osx.

After step 8, the terminal asks for my password, which it accepts and then pops up with this error message:

dd: /dev/rdisk1bs=1m: Operation not supported.

I have also tried making the last m in that statement capital and then the system does not ask me for my password but the error message still pops up. What is happening and why?

  • 2
    There should be a space between /dev/rdisk1 and bs. If that's not the typo you've done while issuing that dd but only here, you can edit your question so that no confusion arise.
    – Samik
    Jul 3, 2012 at 10:55
  • Hmm... Try to erase all data on USB(via terminal or via Disk Utility)
    – user434475
    Jul 29, 2015 at 12:39

8 Answers 8


If you clicked the little eject icon in the Finder, this will unmount and eject the usb drive, which will give the error you saw. You want to umount only.

Unmounting can be done in Apple's Disk Utility using the Unmount button (in toolbar next to Eject), or it can be done as Marcel answers below from the commandline.

sudo diskutil unmountDisk /dev/diskN
  • Welcome to AskUbuntu. It would be helpful to OP if you can explain your answer in more details.
    – JackLock
    Jun 25, 2013 at 18:21
  • Unmount failed for /dev/rdisk3
    – user391339
    Jan 4, 2015 at 22:28
  • 1
    You rox!! Thank you! I was having difficulties to find the solution, thank you very much! :)
    – Cyril N.
    Dec 1, 2016 at 11:26
  • this is correct. Using the "umount" command also ejects the disk (!)
    – sivann
    Dec 2, 2020 at 13:08

If the above does not help (as it did for me), try

sudo diskutil umountDisk /dev/diskN

That did the trick for me.

  • Some explanation?
    – Joren
    Oct 7, 2013 at 14:24

If the disk is still mounted, you'll get a 'resource busy' error. If it's been ejected, you'll get the 'Operation not supported' error. You need to go into disk utility and UNMOUNT the partitions on the drive but do not EJECT the destination drive. Hope this helps as it can get kinda frustrating and the errors aren't always particularly helpful.


I've also had a similar problem while using the correct syntax (i.e. dd bs=1m if=source.img of=/dev/rdisk1).

A reboot seemed to fix my issue, despite several attempts with a command that had worked previously while restoring a different image.

Hope this helps!


i had to unmount then run: sudo dd if=image.img of=/dev/disk1s1 bs=512k

  • Strange, even for me Mac OS insisted on bs=512k. Thank you. Jan 3, 2021 at 12:11

The correct command is sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m (Replacing N with the disk number you found by running diskutil list)

The space between rdiskN and bs=1m is not clear in the guide because of the way the text wraps.


of=/dev/rdiskN bs=1m

I didnt realize my first time that the N is still a variable for the disk number you found when running diskutil list


As DreadPirate said, you probably have to unmount every single partition of the usb drive first. If no other command listed here works, try the following:

df -h

will return the currently mounted partitions. Find the ones belong to your thumb drive and use

sudo umount /dev/disk1sX

for each one of them, where 0 < X <= number of partitions on the usb drive (found after running the first command).

  • I had to use sudo diskutil unmountDisk /dev/diskNsX
    – Jacksonkr
    Jan 5, 2019 at 18:41
  • Well that's what @DreadPirate suggested and it's fine. All I am saying is if that does not work, try my suggestion. It works on my machine.
    – DimP
    Jan 5, 2019 at 18:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.