I need to get my box up to par or android development, but cannot get ia32-libs to install for the life of me. Can anyone help? The error Android's tool gave me was Stopping ADB server failed (code -1) and after a bit of investigation I found that I needed to install the ia32-libs which from my understanding is a pain.

Ubuntu 12.04 (x64)

xxx@xxx:~$ sudo apt-get -f install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-multiarch
E: Unable to correct problems, you have held broken packages.
  • 1
    Please provide the output of following: dpkg --get-selections | grep hold – Andrejs Cainikovs Jul 2 '12 at 15:37
  • Please include the output of dpkg --print-foreign-architectures – tumbleweed Jul 8 '12 at 22:49
  • @AndrejsCainikovs I don't know if OP is in same position as me, but I have the same problem on 12.10 and no held packages -- see my response below. – jaybee Oct 30 '12 at 17:09

I've got the same problem with 12.10, and it seems to be this bug: https://bugs.launchpad.net/ubuntu/+source/ia32-libs/+bug/1016294 . The outputs of dpkg --get-selection and dpkg --print-foreign-architectures (as requested in comments to the OP) are empty.

I have resorted to running the 32-bit version in a VM for now, rather than trashing my system as several seem to have done by trying to downgrade :-(

  • This isn't really an answer, but a "me too statement". Sounds like you have disabled multiarch. Add i386 as an architecture (dpkg --add-architecture i386) then apt-get update and see if this works. – tumbleweed Nov 19 '12 at 20:43

To develop android on ubuntu 64 bit machine, no need to install

sudo apt-get install ia32-libs

instead just issue :

sudo apt-get install lib32ncurses5 lib32stdc++6

which will enable adb and its related 32 bit android dependencies without all the unnecessary packages which will come bundled if you do an apt-get install ia32-libs


I had a similar problem with broken dependencies when trying to install wine and acroread, and a complaint when trying to install ia32-libs-multiarch, just after upgrading to 12.04 from 11.04 (passing over 11.10). It seems that some ppa's I had in 11.04 installed newer versions of applications in the system. After upgrading, the remains of these apps seemed to do some mess in the dependencies.

The solution that seems to work (until now), was found on a german ubuntu board (http://forum.ubuntuusers.de, posts from user Lasall):

First a downgrade is required and done with the following: create the 'preferences' file:

sudo vi /etc/apt/preferences

and insert the following lines:

Package: *       
Pin: release a=precise*
Pin-Priority: 2012

Pin-Priority must be greater than 1000.

Then you may downgrade the offending applications with:

sudo apt-get dist-upgrade

Then you may install packages that complained about dependencies, like sudo apt-get install ia32-libs-multiarch, or sudo apt-get install ia32-libs.

Finally, you should remove the file you just created:

sudo rm /etc/apt/preferences

because else no new updates would be found.

Hope this helps you too!


I had a similar problem when trying to install ia32-libs with ia32-libs-multiarch dependency. In my case, I was trying to install android SDK in Ubuntu 13.10. Then I tried this solution and it was worked for me:

  1. Install synaptic from terminal: sudo apt-get install synaptic

  2. Launch synaptic and go to Settings > Repositories > Other Software tab > click Add. Insert this in apt-line box: deb http://archive.ubuntu.com/ubuntu/ raring main restricted universe multiverse

  3. Click Add Source

  4. Then Reload
  5. In Quick Filter, type ia32-libs
  6. Click Apply

That's it. I hope this helps you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.