2

I would like to change the default program to open video files to VLC player. Currently I have to right click on a file and choose 'Open with...' option which is not the end of the world but very annoying? Is there a way to configure the default program to open video (or any other file types for that matter) ???

3

Go to System Settings > Details(Under System section) > Default Applications > Video . Change it to VLC Media Player.

Default Applications

|improve this answer|||||
  • On my setup, I had setup as above, but then there are many video file extensions that still don't get VLC as the default, so I had to use the solution suggested by tijybba of "Right-Click" + "Properties". But, have to do it every time a new file extension needs to be associated to VLC. So, it is also possible to associate multiple file extensions to VLC using the method suggested here: askubuntu.com/questions/57919/… which involves editing the mimeapps.list at ~/.local/share/applications. – Sri Jul 16 '14 at 5:13
2

Since already it is answered in a convenient way , other Alternate would be as here

Right click the file , select the Properties option and then

enter image description here

it will mention the Current Default Application being used to open it , you can however change it by selecting from listed Recommended Applications options (refer Screenshot ) and select the Set as Default option to open it with the selected desired application. If not mentioned there then , you can further explore the Show other applications menu down there.

Also in Changing Default Video Opening Application this method would be more Helpful, since selecting Vlc as default by the other solution would not always open all the video formats with Vlc , it will try to open them by Other default Installed apps, you will have select the default by following this method One time for formats like ,avi, mp4 , flv ,etc.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.