I installed Ubuntu x64 12.04 Desktop LTS on my new laptop three days ago.

Of course when I installed it I did an "apt-get upgrade" and a "apt-get update". I modified the .bashrc file to add some aliases but that's about it.

Everything went fine I think, but this morning when I tried to connect to my user account, it just simply didn't work.

Even when I give the right password, it will send me to a black screen with a few text lines written in white for a second and then back to the log-in screen.

When I logged into the guest session, I couldn't shutdown / restart.

I tried the "rm /home/MyUsername/.Xauthority" solution after doing a Ctrl + Alt + F1 at the log-in screen. But that didn't work.

Does anyone has an idea ? My Ubuntu seems to use Gnome.

Thank you a lot in advance !

This question is similar to this one, but their solution didn't help : --> after 12.04 upgrade: can't log in although password is correct

  • I fixed the problem by commenting a line I added to ".profile" ! – Awake Zoldiek Jul 1 '12 at 17:07
  • 1
    Welcome to Ask Ubuntu! I'm glad you were able to find the solution. I recommend posting an answer to your own question (this is not just OK, but encouraged) explaining what was causing the problem and exactly how you fixed it. Then other people searching for help with similar problems can benefit, too. (2 days after you post your answer, you can mark it as the accepted answer.) – Eliah Kagan Jul 2 '12 at 14:45
  • I have the same problem. All you have written is not helpful. What means "commenting some lines out" ? What lines? Why is 12.04 locking me out anyway? that is new to me. ubuntu worked till I upgraded. Do I have to re-install natty again to get a sane system. I'm really disgruntled. It worked for 48 hours or so. And I accepted some security updates today (mozilla). I installed the gnome-fallback. And it still worked. But, after I logged out, now it doesn't let me in! A wrong password is recognized correctly. But with the correct one I'm in a loop.- I liked UBUNTU... But this is ridiculous. If U – Andreas Jaehrig Feb 21 '13 at 0:02

I had the same problem, and as you said, solved it by commenting out some lines from the ~/.profile

More specifically, I had just passed some quite short aliases from my ~/.bashrc to my ~/.profile: not a good idea there, must have conflicted with some other important command.

In order to edit ~/.profile, since you cannot login in the shell, use a tty:

  • hit Ctrl + Alt + F2 directly on the login screen to go to tty2
  • login with your normal login/password (don't use the numpad, numlock may not be what you think)
  • vim ~/.profile
  • comment out and save
  • hit Ctrl + Alt + F7 to come back to the shell

And try to login again.


PS: I had this problem and tried all suggested solutions, reinstalling lightdm, reconfiguring lightdm, resetting owner of the home directory, removing Xauthority but it all didn't help... In the end the solution was quite simple, the reason I was only able to log in with the guest account was that there isn't a home folder for this account and I had a separate partition for /home. This partition was simply full (the reason it filled up several gigs all at once is a whole different story...), after deleting unnecessary files I was able to log in again...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.