118

Terminator is very powerful at organizing several computers or servers due to the split window and group all function. But here's the deal: I created my own Layout and would appreciate it to load at startup of terminator. Is that possible?

  • 1
    Can you post your ~/.config/terminator/config, or at least everything below [layouts]? – pconley Jul 1 '12 at 6:10
  • Hi... There is no Folder ~/.config/terminator. – zulu34sx Jul 5 '12 at 20:37
  • If you have a running command in your layout, terminator need a few seconds for drawing layout. Add a line as sleep 1 in your shell script. – user224664 Dec 12 '13 at 8:21
  • open config file ~/.config/terminator/config and edit command = cd /some/folder; bash. then save it and reopen the terminator. – simple_human Feb 11 at 4:04
17

There is a very easy way to accomplish this:

  • Open Terminator
  • Right click -> Preferences
  • In the Layouts tab (to the right of the Profiles tab), edit the default one, you will see that it says Window | window0 and Terminal | child1.
  • For the Terminal | child1, you can set: a Profile (to choose from the installed ones), a Default command, and a Working directory.
  • Set it/them to whatever you like, close, reopen again...
  • ... and voilá!

Hope this helped!

  • Important: Follow these steps exactly and it works. Bizarrely, if you click "Save" after setting a Custom command and/or Working directory, it won't work. Clicking Save seems to clear anything you entered for Custom command and Working directory. – trebormf 2 days ago
147
  1. After setting up your layout, right-click on any terminal background and choose PreferencesLayouts tab and click on Add button.

  2. Give it a name and hit Close.

  3. This should create the mentioned ~/.config/terminator/config file.

  4. Now you can start terminator using the saved layout using: terminator -l yourLayout (replace yourLayout with whatever you chose on step 2).

  5. (optional) Edit the ~/.config/terminator/config file so that where it says [layouts] and nested below it [[yourLayout]], rename yourLayout to default and remove/rename the previous default layout. Now, when Terminator starts without any parameters, it will load your custom [[default]] layout!

  • 2
    I guess there is no way to make it remember also the paths where each window is when being saved? – JussiR Mar 19 '14 at 10:24
  • The flags suggested by @Patrick on his answer below solves the layout issues on my first commend. – mhnagaoka Apr 5 '14 at 14:24
  • 5
    Reame new layout name to "default" to start automaticaly – e-info128 Jun 26 '14 at 14:02
  • 4
    6. Set a custom initial command for each window. =) askubuntu.com/questions/349385/… – vmassuchetto Apr 15 '15 at 8:27
  • 1
    Any way to save the layout from a shell command? – Alex Jul 3 '17 at 9:57
13

I use the method mhnagaoka suggested, but I made it usable from the launcher in Unity. I also had an issue with plain terminator -l my_default command, so specify these additional flags

  • -b for borderless and
  • -m for maximized.

The final Command is terminator -m -b -l my_default.

Now you need to modify terminator.desktop entry for Unity.

Go to your application folder, in my case it was /usr/share/applications. You need to have root permissions to edit with your text editor terminator.desktop.

In my case it was, sudo vim terminator.desktop.

Replace the Exec argument with your Command.

Now you can add the entry to your Unity Launcher, and it should always open your custom layout on the start.

  • 3
    not working in my 14.04 :( it just shows the same single terminal terminator window – tishma Jul 31 '14 at 12:01
12

After saving your layout (as per mhnagaoka's answer), you can make your changes used by default by editing the config file.

Edit the ~/.config/terminator/config file and look for where it says [layouts]. It should look something like this:

[layouts]
  [[default]]
    # ..default layout
  [[yourLayout]]
    # ..your custom layout

Rename [[yourLayout]] to [[default]] and remove/rename the previous default layout. Now, when Terminator starts without any parameters, it will load your custom default layout!

  • This answer suited me best because it doesn't rely on using any mouse interaction. – Reuel Ribeiro Feb 23 at 2:27
7

After setting up your layout, right-click on any terminal background and choose Preferences → Layouts tab and click on Add button. When prompted for the name type "default" and hit Enter.

Note: This may be a glitch but it's a useful glitch for me!

  • 1
    Nice solution and its working perfectly. Thanks :-) – Rubanraj Ravichandran Oct 10 '17 at 19:28
  • 1
    To everyone looking for the answer. This is the best and the easiest answer. – Omar Tariq Aug 21 '18 at 7:42
  • This is awesome. – Astrid Nov 13 '18 at 10:52
  • This does not work anymore.. – Astrid Jan 15 at 10:50
2

It's very simple. No need to edit the configuration file.

Just create your custom layout and Right Click->Preference->Layout->default and Press the save button. Now our configuration is saved as the default configuration. From next launch of the terminator, we will get the custom layout at the startup itself.

  • Found this to be the easiest solution of them all here. Firstly, positioning and creating set of windows and groups you want. Then saving custom layout and then re-opening the terminator did the trick! Thanks! – Shaze Feb 28 at 10:24
2

To open a previously saved layout, open the Terminator Layout Launcher by pressing ALT-L. There, click on the layout you need, and press launch.

1

Just as an anecdote, even after configuring custom layout 're-use profile for newer terminals' has to be checked otherwise the new terminal again opens in default profile. enter image description here

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.