I want to know how to install LibreOffice 3.5.4 in Ubuntu 12.04. I heard that it has many improvements over its earlier versions.

  • Should this question be generalized for installing any development release of LibreOffice? – Christopher Kyle Horton Dec 5 '12 at 23:46

Libreoffice 3.5.4 is currently in precise-proposed repository. If I were you, I would just wait for it until it gets into the precise-updates repository and then you can simply upgrade your system as usual. But if you are quite desperate to try it out sooner, you can follow these instructions to use 3.5.4. You don't have to install an additional PPA, which makes it even better.

First of all, you have to enable precise-proposed repository. It is not enabled by default for various stability issues as the repository usually contains software that are not tested enough.

To enable precise-proposed, open Ubuntu Software Center → Edit → Software Sources → Updates and ensure that precise-proposed is enabled.

enter image description here

After enabling the proposed, use this command to install LibreOffice 3.5.4:

sudo apt-get update && sudo apt-get install libreoffice/precise-proposed

Ok, I've solved the problem that Libre office doesn't work after I've upgraded to Ubuntu 12.04.

This question has been marked as a replacement for this question: Cannot install LibreOffice - however that question contains information that is vital to the problem solving, at least it was for me, so... perhaps marking questions as duplicates AND making sure the information is in the sanctioned and preferred question should be the policy here?

Anyway, I started out with Libre from a PPA in Ubuntu 10.04 (I wouldn't have, had I known it was such a fuss so my goal when trying to solve this problem was primarily to get Libre to work, and secondarily to get it to work without any PPA:s, both regardless of version of Libre).

My first symptom that something was broken was when I tried to open a document and Libre crashed and Ubuntu wanted to make an error report.

I then started to try to reinstall/install libre but got errors on the theme of:

The following packages have unmet dependencies:
 libreoffice : Depends: BLABLABLA!*# but it is not going to be installed
               Depends: ... but it is not going to be installed

Unfortunately I rebooted my computer before I thought to save the exact error message.

I started by removing all PPA:s (in fact I first tried a bunch of them but it didn't help).

Then I updated and upgraded to the latest versions of things:

sudo apt-get update && sudo apt-get upgrade

I also ran autoremove:

sudo apt-get autoremove

When still failing to install, I removed Libreoffice as completely as I could.

I did this by opening Synaptic Package manager and then searching for libreoffice and removing everything (Mark for removal) that seemed to have anything with libre to do.

Marking libreoffice-core for removal seems to take care of most of the packages.

I guess I could have used sudo apt-get remove --purge libreoffice-core as well but I didn't do that to get this exact result - try it if you feel experimental...

Next I did another run of update, upgrade and autoremove as listed above, just to be sure. However I still got the following problem:

$ sudo apt-get install libreoffice libreoffice-gnome
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libreoffice : Depends: libreoffice-core (= 1:3.5.4-0ubuntu1.1) but it is not going to be installed
               Depends: libreoffice-writer but it is not going to be installed
               Depends: libreoffice-calc but it is not going to be installed
               Depends: libreoffice-impress but it is not going to be installed
               Depends: libreoffice-draw but it is not going to be installed
               Depends: libreoffice-math but it is not going to be installed
               Depends: libreoffice-base but it is not going to be installed
               Depends: libreoffice-filter-mobiledev but it is not going to be installed
               Depends: libreoffice-java-common (>= 1:3.5.4~) but it is not going to be installed
 libreoffice-gnome : Depends: libreoffice-core (= 1:3.5.4-0ubuntu1.1) but it is not going to be installed
                     Depends: libreoffice-gtk but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The question supposedly being replaced by this question ( Cannot install LibreOffice ) mentions a package libexttextcat-data and that it was causing problems.

That and the key text you have held broken packages in the error above prompted me to try to remove all packages of Libre I could find (not improbable that the "broken packages" text was always there and what got me to remove Libre from the start, however I am not at all sure what a "held" package is .... sounds to me, like something Lincoln would start a civil war over...)

One of my earliest error messages mentioned something like this package name, however it is no longer in the error text as you see it above. Anyway, I started Synaptic, searched for libexttextcat and removed that package as well.

Then I did some more update, upgrade, autoremove (just to really "rub the dirt out"...)

sudo apt-get update && sudo apt-get upgrade
sudo apt-get autoremove

Then I tried to reinstall Libre again:

sudo apt-get install libreoffice libreoffice-gnome

And lo and behold, it did install and it seems to open documents just fine.

What version is it? I don't really give a cr*p about versions as long as it works but as things would have it, this is version (I guess latest stable from the Ubuntu folks...)

So, to summarize:

  1. Remove any Libre PPA:s
  2. Remove Libre office completely (but only "Mark for removal" otherwise settings will be removed as well)
  3. Remove the "libexttextcat-data" package (or any other package mentioned in the early error messages)
  4. Update, Upgrade, Autoremove (heck do it often! - um and I restarted my system as well... but that was before I removed Libre, if you want to restart do it at this step, but I don't think that's needed...)
  5. Install Libre

As a side note I might mention that I did this without using the suggested "precise-proposed" setting above. I guess that was back when Libre was not in the dist or when you want the newest buggiest version of libre or something...


Open a terminal window under Applications > Accessories > Terminal. Type

sudo add-apt-repository ppa:libreoffice/ppa

Once the repository is added, we need to let the system know about the new packages available. Update the packages list by typing

sudo apt-get update 

When finished, install the latest version of libreoffice package by typing

sudo apt-get install libreoffice

First you need to download Libreoffice, once it gets downloaded, make sure you know the location where it got saved. Most likely, it will be your Downloads folder.

Then Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo apt-get remove --purge libreoffice-core

To remove previous version, if they exist. Then navigate to the folder where you downloaded the file, and extract it. Once you do that, open terminal again, navigate to the newly created folder, and run the commands below:

sudo dpkg -i *.deb  
cd desktop-integration 
sudo dpkg -i *.deb

And Libreoffice will be installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.