My wireless won't resolve dns but my wired connection does.

I've tried:

$ sudo /etc/init.d/networking restart 


$ sudo dhclient -r
$ sudo dhclient 

as I saw at that question. But it didn't solved. Any thoughts on what might been happening or which logs I gotta see to know why is it not solving dns?

sorry about the question like this, but I'm really newbie at ubuntu.

When I try to sudo nmap -sP I can see my wired connection and the modem itself but I can't see my wireless connection.

$ sudo nmap -sP

Starting Nmap 5.21 ( http://nmap.org ) at 2012-06-29 16:21 BRT
Nmap scan report for  <-- modem
Host is up (0.0027s latency).
MAC Address: 7C:4F:B5:88:C3:DE (Unknown)
Nmap scan report for  <-- wired connection
Host is up.
Nmap done: 254 IP addresses (2 hosts up) scanned in 4.55 seconds

Open a terminal


gksu gedit /etc/resolv.conf

And add these lines after



Save the file and close the editor. Then type

sudo /etc/init.d/networking restart

Now ping to test your connection

ping -c 10 askubuntu.com

Now it should work. Flush DNS cache by typing

sudo aptitude install nscd
sudo /etc/init.d/nscd restart
sudo reboot
  • Please do it only, when you are connected by wireless. – ScareCrow Jun 29 '12 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.