87

Since I upgraded to 12.04, I am unable to RDP to a Windows 7 server. All I can see is a pop-up that says "Uable to connect to RDP server ". I am able to RDP using Vinagre, so that rules out any issues with my router or the Windows server. As far as I can tell, there are no logs from Remmina and the Debug window shows a blank. Any one got any ideas? Thanks.

0

7 Answers 7

156

I too had the problem that I could connect to a Windows 7 machine and suddenly (after weeks) I got this error: Unable to connect to RDP server

In my case I deleted the entry from ~/.freerdp/known_hosts and it then worked fine.

9
  • Same goes for current debian testing, version 0.9.99.1.
    – AndreasT
    Sep 12, 2013 at 0:17
  • 2
    This fixed the issue for me as well. Apparently the server fingerprint changed and I needed to resync. A more verbose error would have been nice on remmina's part.
    – gregtzar
    Feb 26, 2015 at 1:37
  • 3
    amaziing !!! I worked also for me. (Ubuntu 14.04 TLS) Thank you very much (+1)
    – Christos
    May 27, 2015 at 19:35
  • 1
    This worked for me as well, but it's a bit concerning why it should. When I diff the new file with the old diff .freerdp/known_hosts{,.bak} I see that the host key has changed. I encountered this issue after disconnecting the remote session (leaving the account logged in on the remote), going to bed, and then waking up the next morning to find that I couldn't re-connect. After reboots on the local and remote machine, restarting the term service (Windows Server 2008), I found the solution here. Any idea why the host key should have changed?
    – Allen
    Apr 17, 2016 at 20:37
  • 3
    Linux Mint 18: the file is now located here: ~/.config/freerdp/known_hosts Sep 8, 2016 at 16:52
71

Click Advanced tab in your Remote Desktop Preferences and choose RDP in Security drop down menu and save.

So far it works for me.

3
  • 1
    Or more generally, choose the authentication type that the server supports, NLA in my case.
    – phunehehe
    Jan 29, 2014 at 5:02
  • 1
    Yes, this worked for me, too. Jun 13, 2016 at 19:19
  • Yup, I needed this to get mine to work as well
    – Cobertos
    Apr 14, 2020 at 22:51
15

I had a similar problem, getting the "Unable to connect to RDP server" message using Remmina and Ubuntu 12.04 to a Windows 7 machine.

It worked fine for weeks and then suddenly stopped.

What fixed it was going to ~/.freerdp/certs and deleting the problem server from that file.

The next time it connected, it asked for a new cert and worked fine.

0
10

I had this problem. Like you I had no output when running remmina on the command line and the debug window was blank. I solved this by removing the line in the file ~/.freerdp corresponding to the problem server.

1
  • 3
    filename is: ~/.freerdp/known_hosts
    – gare
    Oct 29, 2013 at 13:10
8

I have no idea why it worked, but I started changing settings one at a time. When I edited the connection properties, I looked on the "advanced" tab and changed the security from "negotiate" to "TLS", and voila, everything works.

Strangely, "negotiate" still works on the laptop, but at least I'm back in business with my bigger monitor :)

5

I haven't had any files in ~/.freerdp/certs/ so I went ahead and cleared the file ~/.freerdp/known_hosts with this command:

echo "" > ~/.freerdp/known_hosts

Be careful! This will erase the entire file. I only had one entry, so it was okay.

Afterwards connecting to the server Remmina asked me to accept the servers certificate, which I did, and everything was finally back to normal. I suspect that an update of Remmina or the RDP protocoll might be the issue.

1
  • 1
    I can't imagine why Remmina can't come up with a better error message than "Unable To Connect" but your solution saved many hairs on my head!! Sep 29, 2014 at 19:15
5

I resolved this issue by activating the console mode for windows 2003.

Advanced ->
Protocol RDP
security = RDP
tick: Attach to console

1
  • This works fine for me, I was trying to connect to a Windows Server 2012 R2, so the last option was that I was missing. Thanks!
    – Alavaros
    Dec 17, 2014 at 12:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.