I made some mistake by setting environment variabel Now i can not launch any application from the console and recieve this error:

GLib-GIO-ERROR **: No GSettings schemas are installed on the system

I have reinstall gsettings-desktop-schemas but of course that helps not all.

I made setting of variable because i wanted to make view3dscene launchable from the dash:




I had a console warning during the installation of view3dscene as follow:

Note that '/home/XXX/.local/share' is not in the search path
environment variables, so applications may not
be able to find it until you set them. The
directories currently searched are:

- /root/.local/share
- /usr/local/share/
- /usr/share/

How can I make this in the right way and repair those wrong settings? Now i don't want to reboot system because somehow i have feeling that i don't get in anymore with those wrong settings..Right?



Have you tried logging out and back in? You don't need to set those environment variables. The /usr/local/share path is included in XDG_DATA_DIRS by default.

The warning message probably came as a result of you installing it as the root user, rather than the normal user. You should likely just ignore it, and should be able to run view3dscene just fine as your normal user if you've installed it properly.

  • i am afraid to logout because i registred those "GLib-GIO-ERROR **: No GSettings schemas are installed on the system" errors and I am not able to run view3dscene from the dash and cosole..right now i can run application only via click on the bianry..I have also registred that I can't run apps: inkscape, gimp and all my standard apps from the console..i recieve the error above too
    – user43484
    Jun 29 '12 at 20:10
  • You are getting that error because you messed up the environment, and run a program from the terminal where you did that. You can still run those apps from the launcher, no? You can just do "unset XDG_DATA_HOME XDG_DATA_DIRS" and it will probably work again just fine from the terminal you're doing this in as well. Or you could just close the terminal and start a new one. Unless you put those commands in your ~/.bashrc or something. In which case, you should remove them from there.
    – dobey
    Jun 29 '12 at 21:46
  • i have unset XDG_DATA_HOME XDG_DATA_DIRS, I can run inkscape again but still not view3dscene, the gimp gives following error:Gimp-Widgets-CRITICAL **: gimp_device_info_set_device: assertion `(info->device == NULL && GDK_IS_DEVICE (device)) || (GDK_IS_DEVICE (info->device) && device == NULL)' failed I have reboot, could relog without problem
    – user43484
    Jun 29 '12 at 21:58
  • OK. I don't know what view3dscene is, or why you can't run it, but perhaps it was not properly installed. It should work without having to muck with the environment. If it doesn't, something else is wrong, but that's also a separate question from the one you asked here. The CRITICAL from gimp about device info is unrelated to this, as well. As my answer has satisfied this question, could you please accept it as the answer? Thanks.
    – dobey
    Jun 30 '12 at 14:48
  • HMM..view3dscene is a 3d model viewer with simplest installation :castle-engine.sourceforge.net/view3dscene.php
    – user43484
    Jun 30 '12 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.