Possible Duplicate:
Am I using Unity or Unity 2D?

This is really weird XD I have Ubuntu 12.04, my graphic chip is a Mother Board integrated Via Chrome9, which is incompatible with Unity 3D, so I was looking for a dock in order to replace Unity 2d, That was my experience:

Cairo (OpenGL): I tried first with Cairo (W/OpenGL), nice and very configurable dock but it suddenly got freezed after some minutes everytime I used it, about 8 times in diferent DE (Gnome, Classic Gnome, Xubuntu, Cairo (without Unity)...).

Docky: then I installed Docky, it was cool, pretty lightweight and fast, I made everything trying to make it crash as Cairo did before but I Couldn't, the only two things I don't like is I can't get rid of the anchor and it doesn't have an app search plugin. so, I installed...

Docky + Gnome Do: after seen how well docky worked and I missed the app search feature I installed Gnome Do, thinking it was going to be pretty cool and my definitive "Unity killer"... but after rebooting Gnome Do crashed my PC about 20 times at startup, it popped up a password request to acces my passwords in gnome (Message was in spanish so I don't know how it is called exactly) but I could not introduce any password and the desktop was totally blocked, just (prnt Scrn+Allt Gr+O) could take me out of there, I solved the problem by entering in Xubuntu and opening Chromium before Gnome Do loaded, once I had unblocked my passwords with Chromium I could uninstall Gnome Do, to never install it again. (note: Chromium asks me to unblock my passwords because I have them encrypted)

Unity 3D: ... O.O THAT WAS TOTALLY UNESPECTED, I logged in in Gnome Desktop with my docky at my left side, I was surfing in Internet, when wild messages appear, first a Metacity Error, ok, then pops up a compiz error, hmmm ok, but then Unity 3D appeared at my left and I was shocked 0.0 because supposedly my Video Chip (MoBo integrated Via Chrome9) is not compatible with Unity 3D for some reason, It demonstrates it isn't imposible but I think there might be a lack of interest about getting Unity 3D working in every video chip. I'd really like to know how was that posible.

I'm pretty sure I'm using Unity 3D because launcher didn't change color after changing background, besides it has some transparency, the "light" in icons is like the one I saw in some post right here, but there is something weird because when it happened Icons in Unity blurred when I opened Dash, but now they don't blur.

enter image description here


To know whether you are running a 2D session or a 3D session:


ubuntu means 3D and ubuntu-2d means 2D

To see if your card supports unity 3D:

/usr/lib/nux/unity_support_test -p
| improve this answer | |
  • Thanks, I'm running Unity 2D, there might have been an update in 2D then, is nicer than it was some days ago, I think it looks pretty much like 3D, except for a couple things, this just make me sadder 2D will disapear :( – herudae Jun 30 '12 at 4:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.