I have a Lenovo X1 i5vPro 2.50Gh x 4, which works fine with 12.04 LTS 64.... except the right click on the touch-pad, which I can live with.. However, I have just bought a Genuine Lenovo 39+ slice to extend usage.

If I boot with the slice attached I have two strange events:

  1. The battery shows as one battery so I can't tell the state of the internal batteries from the slice.
  2. If I then suspend by closing the lid when I open it again the screen is black with just the mouse pointer. I have tried just typing my password but it just sits there and does nothing.

If I boot with no slice attached all is well and works fine. If I then attach the slice the slice is detected and shows as another battery so can see the state of both. However, the time left is shown in % of charge and not time left before flat.

The other strange thing is that with the two batteries showing if I check the Power statistics they are shown as separate batteries with their own statistics. However, if booted with the slice on and showing only one battery attached the Power Statistics falters and show nothing despite the batteries both being there ans showing as 100% next to the Icon next to the BlueTooth icon.

  • Stranger and stranger. Having allowed the computer to run on both batteries for some time now. The batteries are now shown separately - the slice is shown as empty and 'not present'. The internal battery is shown as having 4 hours left..... Now time and not percentage? – Confused Too Jun 29 '12 at 11:50
  • Even stranger now. I became suspicious that the slice may be defective so dug out my orignial Windoze 7 HD and booted from it. No the slice is genuine and in good health, using Lenovo power management tools. The computer behaves correctly etc..... – Confused Too Jul 1 '12 at 15:02
  • when I re-boot to Ubuntu 12.04 with the slice attached it shows as one battery of 59wh maximum capacity. However, the system appears to drain the slice and when empty starts to drain the internal batteries. When this happens the batteries now appear as two batteries with the slice shown as empty and (not present)? The % also turns to time remaining. – Confused Too Jul 1 '12 at 15:05
  • I think Ubuntu 12.04 must be cooking my Slice. fully charged it is only lasting 1 hour but when that is exhausted it starts on the internal batteries which last 4+ hours. Both are 39+ cell components so should have identical discharge. – Confused Too Jul 2 '12 at 11:29
  • In Windozw 7 both batteries give about 9 hours life and discharge equally not one then the other? Has anyone looked at this or am I shouting in the dark? – Confused Too Jul 2 '12 at 11:30

For your problem with black screens when resuming, I suggest you keep an eye on this bug. It's currently affecting me on my ThinkPad X200, and I'm using GNOME Shell as a workaround while the bug is being fixed.


Since X1 Carbon hasn't gone retail yet, I'd be surprised if you get a lot of feedback on this issue. However, from the "i5vPro 2.50Gh x 4" description I figure you have the regular X1 (with glossy gorilla display) which should be "Ubuntu Certified" according to this.

From what I can gather from the internet (sorry no personal experience, hopefully with the X1C though!) no one else seems to experience the same problem. Have you tried the recommended 32-bit install? Or even an dist-upgrade?

  • You are correct it is a X1. I think I had just been reading about the Carbon and probably wished I had one.... LOL. – Confused Too Sep 4 '12 at 12:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.