I seem to have tried all the various suggested methods for installing ubuntu on a mbp, but can't seem to get anything that works and was wondering if anyone has run into any new problems with the latest non-retina models?

I have a core i7 in my macbook, and model identifier is MacBookPro9,2. I have partitioned my HD using disk utility and have 700gig free space ready for the install (I haven't removed OSX Lion, it is still there in a 50gig partition).


I am just getting a blank screen with a blinking cursor (unresponsive) in the top left whenever I boot from the disk. I left it for 20 minutes and nothing ever happened. This was without any boot manager, just holding "c" on startup.

Attempted remedies:

  • I have downloaded the 64 ubuntu iso from their site 3 times now and burned 4 separate discs to rule out some kind of corruption or burn error. I burned one in OSX Lion 10.7.4 and 3 on my windows 7 pc.

  • I tried holding "alt" instead and then navigating to the windows disc to boot. Same thing happens, blank blinking unresponsive cursor. I also tried going to the EFI disc which actually brings up a menu (after saying "error prefix is not set") asking if I want to install ubuntu, test for errors or partition. All three options lead me to an unresponsive blank screen (some without cursors).

  • I downloaded and installed rEFIt and if I hold "alt" on startup a linux penguin (Boot Linux from CD) appears in my boot options, along with the apple boot, and two others that I'm not sure of: "Boot EFI\boto\bootx64.efi from" and "Boot Legacy OS from". The "Boot Linux from CD" just takes me to the blank blinking cursor screen; again, I left if for 10+ minutes and nothing.

  • I heard that the detection of the graphics card might be a problem and that I need change to nomodeset, but I have tried pressing F6 in all of the boot menus listed above and no options appear.

Does anyone have any other suggested routes or can you see what I might have done wrong?


I am doing pretty much the exact same thing: 64-bit 12.04 on a 9,2 MBP.

In my case, the boot problem was fixed by adding noapic to the Kernel boot options. You will have to do this in order to boot the CD and again once you have 12.04 installed to the HD.

If you get past this point, you might experience additional problems that I see: the laptop gets extraordinarily warm and freezes every few hours.

Prior to installing 64-bit 12.04 I installed the 32-bit version, which seems to work better. I may go back to that or skip the whole project until support catches up with the bleeding edge hardware.

| improve this answer | |
  • @stariz77 does not even get to the linux kernel boot options, but it hangs when leaving refit, on booting grub. – cweiske Jul 29 '12 at 11:06

Your 9,1 15" notes will work for 9,2 13". According to wikipedia MacBookPro 15" 9,1 = MacBook pro 13" 9,2 MacBook_Pro Technical_specifications

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.