20

I updated Google Chrome from the Software Updater in Ubuntu 12.04, but it didn't actually update. "About Google Chrome " is still showing the previous release.

2
  • 1
    Chris, what version number are you seeing?
    – user25656
    Commented Jun 29, 2012 at 7:10
  • Here is more discussion on the subject: askubuntu.com/questions/886190/…
    – SDsolar
    Commented Apr 13, 2017 at 7:39

7 Answers 7

30

If you would like to keep you browser up to date, I think the easiest thing to do is to add the PPA. I will explain how to do this for both Chrome and Chromium. These two browsers are mostly the same, but you can check out the differences here.

Chrome

First you have to install the key. This can be done by opening Terminal and typing

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

Step two is to add the repository

sudo sh -c 'echo "deb http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google-chrome.list'

Then you update and, if you haven't already, install Google Chrome

sudo apt-get update
sudo apt-get install google-chrome-stable

Chromium

Chromium is more straight forward. Just add the PPA, update, and install by typing this in Terminal:

sudo add-apt-repository ppa:a-v-shkop/chromium
sudo apt-get update
sudo apt-get install chromium-browser
4
  • 1
    thank you. it works on my ubuntu 18.0 Commented Feb 27, 2021 at 6:40
  • 1
    after doing this I also had to go the Chrome -> Settings > About Chrome and re-launch (it doesn't work if you just close and start Chrome)
    – Maru
    Commented Sep 28, 2021 at 23:34
  • did not work for me, having added the key and repo, it still said Unable to locate package google-chrome-stable Commented May 28, 2023 at 20:22
  • I am getting this warning for the chrome first option: Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
    – Anyone
    Commented Jul 11, 2023 at 7:13
2

I had the same problem after upgrading to Ubuntu 22.04 because /etc/apt/sources.list.d/google.list was automatically disabled. I changed it from this
# deb https://dl.google.com/linux/chrome/deb/ stable main # disabled on upgrade to jammy
to this
deb https://dl.google.com/linux/chrome/deb/ stable main
and it worked again.

1

I had the same problem for Ubuntu 14 (end of 2015!): Chrome refused to update although all the required updates were done. The reason seems to be that there's still some background processes running even though Chrome is closed.

Close Chrome and just look up all "chrome" entries in 'top' and do 'kill 12345' where 12345 is the PID of each 'chrome' process. Then start the browser.

1
  • 1
    You should also be able to do a pkill chrome to get all the processes.
    – Cory Owens
    Commented Jun 18, 2020 at 15:11
0

Download the latest deb.

Google Chrome

Install it.It will add repository to your software source. After that you can update it via terminal when a update pack release. Via command

sudo apt-get update && sudo apt-get upgrade
1
  • 4
    sudo apt-get update does not install software updates. It updates the information about what software is available (including updated versions) and from where. To actually update the software (i.e., to upgrade packages to newly available versions), run sudo apt-get update followed by sudo apt-get upgrade. You may want to edit your answer to incorporate this information. Commented Jun 29, 2012 at 11:26
0

Same issue when upgraded to Ubuntu 22.04 from Ubuntu 18.04. Chrome fails to auto-update.

Similar to answer from bb1950328 but with different file in which I had to uncomment repo:

sudo vim /etc/apt/sources.list.d/google-chrome.list

### THIS FILE IS AUTOMATICALLY CONFIGURED ### # You may comment outthis entry, but any other modifications may be lost.

#deb [arch=amd64] https://dl.google.com/linux/chrome/deb/ stable main

To

### THIS FILE IS AUTOMATICALLY CONFIGURED ### # You may comment out this entry, but any other modifications may be lost.

deb [arch=amd64] https://dl.google.com/linux/chrome/deb/ stable main

after this change update and upgrade works also for chrome:

sudo apt-get update  && sudo apt-get upgrade
0

Follow the following command in your terminal as it is:

google-chrome --version

sudo apt update

sudo apt upgrade

sudo apt --only-upgrade install google-chrome-stable

Again check for the version and restart your chrome:

google-chrome --version

Tada! It might be helpful to you. I stuck in updating since long time it worked for me.

-1

Similar to H. Arponen's answer, my problem was caused by not closing down all instances of the previous version. However, mine was more different because I did not have any actual normal Chrome instances running, but I had a Chrome app running (Signal IM).

Versions:

  • Linux Mint 18 (based on Ubuntu 16.04)
  • Chrome 52/58
  • Installed via apt (apt-get)
  • Signal 0.38.2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .