I've been using wine from the ubuntu wine ppa for months now, but the last update 1.5.7 seems to be broken. I'm running ubuntu 12.04 x86 (32 bit).

When I try to run any application under any of the wineprefix I have installed in my $HOME I get this:

getting server_pid from lock 23758
wine: cannot get pid from lock (lock isn't locked)
err:process:start_wineboot failed to start wineboot, err 1359
getting server_pid from lock 23758
wine: cannot get pid from lock (lock isn't locked)

I can open winecfg in any of these wineprefix using wibom-gtk (a profiles manager) but wine seems to be ignoring any configuration like virtual desktop. Especially in the devices tab, where nothing appears:

"Failed to connect the mount manager, the unit configuration can't be edited" (not exactly these words, since I use the Catalan locale).

What I have tried, in my desktop and my netbook (the problem happens in both):

  • Removing my wineprefix and generating them doesn't work.

  • Downgrading tho wine 1.4 from the ubuntu-wine-ppa doesn't work.

  • Purging the ppa and downgrading to wine 1.4 from the ubuntu repository (not the wine one, but the official ubuntu default ppa) seems to work. But it let me stuck with an older version of wine without all the functionalities the latest versions have (better sound and directx support).

I'd like to know if this is a temporary mistake by some kind of error compiling the latest wine in the repo, or if the problem is related to my system.

Any help would be appreciated, thanks people!


It seems downgrading to version 1.5.5 works -- if you can downgrade.

However, I've found it easier (takes about 15 minutes) to restore my Ubuntu partition from the backup created by Clonezilla, which I regularly run to be on the safe side. And then used Synaptic Package Manager to Lock Version to 1.5.5.

EDIT: This problem is also discussed here: Err: processtart_wineboot failed to start wineboot, err 1359 Upgrading to the latest version 1.5.7-0ubuntu4-pulse18 now seems to solve the problems caused by the 0ubuntu3 version.

  • I WANTED to "downgrade" from 1.5.7: massive fonts, sluggish, missing labels. I was surprised that the "meta-package" in Software Center installs a development release by default. I can't confirm the errors you got with 1.5.7 unfortunately. But I can confirm that downgrading to 1.4 from the ubuntu-wine-ppa doesn't work. That had me running around in circles (from "can't connect to the devices manager" in config to a "cannot get pid from lock" error). Thanks to your information that the official ubuntu default ppa for 1.4 works I now have a working Wine 1.4
    – user73972
    Jun 29 '12 at 7:40
  • Thanks a lot. I've tried again to enable the ubuntu-wine-ppa and there's a new package compiled only a few hours ago:1.5.7-0ubuntu4-pulse18 Jun 29 '12 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.