My synaptic package manager in ubuntu10.10 is giving error:

  Unable to get exclusive lock
  This usually means that another package management application(like apt-get or  
  aptitude) is already running. Please close that application first.

Please resolve my problem for opening synaptic package manager

  • 2
    The error message generally means that you can only have one "Package Manager" open at a time. That includes apt, aptitude, gdebi, synaptic, software centre etc. Close all the "Package Managers" and try Synaptic again. If you still get the message something more serious is happening" – user4815 Jun 28 '12 at 16:20

I had the same problem. This post helped however, the pa aux command and the Kill command were ineffective. sudo rm /var/lib/dpkg/lock seemed to work, and I followed it up by another Linux post.

  1. You need sudo rights, so the full command is:

    sudo dpkg --configure -a
  2. Try using Konsole terminal program instead. Make sure that all package managers are closed! Issue the commands:

    sudo apt-get update  
    sudo apt-get upgrade

The sudo apt-get update command worked.

The sudo apt-get upgrade one did not as it stated could not get dns proxy.

Also the following came up:

some files failed to upload using old files.

At least the update was able to fetch 39 of them. The other is irrelevant as this is the latest Ubuntu 12.04 64-bit.

| improve this answer | |
  • You've posted this as an answer, and it's perhaps an attempt to answer the question here. But if you want help with the problems you had, you should post a new question to ask for that. Also, please note that you probably should have run ps aux rather than pa aux and kill rather than Kill. Terminal commands don't have any tolerance for incorrect spelling or incorrect capitalization. – Eliah Kagan Jul 8 '12 at 15:01

I had interrupted a sudo apt-get upgrade, and I was unable to get a lock on anything. I simply fixed it by running sudo dpkg --configure -a, and it let me pick up where I left off. Dunno if it helps, might as well share.

| improve this answer | |

As mentioned in the other answer, you have to make sure that no other package management software is running.

Open a terminal and type the following command

ps aux | grep program-name

where program-name can be apt, software etc. (just to find out if apt-get or Software Center are running). If you get entries for them, note down their process id. Let it be xxxx. Then give the following command.

kill xxxx

Now try opening synaptic.

If the problem still persists, give the following command in the terminal,

sudo rm /var/lib/dpkg/lock

Now synaptic should hopefully open.

| improve this answer | |

This error means that anoher Package Management Software is already running and using the files which for example contain the sources for the software. I would look for working processes like apt-get or aptitude with the system-monitor and exit them. Than restart synaptic and it should work.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.