My desktop is about 2 years old. It has "Intel G41 chipset" with "Intel Core2duo processor", 4GB DDR2 RAM.

I want to install Ubuntu 12.04 alongside Windows 7. I downloaded "ubuntu-12.04-desktop-i386.iso" file and burn it on to a CD. Then I inserted in it on my drive and reboot my desktop.

Installation started, but after passing almost half an hour, installation stopped. It showed error lines like this:

2816.493003 end_request I/O error,dev sr0, sector 1291668

When installation stopped, I re-inserted the CD and ran wubi.exe from Windows, then tried "help me boot from CD" option, but after 3-4 mins, an error message popped up saying "permission denied".

I also tried the option described in here, but same messages show every time. What should I do to install Ubuntu now?

3 Answers 3


I had the same problem and I solved it this way:

  • as far as the boot helper is concerned, I removed the failed helper installation and in the BIOS I set boot priority to cd
  • errors during installation were solved by burning the same iso on another CD after ensuring the correctness of its md5 hash; probabily the previous burning had some problems or the cd was not clean..

I hope that these solutions will help you..


Check the md5 hash of the iso file you have downloaded.

Install hashcheck shell extension in windows. Right click on ISO, go to properties and select checksum tab. Copy the md5.

Now open this page, press Ctrl+F and paste the md5. See if it matches the correct version.

If not possibly your download is corrupted and you need to redownload.

Also run wubi as administrator if you are using windows 7. There may be some permission problem if you are changing any file in c: drive.

  • Please let us know how it went.
    – Web-E
    Jun 28, 2012 at 10:37

That I/O error you're getting, it's because of a failing hard drive. Probably many bad sectors on it.

In the live session of Ubuntu, check out the SMART Status of your drive in the Disk Utility tool. If it shows 'A few bad sectors' or anything similar, you need to get a new drive.

If everything is fine, open Windows, Install hashcheck and check the md5 hash of the ISO file you've downloaded.

PS - I'd advise you not to use wubi. There are a few problems like no hibernation and slower disk rates, etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.