I had a problem while formatting Ubuntu.

I tried to reinstall without formatting the home directory and with the same username. The home directory of the new installation was set to be encrypted. Then the installation went wrong because of the cd. So it really never started (stopped at coping stage). How ever Ubuntu did encrypted the home directory but probably the procedure went wrong.

By now I installed Ubuntu in another partition, tried to mount with encrypted-recovery but the mounted directory in tmp wasn't the directory I had before. There were just strange directories with coded name.

Strange fact is that the file system is not damaged: it continues to know how much data is actually stored in it. If I look with gparted or even nautilus I see 45 Gb of data present on the partition. This let me think that my data are not erased but maybe hidden.

Moreover when I tried to mount the encrypted home directory with encrypted-recovery-personal it asked me the encryption secret. I insert nothing, just pressed enter, and the password was accepted.

Is there a method for removing my data? Maybe trying to re encrypt the directory? How could I get back to the previous documents.

Thanks to everyone

  • If you reinstalled without formatting your old encrypted /home then your data is still there. You can reinstall (again without formatting /home) choosing the same username and password according to this answer. To recover your data see this question. – Tom Brossman Jun 28 '12 at 8:21

You can find some answser in the eCryptfs Ubuntu doc : you have to reconfigure the automatic mount of your data.

strange directories with coded name

Is the actually encoded data.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.