I had a wired network connection that worked fine in Ubuntu 11.10.

I upgraded to 12.04 and immediately after the upgrade was completed, the OS reported my cable unplugged.

It was not unplugged and was not defective.

I have a D-link DFE-530TXS 10/100 ethernet NIC and I see what seems to be the generic 10050 driver loaded.

Is there any way to just flush anything and everything to do with the network configuration and have Ubuntu reset/find everything again?

If not, is there any way, I can get it to realize that my network cable is not unplugged? (considering it worked mere minutes before).

  • I assume you formerly used a different driver. Does the additional drivers program offer a familiar driver? Logs to check include /var/log/syslog and the udev log under the /var/log/ tree as well. Jun 28 '12 at 4:17

I had this problem on the latest 12.04 upgrade (I was already on 12.04, but an innocent-looking system update killed it).

Do you have settings for your interface in /etc/network/interfaces ? I have. This link may help: http://wiki.debian.org/NetworkManager#Wired_Networks_are_Unmanaged

In the end I un-installed Network Manager and it allows the standard /etc/network/interfaces stuff to work properly.


Sounds crazy, but:

  1. How are the LEDs on the physical connection? Nearly all have leds, and if no LEDs are present typically the cord/instantiating end are at fault.

  2. If LEDs are present- are they "solid" or blinking?

  3. If Solid? Probably a driver or hardware issue. Replace the hardware and troubleshoot. (frys electronics has a 15-day return policy. Just saying.)

  4. If Blinking? Must be driver/configuration related. Post a relevantly censored printout of the command:

    ifconfig -a

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.