Tried all the fixes here to no avail. Ubuntu Software Center opens fine, but when I attempt to click the Install button for any of the programs, no authentication pops up (as it does on my other 12.04 install) and nothing downloads. It flashes installing and then stops.

Under the Edit menu I cannot alter the checkmarks on tabs such as Ubuntu Software and Downloadable from the Internet. It lets me click the check mark and turns it right back off again.

apt-get from Terminal works fine for the same programs.

It seems like my permissions were locked somehow, but I don't know what directory it wants to download into and don't know how to fix it. Do I need to run Software Center as a super user?

This was an upgrade from 11.10 if that matters.


Try to remove Software Center, and re-installing it. to do that just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo apt-get purge software-center

and when that's done, do

sudo apt-get install software-center

Then do

sudo apt-get update && sudo apt-get upgrade
  • Purge and reinstall does not work. Running program from a terminal works; non-root cannot run either Update Manager or Software Center by default. Icons are there but everything appears broken when you try to run it without any request for authentication. Instead, run apps from terminal with 'gksudo' in front. So now every time I want to run these programs I use the terminal and everything is great. gksudo nautilus (run file manager as root) gksudo software-center (install software, when you click install it actually works) gksudo update-manager (run updates that actually install)
    – VidiMan
    Jun 29 '12 at 16:14
  • I wouldn't remove the software-center until I'd tried everything else. That would include sudo apt-get install --reinstall software-center.
    – Marc
    Jun 24 '13 at 0:55

the solution is very simple, just select the software you want to install, obviously the "install" button will not work, so instead click on File on the top menu, and click "Install", and see it will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.