When booting, lightdm dumps to tty. No GUI interface works- this is after a fresh install of Ubuntu 12.04 where the GUI interface works when running off the USB.

I have an NVIDIA Corporation G98 [Quadro NVS 420] graphics card.

After I call startx from the terminal it still doesn't work. I get the following in the Xorg.0.log:

[   327.718] (--) NVIDIA(0): Memory: 262144 kBytes
[   327.718] (--) NVIDIA(0): VideoBIOS: 62.98.6f.00.07
[   327.718] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   327.718] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[   327.756] (--) NVIDIA(0): Connected display device(s) on Quadro NVS 420 at PCI:3:0:0
[   327.756] (--) NVIDIA(0):     none
[   327.756] (EE) NVIDIA(0): No display devices found for this X screen.
[   328.010] (II) UnloadModule: "nvidia"
[   328.010] (II) Unloading nvidia
[   328.010] (II) UnloadModule: "wfb"
[   328.010] (II) Unloading wfb
[   328.010] (II) UnloadModule: "fb"
[   328.010] (II) Unloading fb
[   328.011] (EE) Screen(s) found, but none have a usable configuration.
[   328.011] 
Fatal server error:
[   328.011] no screens found


[+0.00s] DEBUG: Starting local X display
[+0.00s] DEBUG: X server :0 will replace Plymouth
[+0.02s] DEBUG: Using VT 7
[+0.02s] DEBUG: Activating VT 7
[+0.02s] DEBUG: Logging to /var/log/lightdm/x-0.log
[+0.02s] DEBUG: Writing X server authority to /var/run/lightdm/root/:0
[+0.02s] DEBUG: Launching X Server
[+0.02s] DEBUG: Launching process 1074: /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch -background none
[+0.02s] DEBUG: Waiting for ready signal from X server :0
[+0.02s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.02s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+1.38s] DEBUG: Process 1074 exited with return value 1
[+1.38s] DEBUG: X server stopped
[+1.38s] DEBUG: Removing X server authority /var/run/lightdm/root/:0
[+1.38s] DEBUG: Releasing VT 7
[+1.38s] DEBUG: Stopping Plymouth, X server failed to start
[+1.39s] DEBUG: Display server stopped
[+1.39s] DEBUG: Stopping display
[+1.39s] DEBUG: Display stopped
[+1.39s] DEBUG: Stopping X local seat, failed to start a display
[+1.39s] DEBUG: Stopping seat
[+1.39s] DEBUG: Seat stopped
[+1.39s] DEBUG: Required seat has stopped
[+1.39s] DEBUG: Stopping display manager
[+1.39s] DEBUG: Display manager stopped
[+1.39s] DEBUG: Stopping daemon
[+1.39s] DEBUG: Exiting with return value 1


X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-31-server x86_64 Ubuntu
Current Operating System: Linux oorn 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=b25ab072-077d-40f1-95a4-c7fd66acd2f0 ro reboot=pci quiet splash vt.handoff=7
Build Date: 07 May 2012  11:43:21PM
xorg-server 2:1.11.4-0ubuntu10.2 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.24.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun 27 12:51:45 2012
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) NVIDIA(0): No display devices found for this X screen.
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

 ddxSigGiveUp: Closing log
Server terminated with error (1). Closing log file.

1 Answer 1


Ok, so I figured out a solution- purge almost everything nvidia. First steps were through the terminal since I didn't have a working GUI. I followed http://peniwize.wordpress.com/2009/07/27/how-i-solved-my-nvidia-driver-kernel-module-api-mismatchj-problem/ Which basically boiled down to the following:

sudo nvidia-installer --uninstall
sudo rmmod nvidia
sudo find / -type f 2> /dev/null | grep -i nvidia | grep -i \\.ko | sudo xargs rm -f

sudo apt-get remove nvidia-current

Then reboot:

sudo shutdown -r now

That got a low resolution incorrect ratio (stretched) GUI going again.

Then once some GUI is back, get synaptic package manager and purge everything left with nvidia in the name EXCEPT for the nvidia-common that depends on ubuntu-desktop (there were two nvidia-common packages in my case). Everything else goes. Then restart again and presto it's my old desktop back at proper resolution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .