I don't get my multimedia keys (FN Keys) working. The Notebook is a ASUS N56VZ.

If I normally press the multimedia key combinations, nothing happens. If I try to get the keycodes while pressing, for e. g., Fn+F8 (this should turn volume up) with xev or acpi_listen started, there is no output at all. Only the Fn+F1 (Standby) and the Fn+F2 (Wireless on/off) combinations are working, but also, there is no output at xev or acpi_listen, while doing this.

What can I do here?

  • 2
    There are a couple of recent BIOS updates for your laptop - have you got the latest installed? – fossfreedom Jul 9 '12 at 12:04
  • I've tested this an updates my BIOS to the version which is the latest at the official ASUS N56VZ Driver page. AFter this update, still no success. – linuxrecon Jul 12 '12 at 15:16

I also have an Asus N56VZ.

Good news, you can have nearly all the Fn keys to work (all except the screen backlight control keys, don't know why)

Bad news, for the moment, you will have to wait for kernel 3.5 release or to modify source code according to what you can see here if you cannot wait.

UPDATE 11/19/2012

Good news, most of the Fn keys work out of the box since Ubuntu 12.10.

Another good news ! For the reluctant screen backlight control keys (F5 and F6), I have found this procedure. It originaly has been written for the Asus Zenbook Prime, but it works like a charm with the N56VZ.

UPDATE 04/07/2013

I recently upgraded my firmware to version 2.16. Unluckily, the fixasusbacklight workaround seems inefficient with this version. The screen backlight Fn+F5/F6 keys are no longer working. Anyway, this situation should be fixed by the end of the month with the release of Ubuntu 13.04. I have just tested the beta Live CD and everything works fine with it.

| improve this answer | |
  • I have N56VJ much similar to N56VZ.I have some sleep issues with ubuntu 12.10 on n56VJ, pls see this:goo.gl/uNOY0 do you also experience this issue at your end? – ashishsony Mar 6 '13 at 10:53
  • @Jean-Louis How did you apply the fixasusbacklight? What is your combination of Base Offset and DIDL & CADL offsets? For BIOS 2.12 I followed the procedure described in the link and found respective addresses to be 0xCA876018, 0x120 and 0x220. Unfortunately, this still doesn't work and no Fn+F5 nor Fn+F6. – Adam Ryczkowski Apr 3 '13 at 14:18
  • @adam-ryczkowski I don't have the same BIOS version. Mine is 2.11. For this version, the values you indicated are efficient. Did you try to apply the procedure indicated in the README to extract the DIDL/CADL offsets? – Jean-Louis Jouannic Apr 3 '13 at 17:00
  • @Jean-Louis Yes, I did. I edited three values in that script. BTW: When I use acpi_os= line in /etc/default/grub, I can adjust the brightness with Fn+F5/F6, (without the script) but only about upper 20% of it. And although adjusting technically works, Ubuntu is not aware of it; I can't catch the Fn-F5 key to bind it with xbacklight and there is no OSD notification about changing screen brightness. – Adam Ryczkowski Apr 4 '13 at 9:03
  • @adam-ryczkowski Well. I'm afraid I won't be able to help you. Maybe you can try to upgrade your firmware. As I mentioned above, with the last BIOS 2.16, no more workaround seems to be necessary. Every Fn keys work fine. – Jean-Louis Jouannic Apr 4 '13 at 9:23

According to Asus, this maybe an issue with the BIOS. They also said that according to responses from the BIOS team, the calling method of wmi evaluate method, returns ASUS_WMI_UNSUPPORTED_METHOD in new ASUS laptop PCs. This patch fixes it.1

As fossfreedom said, there are a couple of recent BIOS updates for your laptop. You need to make sure that your BIOS is up to date before attempting this fix.

I shared this file on dropbox, because I couldn't find it anywhere that doesn't require you to have a user name and a password.

So first you need to download the file asus-wmi-dkms_0.2_all.deb. Once you do that, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, navigate to the folder where the file got downloaded, probably the Downloads folder, and then run the commands below.

sudo apt-get install dkms
sudo dpkg -i asus-wmi-dkms_0.2_all.deb

I hope that this works for you.

Click here to download the file

1Source:Asus VIP Tech Support

P.S. Let me know if this works. Because if it doesn't I need to let Asus VIP support know. Thanks

| improve this answer | |
  • Do you know how to update the bios from ubuntu? I only have Ubuntu (and windows 7 in virtualbox, but I think I can not update the bios from a VM) installed. Thanks – fernando garcía Jul 16 '12 at 14:02
  • 1
    Take a look at this: ehow.com/how_7256759_update-bios-ubuntu.html – Mitch Jul 16 '12 at 15:16
  • I get a Error! Bad return status for module build on kernel: 3.2.0-26-generic (x86_64) when I run the dpkg command above. I have updated the bios to the latest version (N56VZ.204). – Keppil Jul 16 '12 at 21:58
  • Did you download the file? – Mitch Jul 16 '12 at 22:19
  • @Mitch: Yes, I upgraded the BIOS, then downloaded your file and ran the commands you specify above, which gave me a lot of output ending in the line in my previous comment. – Keppil Jul 17 '12 at 5:12

I have an ASUS N56VZ too.

To get the Fn Key to work I installed the kernel 3.5.3, everything but the Screen Brightness works perfectly. I'm pretty sure a kernel update is not necessary, if you update the module asus_wb_wmi will be enough I guess.

Other thing that is working now with this kernel is the Wifi led that wasn't working before.

| improve this answer | |
  • In a current Ubuntu 12.04 kernel 3.2.0-32-generic all function keys except Screen Brightness work fine. Do you know what a module is responsible for WiFi led ? – tommyk Oct 28 '12 at 15:27

Try to edit your Keyboard Shortcuts, as all of the multimedia functions listed above are available for input.

Go to System Settings, Keyboard, then click the Shortcuts tab. The functions that you are looking for are in the Sound and Media section, but you may also find some useful functions worth changing in other sections as well.

| improve this answer | |

It appears the function, multimedia keys are software routed; with the exception of the power functions, standby and wifi power.
IF you want those function shortcuts, you would have to manually create them in KB preferences: because they are not native extensions.

For example: My keyboard has completely seperate shortcut keys (its an old HP i found) and theres a button called "Shopping" that is a serperate code, and unmapped. So i set it to terminal.

If you go into keyboard settings -> Shortcuts tab: Does it let you map "Function + Fx" ?

| improve this answer | |
  • No, no way. I can't map with the FN+F1 keys, there are just not recognized. The only thing I can do is, to set the Volume Up / Down (for e.g.) with SHIT+Fx instead of Fn+Fx, but this isn't a real solution. – linuxrecon Jul 10 '12 at 6:27

I have an Asus N53SM, and all my FN+F* keys show up as making a keycode in xev. Make sure you have the xev window selected while you are testing out the keys. If your keys aren't producing a keycode, then there is no way for the XWindows system to know when they are pressed.

| improve this answer | |
  • I'm absolutely sure that the xev window was in front. Otherwise it wouldn't be possible to test other keys like 12345 with an output. – linuxrecon Jul 12 '12 at 15:17

I have an N56VJ and the last kernel update to finally has the screen backlight f6, F7 working. They are generating events in xev and I get the slider display at upper right. It will not change the brightness much though, the slider will only move down to about 90 percent. Is there a way to change the range?

| improve this answer | |
  • If you have another question, please ask it by clicking the Ask Question button. – Oyibo Nov 30 '12 at 14:18
  • I confirm, that in N56VZ, on one happy day, miraculously the Fn+F5/F6 started to produce keyboard events, brightness started to change and the OSD started to confirm it(!). – Adam Ryczkowski Apr 7 '13 at 9:01
  • 1
    You can manually change the brighntess level all the way down (to disable it altogether) by doing echo 23 > /sys/class/backlight/intel_backlight/brightness as a root. "23" is the desired brightness level. If you put "0", the screen will look blank. – Adam Ryczkowski Apr 7 '13 at 9:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.