3

I don't know if this problem happened when I installed Ubuntu before.

Recently I noticed that when I boot Ubuntu, the Digital Audio Output light automatically switches on. Digital Audio Output light on means "Something wrong in the headphone port". Although my headphone is working in Ubuntu.

I've heard that the headphone contains some magical "switch" that will fix the light problem. So I poked the headphone port with chopsticks, pens, paper clips, even my finger, and the Digital Audio Output light still stays on.

I don't have this problem in OSX.

How do I switch the light off?

2
  • 1
    It's not a warning light - it's the optical digital output, which also uses the headphone port. Still, it would be good if it wasn't on when you're not using it! Jun 27 '12 at 1:17
  • I thought it was! To me, everything that is bright and red is a warning sign. Anaways, do you know how to fix it? Jun 27 '12 at 1:24
5

This is the digital audio output (optical SPDIF), not a warning light. You should be able to turn it off with:

amixer set IEC958 off
2
  • Does this also permanently disable the optical output?
    – totymedli
    Jun 7 '17 at 9:36
  • 1
    @totymedli: it disables it, but not permanently - you can re-enable it at any time, using on instead of off. Jun 7 '17 at 23:30
3
  1. Open Terminal by Ctrl + Alt + T
  2. Type in sudo alsamixer
  3. Use the arrow keys to move around and when over S/PDIF press M to mute, this will turn the light OFF.
  4. Hit the Escape key - DO NOT CLOSE TERMINAL
  5. Type sudo alsactl store - This will make it persist across reboots
  6. Close Terminal
1

I would like to share with you how I solved this with a permanent solution without scripts. This way we can also get rid of the ugly pop sound when pulseaudio starts.

I use Apple MacBook 7,1 Mid 2010, White Unibody.

The reason why the red light lights up on every pulseaudio start is that there is automatic detection of hardware defined in /etc/pulse/default.pa

The usual default.pa example here: https://gist.github.com/95406ea115dc3a0a561f8242e2ae00f4

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif

When these modules are being loaded it automatically detects your hardware and also initializes it. While the hardware is being initialized then SPDI/F output is turned on so red light is glowing even if you previously toggled mute using alsamixser off. When SPDI/F are toggled again on then there is also the ugly pop sound effect.

To avoid this behavior I decided to define my hardware manually. I don't wan't use automatic hardware detection modules. I disabled them by commenting whole block:

### Automatically load driver modules depending on the hardware available
#.ifexists module-udev-detect.so
#load-module module-udev-detect
#.else
### Use the static hardware detection module (for systems that lack udev support)
#load-module module-detect
#.endif

Now, I need to define my audio hardware - output sink and input source. I have used module-alsa-sink and module-alsa-source. I also need to know which HW ID's my audio sources have. On my machine there is only one integrated audio card with both input/output which has id hw:0,0. It can be different on your machine.

This is how I load outpit sink and input source modules:

### Load audio drivers statically
load-module module-alsa-sink device=hw:0,0
load-module module-alsa-source device=hw:0,0
#load-module module-null-sink
#load-module module-pipe-sink

It's important to reload pulseaudio then. You can use: pulseaudio --vv --kill and then again start it with pulseaudio --vv --start

No we will have available both our audio input/output, the jack isn't glowing with the red and the pop sound on startup is gone. All changes made in alsamixer will always persist too.

But, with this simple configurations we can't now use SPDI/F as regular output. What if decide to play sound through it?

I can even define the SPDI/F output too. The SPDI/F has hw0,1 ID on machine. If I would like to use it again. I will add this line to my configuration:

### Load audio drivers statically
load-module module-alsa-sink device=hw:0,0
load-module module-alsa-sink device=hw:0,1
load-module module-alsa-source device=hw:0,0
#load-module module-null-sink
#load-module module-pipe-sink

With this configuration we can easily disable and enable it in alsamixer. And the configuration will persist.

Here is sample of my configuration I use: https://gist.github.com/7a11adf0edc49d55a60be071ca307784

Actually, I don't own any other kind of sound system so I'm not able to test it with it. If you are using 2.1 or 4.1 sound system the output will be probably played only as stereo and you will need add more configurations in order to get it properly work. The same problem could be with HDMI outpout, I can't test it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.