3

I'm using quickly and I can't seem to upload to my ppa. This is what I get:

$ quickly share --ppa swink/ppa
Get Launchpad Settings
Launchpad connection is ok
.........An error has occurred when creating debian packaging
ERROR: can't create or update ubuntu package
ERROR: share command failed
Aborting

I can create a package but I do get a warning:

$ quickly package --extras
........Ubuntu packaging created in debian/
............................................................................................................................................................................................................................
Command returned some WARNINGS:
----------------------------------
** (setup.py:26291): WARNING **: Error sending credentials: Error sending message: Operation not permitted
----------------------------------
Ubuntu package has been successfully created in ../unity-bookmarks_1.0-public4_all.deb

What could be the issue?

Edit:

when I run debuild -S, I get this: clearsign failed: secret key not available

Edit 2:

I even tried to setup a fresh pgp key, but I get exactly the same errors...

2

2 Answers 2

0

I have not used quickly so excuse the ignorance but...

When you are trying to create a source package with debuild, dpkg-buildpackage will go through and try to sign using gpg. If gpg is not setup properly then that will obviously fail, but also if your key's uid does not correspond with the changelog entry, it will fail to sign as well.

If you use debuild -us -S that will create an unsigned package. You can sign the files later for upload.

Ensure the changelog entry (email and name) match your key's uid. You can always set it in bashrc with DEBEMAIL and DEBFULLNAME entries.

You can verify the correct key uid using gpg --list-key

3
  • Though the quickly command doesn't work. This seems to be a valid "workaround" for me. Thanks :) Commented Jun 28, 2012 at 14:41
  • It's likely that quickly is not setup properly? maybe revisting 'quickly --configure' will work?
    – zoopster
    Commented Jun 28, 2012 at 19:12
  • I already tried that, I get the vague error: ERROR: configure command failed Aborting Something is definitely configured wrong.. Commented Jun 30, 2012 at 10:10
0

It sounds like you may not have your SSH & or your GPG keys setup properly. You should be able to see both of them from the account page on Launchpad ( off to the right side a little is where they should be when looking at your profile )

You want to make sure that they indeed are as thats how the Package mgmt authenticates that you can upload and also indeed made the packages your self.

Cheers!

EDIT:: More info to your updates ...

OK , and seeing your other edit , have you also ensured that DEBEMAIL and DEBNAME are correct in the environment as that will be used to fill in the change-log thus also what is used to look for a private key of the same email address, so make sure those match, as well as run "gpg --list-secret-keys" to make sure the one for your email does show up and then you can force it tobe used with debhelper by using the -k fag when building ( thats how package uploads are often signed when sponsored into debian so very common and documented well )

1
  • I'm able to see them on my launchpad page. So they should be set up correctly.. Commented Jun 27, 2012 at 0:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .