I've read several similar grub error questions and answers, researched on Google (a lot), but still have not found a solution to my problem.

I have an "old" notebook where I've installed Windows XP and then Ubuntu 8.04 - everything worked well for a long time. After the kids played with it (i.e. I have not seen what happened), I couldn't boot anymore. Grub simply said Error 17, and nothing else. After several Error 17 failures, the error changed to Error 18 - and this is the error it shows now.

What have I tried? I tried several Linux LIVE CD's and DVD's I have: Ubuntu 8.04, Kubuntu 10.04, Ubuntu 10.04, Ubuntu 11.10, Fedora 11, etc. - none of them is able to start, in all modes and options I tried (I have not manually edited the commands, but tried the provided options). I can't use the Live CD OS, and I can't install them either. This is important: it is ok to erase all HD contents! It is ok to format, repartition, lose all HD data - no problem.

In most of the Ubuntu flavours, including the 8.04 CD, the initialization stucks, showing repeatedly the following error messages:

ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata3.00: BMDMA stat 0x25
ata3.00: cmd 25/00:08:e5:a5:50/00:00:12:00:00/e0 tag 0 dma 1024 in
ata3.00: status: { DRDY ERR }
ata3.00: error: { UNC }

I also have tried the Windows XP installation CD. The recover command-line fails: fixmbr, fixboot, format - nothing works. If I try diskpart the partitioning tool tells me the HD is "unreachable" and if I try to continue a kind-of BSOD appears, giving me the only option to restart the computer.

If instead of the recover command-line, I try to install the system, the same diskpart thing happens in the partition selection step.

So, I downloaded and burned Rescatux into a CD. It can't start, saying:

Welcome to GRUB!

error: invalid arch independent ELF magic.
Entering rescue mode...
grub rescue> 

And I am left with this grub rescue prompt, which sounds good, but it is useless to me, since I have no idea of what and how can I do with it.

So, please, good and helpful souls who read my quest up to here: what can I type in this grub rescue prompt which can help me in the way of being able to boot again???

It is ok to me to format the HD, reinstall Windows XP, reinstall Ubuntu, repartition the HD, or eventually restore the damaged part and recover the dual boot ability. I just want to use my notebook again.


  • ls command gives me (hd0) (cd) reply – J. Bruni Jun 26 '12 at 22:21

From what you say, it doesn't sound like a problem with GRUB or any other operating system. GRUB is the first thing that is read on the hard drive, but it seems like you are having problems even reading the hard drive at all. It may be a hard drive failure on the laptop, which definitely happens eventually to any hard drive, especially laptops that move around while the drive is spinning and also have reduced airflow (especially when old and clogged up with years of dust inside).

But the fact that you are having trouble reading all of the CDs makes it seem like it might be something causing all the disks to fail, like a controller card or something. It's possible to have multiple failures at once, but seems unlikely.

If it was me, and I really wanted to resurrect the laptop, I would try to first take apart as much as I can and clean it out with a vacuum cleaner and perhaps compressed air, getting out as much dust as possible. Sometimes dust makes the cpu fan stop, and when that happens, all sorts of errors occur. I once had a computer where the fan had stopped, and I thought I had a virus, as it kept getting strange errors right away.

If you can't get a CD to boot properly, nothing else will work, though.

|improve this answer|||||
  • partitioning tool tells me the HD is "unreachable" For what my opinion is worth(grain of salt)? I have to agree with Marty here sounds like a hard drive failure or a control card, but I wonder if a control card failed, would you able to see the drives is the ls command? according to his comment to his question they are listed.... – TrailRider Jun 26 '12 at 23:29
  • @TrailRider: Sometimes failures are not total failures. But an overheating cpu can do things like that, too. I've seen some pretty clogged-up laptops in my time. – Marty Fried Jun 26 '12 at 23:48
  • true, that would explain the fact that he can find the drives but not use them....I was just wondering thanks for the reply. – TrailRider Jun 26 '12 at 23:54
  • 1
    Time for some feedback (better late than never)! In short: I changed the hard drive, and the problem was solved. I only bought this new HD after unsuccessfully trying to recover the existing one. I thought I was almost there using the "Samsumg" software found on UBCD (Ultimate Bootable CD) - the lost HD was a Samsumg one. Problem solved... but I really wanted to be able to use that HD, since it seems only a fraction of it was damaged. Anyway, thanks for your help and everyone else's answers and comments! – J. Bruni Aug 1 '12 at 13:25

8.04 is no longer supported ( on the desktop ). It also looks like your drive may be failing. Download the 12.04 cd, boot it up, open the disk utility and check the SMART status of the drive for errors.

|improve this answer|||||
  • But he tried so many other CDs, and none of them would work. Why would the 12.04 CD magically work where all the others fail? – Marty Fried Jun 26 '12 at 23:19
  • @MartyFried, the only reason the version matters is that you generally don't want to be using software that is hopelessly out of date. Whatever he tried before doesn't matter -- what is important now is verifying whether or not the disk needs replaced. – psusi Jun 26 '12 at 23:29
  • In another time and place, version matters. But in this case, he has already tried currently supported versions, and has been unable to even boot the CD. Downloading yet another unbootable CD is not a very constructive use of his time at this point, and won't help verifying anything if it won't start. Now, if he can get his system to read a CD, then I'll change my mind. – Marty Fried Jun 26 '12 at 23:46
  • Marty Fried is right... Indeed, I actually have a 12.04 CD now, which I downloaded and burned for installation in another computer. But for the laptop in question, even working fine, with its new HD, the "latest" LTS version it accepts is 8.04. Both 10.04 and 12.04 simply do not run in this "old" hardware. (I spent a whole day applying all imaginable tweaks trying to make 10.04 work on it, but it seems the required Linux kernel has issues with it.) Thanks, anyway. – J. Bruni Aug 1 '12 at 13:31
  • FWIW, I have a similar situation with an old Dell Inspiron laptop; it has an nVidia card that doesn't work with the open-source driver - causing partially readable text, and smeared cursor. It worked until 10.04, I think, but nothing seems to work with it now. At one point, I got it working with a downloaded nVidia driver, but it's hard to even get to that point, so I gave up and put XP back on, and I use it as a photocopier/fax system since my Canon scanner only works with windows. – Marty Fried Aug 1 '12 at 18:55

Give this a try if you are getting grub rescue:

  1. At grub>. enter these commands

    find /boot/grub/stage1

    This will return a location. If you have more than one, select the installation that you want to provide the grub files.

  2. This is important: what was returned for the find command use it in the next line for the "?" -

    root (hd?,?)

    Again use the value from the find command i.e. if find returned (hd0,1) then you would enter root (hd0,1)

  3. Next enter the command to install grub to the mbr

    setup (hd0)
  4. Finally exit the grub shell


Now you are done. Reboot the machine.

Another option is to run this command:

grub-install /dev/hda
|improve this answer|||||
  • 1
    Thanks! It may help someone else. I learned and played a bit with this "grub rescue" prompt. But my case was really a damaged HD, and the only workaround was substituting it. – J. Bruni Aug 1 '12 at 13:33
ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata3.00: BMDMA stat 0x25
ata3.00: cmd 25/00:08:e5:a5:50/00:00:12:00:00/e0 tag 0 dma 1024 in
ata3.00: status: { DRDY ERR }
ata3.00: error: { UNC }

Nothing to do with the grub for this error message. The error message you have obtained is purely related to the hard disk being used. There is a sector corruption in the hard disk onto which the information required by grub has been stored. So when grub tries to get the required information, it fails because of corrupted sector in the hard disk.

My suggestion, you can better change the Hard disk, because all the methods to recover this particular error will only work temporarily (Not even sure that the hard disk will recover from this error).

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.