Whenever I try to add a repository via the command line, I get the following error message:

Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 125, in <module>
    ppa_info = get_ppa_info_from_lp(user, ppa_name)
  File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 80, in get_ppa_info_from_lp
pycurl.error: (60, 'server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none')

Is there a way to remedy this situation?

  • Is your network using a proxy server? Jun 26, 2012 at 17:19
  • Not to my knowledge Jun 26, 2012 at 17:25
  • 2
    This is rather an error about Certificate Verification than Network Connectivity. Does the mentioned file /etc/ssl/certs/ca-certificates.crt exist?
    – mweinelt
    Jun 26, 2012 at 18:30
  • Yes, the file does exist Jun 26, 2012 at 18:53
  • Can people experiencing this problem connect to launchpad.net/api/1.0/~jsjgruber/+archive/ppa with Firefox and get a secure connection (locked padlock on the URL line)? What version of the ca-certificates package do you have (dpkg -s ca-certificates ? Output of ls -ltr /usr/share/ca-certificates/mozilla/Go* ? Does it help to upgrade the ca-certificates package and run sudo update-ca-certificates ? Aug 5, 2012 at 20:35

4 Answers 4


You need to make sure your date is set, the certificates have a valid from date and if your system date is 01-01-1970, all certificates will fail.

Use something like

date -s "Oct 9 05:16:00 UTC 2012"

then try again with add-apt-repository.


This kind of problem can be caused when there is something wrong with the central authority certificates on your system. These certificates are used to establish a chain of trust from someone Ubuntu or Mozilla trusts to a particular site when https: is used. The chain of trust starts with certificates installed as part of your Ubuntu system.

The problem might ordinarily manifest itself when you use a web browser to make a secure connection to a web site. In this case add-apt-repository is using the https: protocol to securily add a repository and its authentication keys. The current Ubuntu ppa repositories require a chain of trust from MakeDaddy.com to Canonical. If you use Firefox to browse to the same repositories using https: you will probably see an error rather than a closed padlock for the site, and clicking that will provide error messages indicating that the chain of trust cannot be determined.

Enter the following to reinstall the central authority certificates:

sudo apt-get install --reinstall ca-certificates

Another helpful command for this:

sudo update-ca-certificates

I used to this get this error when i used the command in the terminal, but when i added it from gui for the software sources it was added successfully. Try using the gui.

  1. Press start button and type software sources and press enter.
  2. Go to other software tab and click add button in the bottom
  3. Type the apt line of the repository and click add source and wait for a moment
  4. Go to terminal and type sudo apt-get update and that should be all.


NOTE #1 If you had previously tried to install the Netflix Desktop App via our terminal commands from the earlier post, we recommend running the line below in a terminal to clear out any unexpected errors BEFORE trying to install the Netflix Desktop app via the PPA method...

rm -Rf ~/.netflix-desktop

Worked like a charm!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .