20

I am trying to install VitrualBox's Guest Additions on Ubuntu Server 12.04, but keep getting an error. I am using the following command sudo ./VBoxLinuxAdditions.run --nox11 and get the following error:

enter image description here

4 Answers 4

20

I had the same problem when running the installer from the vbox additions iso, but running sudo apt-get install virtualbox-guest-utils worked fine. I did an apt-cache search virtualbox to verify the name of the package before attempting the install.

I did however, run the command suggested by Gregory above (as I was trying to get the installer to work from the iso, which it never did), but that may or may not have had an impact.

If you want to avoid the installing X11 dependencies use:

sudo apt-get install --no-install-recommends virtualbox-guest-utils && sudo apt-get install virtualbox-guest-dkms

Edit: See comment below.

4
  • 7
    If I would downvote if I could, installing virtualbox-guest-utils will install all X.org system, not wanted on a server. See Gregory answer for the proper way to install VBox additions.
    – CharlesB
    May 27, 2013 at 15:52
  • 9
    @CharlesB @JobiCarter Hm, but would apt-get install --no-install-recommends virtualbox-guest-utils && apt-get install virtualbox-guest-dkms work? Because virtualbox-guest-x11 is a recommends not a dependency: see dependencies.
    – ignis
    Jul 3, 2013 at 19:22
  • 1
    @ignis's solution is the correct one to avoid X dependencies. Sep 24, 2013 at 20:29
  • Worked fine for me too. Mark as correct answer.
    – Magno C
    Apr 23, 2015 at 16:38
15

I had the same issue. Install some additional packages and every thing will be fine:

sudo apt-get install build-essential linux-headers-$(uname -r)
2
  • I will try this. EDIT: Seems legit! Dec 13, 2012 at 3:42
  • 6
    You should add dkms package
    – CharlesB
    May 27, 2013 at 15:53
4

I had a similar problem and unfortunately none of the previously suggested solutions helped. What I did in the end was uninstall VirtualBox & install the latest version. This also meant that my version of the Guest Additions went from v4.1.18 to v4.2.4. Once I restarted my Virtual Machine created with the previous VirtualBox version, I was able to mount the guest additions ISO & run the VBoxLinuxAdditions script. You still get the error with the Window System drivers but that's to be expected with Ubuntu Server.

So I suggest giving an update of VirtualBox (and therefore the Guest Additions ISO) a try as well.

1
  • A similar upgrade from 4.1.18 to 4.2.10 worked for me as the other solutions didn't fix the problem.
    – agxs
    Apr 23, 2013 at 9:42
0

I would add to @ignis' solution: sudo reboot

After the ubuntu server restarts the Guest Additions will be available to you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.