When I shutdown or reboot my Ubuntu 12.04 it doesn't ever finish shutting down.

I end up stuck on a black/blank screen and have to hold the power button to shut it down.

Does anyone know where I can begin debugging this issue?

Thanks in advance

  • Have tried modifying Grub?
    – Mitch
    Jun 25, 2012 at 10:25
  • No haven't modified GRUB. Worked fine before upgrading to 12.04
    – darryn.ten
    Jun 25, 2012 at 10:28
  • contents of /etc/default/grub please?
    – Mitch
    Jun 25, 2012 at 10:35
  • /etc/default/grub doesn't exist for me (?)
    – darryn.ten
    Jun 25, 2012 at 10:42

6 Answers 6


By default, the latest ubuntu install (12.04.2, and few others behind) hides messages and shows a nice animated image (splash) in a fancy resolution.

To make sure to view the console and possibly see what's hanging behind that dark screen:

/etc/default/grub (edit & save):

# find line below and put a # in front of it
# and put this one:

Now update grub boot entries with these new defaults:

you@yourmachine:~$ sudo update-grub

And at your next start/shutdown process, you should see message lines with [ OK ] or [ ERROR ] or something wrong following it's title:

* Starting network shares                   [ OK ]
* Starting mysql server                     [ OK ]
* ...later when shutting down...
* Stopping mysql server                     [ OK ]
* Not Stopping something like it should     [    ]

nomodeset: You usually can toggle between the splash screen and the console messages with Esc key, but some video cards or lack of drivers can't handle the mode/capacities the boot process is using. nomodeset ensures it's using basic common capacities and makes sure you see messages (provided you don't press ALT-F1 to F7 during boot/shutdown to view other terminals than the one used for services startup/shutdown).

Edit: You can also try without nomodeset if you run into troubles starting X. GRUB_CMDLINE_LINUX_DEFAULT=""

  • Note that by doing this, you can also break your X settings and can result in your graphics driver not being loaded at boot. I would not recommend following bksunday's advice.
    – Will
    Sep 30, 2013 at 21:07
  • I find it hard to view all the logs and find out what isn't working during shutdown. Would have loved to see your advice on the issue! Edited my answer now. Better? ;)
    – bksunday
    Oct 1, 2013 at 12:54
  • Thanks for the prompt response. I am having the same problem as well and haven't found a fix it - adding nomodeset does not display the console messages at shutdown for me unfortunately. Once I find a solution, I'll post it. :)
    – Will
    Oct 2, 2013 at 15:15

You can find the logs at /var/log/syslog

Check the logs to get a better understanding of what is happening.

Also, try typing init 0 in the terminal.

  • Last 2 lines in syslog don't show anything suspicious: - kernel: Kernel logging (proc) stopped. - rsyslogd: [origin software="rsyslogd" swVersion="5.8.6" x-pid="1066" x-info="rsyslog.com"] exiting on signal 15.
    – darryn.ten
    Jun 25, 2012 at 10:29

I am somewhat new to Ubuntu 12.04 but I had used other versions of Ubuntu in the past. I have my account plus the guess account for my kids on this computer and if any of the account is logged in when the command to shutdown is given the computer will not even attempt to shutdown. The only way to shut it down if one of the account still logged is by logging out all accounts first and then providing the command from the login screen. I will shut down fine from terminal using the "shutdown -h now" command. Unfortunately I have still much to learn in order to attempt to correct this issue on my own.


I can't comment, so I'll post this as an answer:

I had the same issue on my 12.04 recently; in my case, it was due to one program (in my case pcscd) that wasn't stopped properly at shutdown and caused a 'cpu-lockup'. So, to turn of the splash screen (the ubuntu with the five dots):

  • hit 'escape' when you shutdown your computer.

  • you can disable splash in GRUB, but since you don't have that...

What messages are displayed on the screen? (look for something like "some process PID locks ..." (I forgot what the exact terms are...). If necessary, you can take a picture and post it here.

If you can confirm a process not being stopped normally, we can proceed by stopping it at shutdown via runlevel commands


I solved this problem by logging out first, then shutting down from the login screen. Shutting down without logging out first was resulting in a black screen, but with the power on the computer still on. I have Ubuntu set up with only one user so I'm not sure what's causing this problem. I haven't had a look to see if there are any processes running that are preventing shutdown as I'm very new to Linux and I don't actually know how to do that. A bit of searching will probably reveal the solution but if anyone can enlighten me here that would be great.


I did have this problem and still have it in one way, but some improvement has occurred. Until now, I had to press for a few seconds the start/shut down button from my Easynote ENTG71GM Packard bell /ACer. Ubuntu 14.04 LTS. Previously W8.1 but after having a pop up bothering me to install w 10 for free I did the big mistake to install it. Since I couldn't make W 10 to find my mejl and contact from W 8.1 I decided to try on Linux.

I did try every solution offer in different forum. None of them gave any result. I did follow steps like different codes in terminal, working on bios etc. I cannot state her every try for I am totally new. However this problem forced me to understand a little bit of Linux. I couldn't figure out first what a terminal was... Så it wasn't in any case a waste of time.

My partial solution: I read on a thread that there was a problem with ELAN. I remembered that Windows 10 made me install some ELAN something. Sorry I don't know what it is. It didn't change a thing in W 10 so I forgot about it. Yesterday, I read the tread, Went on W 10, got read of ELAN and now my EasyNote shuts down properly when I reboot from Ubuntu.

The problem is that it reboots even when I chose to shut down.

However and since so many of you are helpful I thought that this I could spend some time to write this note. It maybe can be useful for somebody.

I will now try to solve the restart problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.