I am trying to set my wireless card into monitor mode. I am working with:

description: Wireless interface
product: BCM4312 802.11b/g LP-PHY
vendor: Broadcom Corporation
logical name: eth2

When I try to set it to monitor mode I get:

sudo iwconfig eth2 mode monitor
Error for wireless request "Set Mode" (8B06) :
    SET failed on device eth2 ; Invalid argument.

I also tried using:

$ sudo airmon-ng start eth2

Found 5 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID    Name
1094    NetworkManager
1096    avahi-daemon
1097    avahi-daemon
1167    wpa_supplicant
1720    dhclient
Process with PID 1720 (dhclient) is running on interface eth2

Interface    Chipset        Driver

eth2        Unknown         wl (monitor mode enabled)

$ sudo iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth2      IEEE 802.11bg  ESSID:"Redacted"  
          Mode:Managed  Frequency:2.437 GHz  
          Bit Rate=54 Mb/s   Tx-Power:24 dBm  
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=4/5  Signal level=-59 dBm  Noise level=-57 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:24  Invalid misc:0   Missed beacon:0

I've gone through various driver tutorials, but nothing is helping. Anyone know how to get this working for this specific wireless card?

3 Answers 3


The official Broadcom STA/wl driver DOES NOT support monitor mode

  • You are using the Broadcom STA (wl) official driver; this does not support monitor or promiscuous modes (regardless of whatever airmon-ng tells you.)
  • For this you need the b43 driver, which can be installed with sudo apt-get install b43-fwcutter firmware-b43-installer
  • You can unload one and load the other with sudo rmmod wl; sudo modprobe b43 (and vice versa).
  • Note that b43 and wl have their own advantages and disadvantages, so you may want to google before choosing one or the other.
  • Hey izx. I got installed b43-fwcutter, firmware-b43-installer. Then I tried sudo apt-get install b43-fwcutter firmware-b43-installer this stops my wireless card and iwconfig give no results. My wireless card is: Broadcom Corporation Device [14e4:4365] Could you pls help me Mar 23, 2013 at 15:45
  • The official Broadcom STA/wl driver DOES support monitor mode. See my answer below.
    – ssice
    Mar 26, 2013 at 16:52
  • @codeomnitrix sudo echo 1 > /proc/brcm_monitor0 enables monitor mode for wl. A new device name prism0 will appear, that's your monitor. Unfortunately, I seem to be having trouble deauthing - everything else works just fine.
    – Powerslave
    Dec 4, 2017 at 1:38
  • FYI I had to restart after loading and unloading a module for the new one to work
    – Escobar5
    Apr 29, 2020 at 19:45

The above answer is not true. At least, from version (I think that is from year 2007 or so).

The official Broadcom STA/wl driver does support monitor mode

However, it's not standard the way it does, so in order to enable it you have to do the following:

  • You have to type in a 1 to the file /proc/brcm_monitor0. You may do this via the following shell command: echo 1 | sudo tee /proc/brcm_monitor0.
  • It will create a new interface. The interface is called prism0, and not mon0.


In my case, I can't set b43 up, and whenever I actually get the kernel to load it, my connectivity will drop to unusable, dropping most packets.

I hate wl not being free, but I can't use the b43 alternative in my BCM4322.

  • hey ssice, i tried to change file to contain 1 but I am still not getting any new interface as you mentioned. could you pls help me. my wireless card is Broadcom Corporation Device [14e4:4365] Mar 23, 2013 at 15:50
  • Might it be related to superuser.com/questions/454784/… ? It seems to me that your card does not have as good support. Doesn't the new interface show up in programs like wireshark?
    – ssice
    Mar 23, 2013 at 18:21
  • Hey although it don't show up but still I am able to use airodump on this interface. thanks. But one strange thing happening all the time I turn on monitor mode from /proc/brcm_monitor0 when i got to turn that off, it just crashes the system and some dump screen comes. Mar 24, 2013 at 17:08
  • I don't know. In my config it doesn't, but if you are using the driver that is in my link above (there's the link to the README), I don't see your card in the list of supported devices. Maybe that particular opcode for turning off the monitor mode is not well handled.
    – ssice
    Mar 25, 2013 at 15:51
  • Ya it is not listed over there, could you please help me how to turn off monitor mode my card is: 14e4:4365 Thanks Mar 26, 2013 at 4:27

If you choose to use non official drivers, pay attention that it doesn't support all cards. Check it here: http://wireless.kernel.org/en/users/Drivers/b43#Supported_devices

For example (not supported): Broadcom Corporation Device [14e4:4365]

Check your card:

lspci -vnn -d 14e4:

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .