I recently download Ubuntu 12.04 LTS onto my Macbook Pro 5-5. Everything worked seamlessly, save for the brightness control. I couldn't change the screen brightness from the hardware buttons, nor from the system preferences.

To fix it, I used the instructions here: MacbookPro 5-5 LCD Brightness Control

At #2, I restarted my laptop, only to see that it went straight to the Ubuntu Startup Screen, with the 5 orange dots (Usually they all startoff white, then turn orange to indicate progress). From there, I tried controlling the brightness from the keyboard, and it worked, but sadly, my computer is still stuck on the loading screen.

(Yes, I have tried manually restarting it)

Could you please help? Thank you in advance

  • Have you tried to wait it out for a long while? Every so many boots the system will check your file systems, which will delay start up. Could this be the problem you are experiencing? – John S Gruber Jun 25 '12 at 4:16

Sometimes the graphical login hangs, while you could read an errormessage in the commandline, which indicates to hit the S or the Enter key, which isn't propagated to the graphical login.

So you can watch you HDD-led (Macbooks have such a thing too, do they?) to settle, which indicates, no loading and logging is going on and just hit those keys for good luck, keeping an eye on the LED to check if it has influence.

Or hit Ctrl+Alt+F1 (or F2, F3, ... F4) to get to the pure text screens. F1 should show the logging messages, with error cause as the last message(s). Alt+F7 (maybe F5) will bring you back into the graphical mode.

Or edit grub while booting, hitting e will give you an edit line, there you can remove 'quiet' and 'splash' from the kernel options. This will keep you longer in touch with the messages, and maybe you can read more about the cause.

Next option: Boot from a live cd, mount your system, and read the logfiles in /var/log, most recent files first, boot.log, kernel.log, syslog.

Afaik, Grub has a minimal HDD-access build in, so maybe you can even inspect logfiles from the grub bootscreen, but I don't know from my heart what key to hit, to do so. But there should be a help message, which get's you started.

| improve this answer | |

I had the same problem, except I was not using a mac. My problem, and most others that I have seen on the net have been derived from video card drivers.

For me, I could not install at all. So what I did was during installation. At the menu screen (try out, install ...) I hit F6, and added nouveau.blacklist=1 to the end of what's already there, and then let the rest fall into place.

For me it worked. I hope that can help you in some way!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.