I'm trying to copy/move files to an external 1 TB hard drive with about 50 GB remaining space. I receive a "no space left on disk" when I try.

I've moved files off and retried, but still get the same message. Disk Usage Analyzer, Properties, and freeware Treesize all report available hard drive space of about 50 GB. I've tried df -i (50 GB available) and df -k, with the latter reporting only 1% of inode usage.

I've been able to save files from Firefox to the drive also. I can't even rename files without getting the message. Yesterday in the midst of trying to figure this out I tried to move 4 files to the drive and got the message. Today, I found them on the drive. What's up with that? (That's the only time that has happened to my knowledge.)

Is this an Ubuntu problem? or is my hard drive just about to fail because of something like a controller problem?


You have 5% reserved space on your drive, which can only be used by root. Either you free more space (as you cannot use the 50GB as a normal user), or you tunefs the filesystem to not reserve these GB's for root.

  • Thanks for the reply, but I don't think that's the problem. I've had the drive as low as 5 GB of free space without problem and have been alternating between that and 20 GB for most of the last several months. This just started when I was at 16 GB free; I've since freed up the extra space I have by moving stuff off. Like I wrote, I even get the message when I try to directly change a file name, but I've also used a Windows program known as "Bulk Rename Utility" under Wine to change multiple file names at once without getting the error message. Something else is wrong. – Ned Jun 24 '12 at 20:11
  • What does mount output for that drive? – jippie Jun 24 '12 at 20:18
  • I'm pretty much a Linux noob, but this is what I got using mount in terminal: /dev/sdc1 on /media/My Book type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=512) – Ned Jun 24 '12 at 20:24
  • I think it is an NTFS filesystem, best to get into Windows and do a thorough check on the drive. – jippie Jun 24 '12 at 20:28
  • I'm certain it is NTFS. Ok. I'll do that. Thanks for the suggestion. – Ned Jun 24 '12 at 20:29

OS is depending of H/w configurations when installed in Intel chip set MB s/ms its getting a message box with Ubuntu 12.04 Internal Error it freequently comes then when updatiing applications hard disk size is increasing freequently and hard disk becomes full 100 kb download shows 1 GB increase when hard disk becomes full OS crashes pen drive not gets detected

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.