Possible Duplicate:
WI-FI doesn't work (Hard Blocked)

I'm new to linux and i am having trouble getting my wireless to work

I've found the following things

 Wireless LAN
    Soft blocked: no
    Hard blocked: yes

and :

*-network DISABLED      
       description: Wireless interface
       product: RT3090 Wireless 802.11n 1T/1R PCIe
       vendor: Ralink corp.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 00
       serial: 6c:62:6d:19:38:b9
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt2800pci driverversion=3.2.0-25-generic-pae firmware=0.34 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdfe0000-fdfefff

Can you please tell me what to do?

marked as duplicate by Marco Ceppi Jul 5 '12 at 14:10

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    Turn on the hardware switch for your wifi adapter. – RobinJ Jun 24 '12 at 13:49
  • What model is your laptop, as robinj says, hard block refers to a real life hardware switch. If you can tell me the model I can look it up. – 0x7c0 Jun 24 '12 at 14:46
  • MSI CR630 - this is it – Cristian Jun 24 '12 at 22:21


rfkill unblock all

..or what RobinJ mentioned, try the hardware switch on your laptop:

hardware wifi wireless switch

  • robinJ thanks but i believe that if i were able to give you that much info from the terminal than i am able to find which are the keys for turning on my wlan. Unfortunately already tried it and it doesn't work. It doesn't look like the one in the picture provided by medigeek but i have FN+F10. (It didn't work but FN+-> works in controlling the audio level) – Cristian Jun 24 '12 at 14:40
  • And i tried with rfkill unblock all ----> no succes – Cristian Jun 24 '12 at 14:41

For the problem with the wireless network my laptop msi cr630 has as a hard unblocker the Fn + F8 . Problem solved sorry to bother you :D

  • You could mention your laptop brand and model, so that other users could benefit from this answer as well. – Savvas Radevic Jun 25 '12 at 4:57
  • sorry new to this kind of things MSI CR630 – Cristian Jun 25 '12 at 21:47

I found this and it worked for me.

This is how to get the wireless hardswitch to turn on using the terminal:

sudo apt-get remove bcmwl-kernel-source
sudo apt-get install firmware-b43-installer
sudo apt-get install b43-fwcutter

Then enter this command to turn it on:

cat /etc/modprobe.d/* | egrep '8180|acx|at76|ath|b43|bcm|CX|eth|ipw|irmware|isl| lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3 |rt6|rt7|witch|wl'

Reboot and see if it stays on.

Not the answer you're looking for? Browse other questions tagged or ask your own question.