Blender and Stellarium aren't working for me in Ubuntu 12.04 (Precise). But blender was working is the previous releases of Ubuntu. I think this is because Precise's drivers for my graphics card don't have 3D support.

When I try sudo apt-get install nvidia-96 I get this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-96 : Depends: xorg-video-abi-10 but it is not installable
             Recommends: nvidia-settings but it is not going to be installed
E: Unable to correct problems, you have held broken packages

I did some googling and saw various solutions about downgrading X, adding PPAs, etc., but the problem didn't seem to be solved and I don't know what to try.

How do I get 3D drivers for my card?


I think your best bet is to go with Noveau


See the answer by cascade9

Here is a matrix of what features are implemented. http://nouveau.freedesktop.org/wiki/FeatureMatrix

  • I've got xserver-xorg-video-nouveau, libgl1-mesa-dri and libgl1-mesa-dri-experimental installed, but it's still not working. Is there any additional installing/configuring required?
    – Hippo
    Jun 25 '12 at 12:01
  • You may need to edit your xorg.conf. It's in /etc/X11/xorg.conf and the section you need to modify/add is: "Device" See: nouveau.freedesktop.org/wiki/InstallNouveau
    – danjo133
    Jun 26 '12 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.