I would like closing the laptop lid to be a no-op. How can I do that?

14 Answers 14

up vote 260 down vote accepted

For 13.10 - 18.04:

To make Ubuntu do nothing when laptop lid is closed:

  1. Open the /etc/systemd/logind.conf file in a text editor as root, for example,

    sudo -H gedit /etc/systemd/logind.conf
    
  2. Add a line HandleLidSwitch=ignore (make sure it's not commented out!),

  3. Restart the systemd daemon with this command:

    sudo restart systemd-logind
    

    or, from 15.04 onwards:

    sudo service systemd-logind restart
    

See also: Ubuntu Server 13.10 now goes to sleep when closing laptop lid

  • 40
    This didn't work for me. What finally solved it for me was setting IgnoreLid=true in /etc/UPower/UPower.conf – Kimble Apr 2 '14 at 14:10
  • 4
    HandleLidSwitch=hibernate if you want your laptop to hibernate instead of doing nothing. – Salman Abbas Apr 18 '14 at 1:08
  • 6
    Aternative: sudo apt-get install dconf-tools, open dconf Editor application, go to org => gnome => setting-deamon => plugins => power – pbaranski Apr 26 '14 at 18:21
  • 6
    Worked for me on 14.04. – kroiz Jun 13 '14 at 7:36
  • 3
    I restart it using sudo service systemd-logind restart – Iacchus Nov 17 '15 at 14:29

For 11.04 and earlier:

Do nothing when laptop lid is closed (helpful when an external monitor is connected):

  • Alt + F2 and enter this: gconf-editor
  • apps > gnome-power-manager > buttons
  • Set lid_ac and lid_battery to nothing

alt text

OR

1.When on AC Power, do nothing when laptop lid is closed:
gconftool-2 -t string -s /apps/gnome-power-manager/buttons/lid_ac nothing

2.When on Battery Power, do nothing when laptop lid is closed:
gconftool-2 -t string -s /apps/gnome-power-manager/buttons/lid_battery nothing


Blank screen when laptop lid is closed (preferable when no external monitor is connected):

  • System > Preferences > Power Management
  • On AC Power (On Battery Power) > Actions
  • When laptop lid is closed: Blank screen

alt text

OR

1.When on AC Power, blank screen when laptop lid is closed:
gconftool-2 -t string -s /apps/gnome-power-manager/buttons/lid_ac blank

2.When on Battery Power, blank screen when laptop lid is closed:
gconftool-2 -t string -s /apps/gnome-power-manager/buttons/lid_battery blank

For 11.10 - 12.04:

You can select "Do Nothing" in the power settings. Open the dash (super key), search for "power" and then select the correct option in the dropdown. Note that closing the lid will actually turn off the screen though plus any external monitors:

enter image description here

If you move the mouse then any connected monitors will power back up with the laptop closed. This will then become the primary monitor.

  • 3
    Yes, but this doesn't seem to work. I think it's a bug in 12.04. – Thom Jun 17 '12 at 21:43
  • 1
    Works for me on Ubuntu 12.04.1 LTS. – Tgr Sep 6 '12 at 9:07
  • It is not working for me in Lubuntu 13.10 – Sandeep Jindal Feb 13 '14 at 17:45
  • working for my ubuntu 13.10 – Ashish Feb 17 '14 at 5:58
  • Any way to do this on the command line? No X server on my lucid machine... – Steve Kroon Aug 5 '14 at 15:17

Ubuntu 15.10 - Ubuntu 18.10

TLDR: Add IgnoreLid=true to /etc/UPower/UPower.conf

  1. In terminal do:

    sudoedit /etc/UPower/UPower.conf
    
  2. Change IgnoreLid to IgnoreLid=true

  3. Save and exit the editor.
  4. Restart the UPower service with:

    service upower restart
    
  • 1
    For me, this didn't work on Ubuntu 15.10, but following these steps here did: askubuntu.com/a/594417 – CrazyPenguin May 19 '16 at 16:19
  • 2
    This worked for 16.10. Thanks! – koukouviou Dec 19 '16 at 8:04
  • Perfect. This prevents my external monitor from going to sleep on lid close in 16.10. No more worries when closing it. – Andreas Mar 19 '17 at 21:35
  • Works for 16.04 - Prevents networks from disconnecting, which is the single most important issue for me. Thank you. – SDsolar Mar 4 at 7:56
  • This didn't work on Ubuntu 17.10 with Gnome. – James Ray Mar 23 at 7:07

11.04 and previous versions

Copying 1st given answer from: http://ubuntuforums.org/showthread.php?t=1319921&highlight=close+laptop+lid

In a terminal (Applications-->Accessories-->Terminal), type: gconf-editor

Navigate to apps-->gnome-power-manager-->buttons and set lid_ac and/or lid_battery to "nothing" (without the quotes).

alt text

I have 14.04.1 LTS, Trusty Tahr.

What doesn't worked for me:

  1. Open the /etc/systemd/logind.conf file in a text editor as root, for example,

    sudo -H gedit /etc/systemd/logind.conf
    

    Add a line HandleLidSwitch=ignore (make sure it's not commented out!),

    Restart the systemd daemon with this command:

    sudo restart systemd-logind
    
  2. Edit gConf

    When on AC Power, do nothing when laptop lid is closed:

    gconftool-2 -t string -s /apps/gnome-power-manager/buttons/lid_ac nothing
    

    When on Battery Power, do nothing when laptop lid is closed:

    gconftool-2 -t string -s /apps/gnome-power-manager/buttons/lid_battery nothing 
    

What worked for me:

Setting IgnoreLid=true in /etc/UPower/UPower.conf

  • Working at Xubuntu 14.04.3 i386. Xubuntu have utility Power manager but settings for closing lid not worked for me. This is registered bug? – Vitaly Zdanevich Aug 28 '15 at 23:36

There is a bug with some laptops and monitors that makes Ubuntu not honor the "do nothing" setting when the laptop's lid is closed. I have not been able to find a complete solution, but maybe there is something to do with this link where they hint at this file : /etc/default/acpi-support and using:

gconftool-2 -t string /apps/gnome-power-manager/buttons/lid_ac -s "blank"
gconftool-2 -t string /apps/gnome-power-manager/buttons/lid_battery -s "blank"

For Saucy:

Edit /etc/systemd/logind.conf and set HandleLidSwitch=lock to lock the screen on lid close (but not suspend), or HandleLidSwitch=ignore to not even lock the screen.

This is due to an upstream GNOME change. See GNOME bug 687277 for the rationale for this change.

  • Does ubuntu use systemd? – Khurshid Alam Oct 16 '13 at 19:38
  • systemd is now many things. Ubuntu does not use systemd's init ("pid 1"), but it does use components that were formerly independent but are now absorbed into the systemd source, such as udev. So you will see mentions of the systemd name on an Ubuntu system, but that does not mean that its init system has suddenly changed. – Robie Basak Oct 17 '13 at 8:14

11.04 and previous versions

you can also go to system->preferences->power management

near bottom of the window you will find a dropdown where you can select what your system does when lid is closed

12.04

In System Settings, open Brightness & Lock. On that page, uncheck the checkbox at the bottom that says, "Require my password when waking from suspend."

  • 1
    Tried this and it made no difference. – Thom Jun 17 '12 at 21:43

I like to suspend my laptop sometimes, and other times I like to keep it going for long times like a server (do nothing when I close the lid). I use Debian, and here's my simple script to do either one on the fly without rebooting:

# run this in the as the same user (or root) that xwindow is using

# test for required parameter --> empty not allowed
if [ "$1" == "" ]; then
    echo "Please provide true or false"
    echo "True means keep running when lid is closed"
    echo "False means suspend the computer when lid is closed"
    exit;
fi

# "running true" means keep running even if the lid is closed
if [ "$1" = "true" ]; then
    gsettings set org.gnome.settings-daemon.plugins.power lid-close-ac-action nothing
    gsettings set org.gnome.settings-daemon.plugins.power lid-close-battery-action nothing
fi


# "running false" means suspend the computer!
if [ "$1" = "false" ]; then
    gsettings set org.gnome.settings-daemon.plugins.power lid-close-ac-action suspend
    gsettings set org.gnome.settings-daemon.plugins.power lid-close-battery-action suspend
fi

# if "echo" is supplied as a param, just show the current settings
if [ "$1" = "echo" ]; then
    gsettings get org.gnome.settings-daemon.plugins.power lid-close-ac-action
    gsettings get org.gnome.settings-daemon.plugins.power lid-close-battery-action 
fi

# restart gnome to make changes effective
/etc/init.d/gdm3 restart

You can easily disable the lid lock feature by clicking the System Settings icon in the Launcher/Task bar, and then clicking on Brightness & Lock.

From there, you flip the Lock switch to the off position, and un-check the "Require my password when wakening from suspend." check-box.

enter image description here

Another thing you have to watch for if you also plan on setting up hibernation (suspend-to-disk) is whether or not your system has a large enough swap partition to actually go into hibernation. Hibernation is different than suspend, but sometimes people like to set up the hibernation feature while they are configuring suspend.

You can also go over your Power settings, so they don't suspend the system when the lid is close. You can do this in System Setting -> Power.

enter image description here

Let us create a script that works on all versions

#!/bin/bash

# PLEASE FEEL FREE TO CHANGE THE SCRIPT

# Ubuntu 16.04 [PLEASE COMPLETE]

sed -i '/HandleLidSwitch/d' /etc/systemd/logind.conf >/dev/null 1&>2
echo 'HandleLidSwitch=nothing' >> /etc/systemd/logind.conf >/dev/null 1&>2

# Ubuntu 14.04 [PLEASE COMPLETE]


sed -i '/IgnoreLid/d' /etc/UPower/UPower.conf >/dev/null 1&>2
echo 'IgnoreLid=true'>> /etc/UPower/UPower.conf

# [PLEASE COMPLETE ]

# gconftool-2 -t string -s /apps/gnome-power-manager/buttons/lid_ac [PLEASE COMPLETE ]
# gconftool-2 -t string -s /apps/gnome-power-manager/buttons/lid_battery nothing [PLEASE COMPLETE ]

# RESTART SERVICES

service upower restart
service systemd-logind restart
  • "HandleLidSwitch=nothing" does nothing useful. "HandleLidSwitch=ignore" is The Real Thing(tm). – Laszlo Valko Jul 5 at 11:17

For 12.10:

Edit /etc/UPower/UPower.conf and add IgnoreLid=true to the bottom.

This method no longer works in Saucy. I am unsure about 13.04.

  • Works on 15.04 64 bit after issuing systemctl restart upower. – KcFnMi Sep 9 '15 at 16:36
  • 1
    /etc/UPower/Upower.conf IgnoreLid=true on ubuntu 14.04 use to work. after the 3.13 kernel roll out it not longer works anymore – user493997 Jan 16 '16 at 17:48

protected by Community Jun 9 '16 at 4:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.