So, as a number of users seem to be experiencing, I am unable to change brightness on my laptop. Using the Brightness and Lock in settings, the slider moves but brightness does not adjust. The fn keys work for volume but not for brightness. I have updated my drivers and installed all updates, however the brightness is still at maximum.

I have heard that opening sudo gedit /etc/x11/xorg.conf and entering Option "RegistryDwords" "EnableBrightnessControl=1" can fix this, however when opening xorg.conf through Terminal I am greeted with a blank document... Not very reassuring.

Toshiba L750 Laptop

Nvidia Graphics Card

Dual boot with Windows

  • its /etc/X11/xorg.conf .. capital X. Also please post result of ls /sys/class/backlight/*/brightness . Is your system optimus enabled. what is output of lspci | grep VGA? – Web-E Jun 23 '12 at 14:27
  • For ls /sys/class/backlight/*/brightness I get: /sys/class/backlight/acpi_video0/brightness /sys/class/backlight/toshiba/brightness Unsure how to tell if Optimus enabled, as for lspci | grep VGA I get: 01:00.0 VGA compatible controller: NVIDIA Corporation Device 0dec (rev a1) – Raymond Standen Jun 23 '12 at 21:51
  • Please try the steps over here.. askubuntu.com/a/154562/35775 . Just adjust the paths accordingly. Let me know the result. – Web-E Jun 24 '12 at 4:56
  • Hi, I updated grub and rebooted however the brightness did not adjust. For both echo 1024| sudo tee /sys/class/backlight/toshiba/brightness and echo 1024| sudo tee /sys/class/backlight/acpi_video0/brightness I am met with Invalid Argument – Raymond Standen Jun 24 '12 at 7:14
  • you need to get the max brightness first. Please recheck – Web-E Jun 24 '12 at 9:34

Same problem on Sony Vaio VPCEH and Ubuntu 12.04. The fn Keys moving the brightness slider but not affecting the real brightness on screen.

I edited /etc/X11/xorg.conf (very simple file) and added the line:

Option "RegistryDwords" "EnableBrightnessControl=1"

I rebooted the machine and now it works! Thanks to all!


I myself have an L750 too and tried everything to resolve this issue and didn't succeed. But after weeks of googling i ran into this solution:


Take a look at this reference which doesn't exactly match your laptop but the issue is the same.

What I did is almost the same as it's written in the linked post. Only thing you should notice is that Ubuntu 12.04 has the 3.4.1 version of gnome settings daemon, however I still downloaded the 3.2.2 source because the method of the detection of your display is changed in 3.4.1 so you can't modify it as you should.

After installing the latest package of nvidiabl, applying the changes to gsd-backlight-helper.c, compiling it, copying it into the right folder and adding nvidiabl to /etc/modules brightness controll works for me.

Of course you have to switch "toshiba" with "nvidia_backlight" and not "sony".

Not sure if this will work for you though, because my graphics card isn't an optimus one.

I hope i could help.

  • Hi, I appreciate all the help with this but, after changing the xorg.conf a few times (and fortunately not breaking my computer as a result) my computer finally allows me to change brightness. My eyes are very thankful and I appreciate the help of the community (: – Raymond Standen Jun 28 '12 at 10:36
  • @RaymondStanden You can select this solution as the correct solution so people can benefit from this in the future – Suhaib Sep 30 '12 at 0:33

I have a Toshiba Satellite Pro L870 and the xorg.conf solution did not work for me. However, I remembered that in Ubuntu 8.04 it was possible to program what special actions the keys did. Well, here's how you can do this in Ubuntu 12.04:

  1. First install xdotool.

    sudo apt-get install xdotool
  2. Open System Settings (Applications->System Tools->System Settings in Gnome).

  3. Open Keyboard and go to the Shortcut tab.

  4. Click the "+" button at the bottom of the page and add the following shortcut:

    Name: Brightness Down
    Command: xdotool key XF86MonBrightnessDown

    Click "Apply".

  5. On the Shortcut tab click on the word "Disabled" to the right of the "Brightness Down" entry. Now press the key that should decrease the brightness on your keyboard - this was F2 for me but it may be F6 or even something else on your keyboard.

  6. Click the "+" button again and add the following entry:

    Name: Brightness Up
    Command: xdotool key XF86MonBrightnessUp

    Click "Apply".

  7. On the Shortcut tab click on the word "Disabled" to the right of the "Brightness Up" entry. Now press the key that should increase the brightness - F3 for me but possibly F7 or even something else on your keyboard.

Now sit back and enjoy the brighness, or darkness depending on which key you press.


I used Toshiba L735 with nvidia. I also have problem about brightness won't change. following these step can solve this problem.

1.open terminal 2.enter : sudo gedit /etc/X11/xorg.conf 3.entering Option "RegistryDwords" "EnableBrightnessControl=1" 4.I rebooted the machine and now it works! Thanks to all!

and these not working. you might also do these step below too.

1.install NVDIA 319 post-releases 2.go to terminal and type “sudo apt-get install xbacklight” 3.restart 4.go to terminal and type “xbacklight = 50”


I have Toshiba Satalitte L750. The solution that worked for me and also solved other graphical problem is to change to NVIDIA driver from "Additional drivers"

  • 1
    This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – Pilot6 Jun 27 '15 at 14:27
  • @Pilot6 This clearly is an attempt to answer the question. – Seth Jun 27 '15 at 21:45

it is iöprotant where you have add enablebrightness controll

it must ne in the section "device"

endsection ubuntu 14.04 fn brightness nvidia not working samsung r540

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.