I'm very new to Ubuntu. I wanted to move away from Windows because I've been learning Python for the last year and wanted to be on an OS that was good for Python development. Ubuntu and Python are rather simpatico, hence the move.

Well, as you might guess from the title, I've had a few issues involving the nvidia card. For one, I get a false positive GPU hang until I went and did this:

  • I ran sudo nano /etc/defaults/apport.
  • Editing this file, I set enabled=0.

This eliminated the error message and allows me to use the computer. But beyond this, I have also never been able to get the ancient GPU and Ubuntu to play nice.

I've tried two separate solutions, only to have the same thing happen both times; an unbootable computer. I've tried to:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates && sudo apt-get update && sudo apt-get install nvidia-current

I've also attempted to install the .run packages for nividia-173, and walking through the motions of killing the X server session and trying to install in this way, etc... They both lead to the same black screen on start up. I get a momentary purple screen, then nothing. I'm forced to restart with GRUB and when I do, slow computer is slow.

The thing of it is, even when I go back and "sudo apt-get purge" all the non-working things, I still reboot to a splash screen, momentary Ubuntu purple, and eventual black screen. So whatever it is that these drivers are going and doing once I let them snake in, they're doing a good job of borking everything right up, because uninstalling doesn't seem to matter one bit.

Now, I know I'm doing all this on an older box. It's a Dell Dimension 2400, running a 2.4 Ghz Celeron processor and 1 GB RAM, and I also know the graphics card is something of a dinosaur (to compliment the prehistoric computer, of course). So I'm willing to submit that maybe I'm just asking too much of an old bird. I'd post the exact specs, but I can't, because right now that computer is in the middle of the third re-install of Ubuntu 12.04 in two weeks.

I've also seen the nvidia issue seems to be pretty well-traveled by now, and honestly there's so much different information out there and varied results from the outcomes that honestly I don't know what to try right now, except just leaving the blasted thing alone and running it without the drivers.

The problem here is, I don't know what I'm supposed to know in order to troubleshoot this stuff, so I don't rightly know the right questions to ask, but at this point I'm wondering if I should just look into an older version of Ubuntu. The computer was running Windows XP until I decided to be bold and jump ship; it wasn't blazing fast, but it worked. And if my research and memory serve me correctly, this issue involving this particular configuration didn't pop up until, what, Ubuntu 11? If I roll-back to try and correct this issue, am I doing it weird?

I haven't written but five lines of code since I started mucking around with my OS. I did this so I could code more, not less. I'm frustrated and sad and annoyed that my experience with non-proprietary operating systems has thus far been fraught with bad drivers, three reinstalls, and a steep learning curve. Whatever advice the community has for me at this point, I'm all ears here.

EDIT: Got the old girl up and running. Here's my lshw:

description: Space-saving Computer
product: Dimension 2400
vendor: Winbond Electronics
serial: G7TBR41
width: 32 bits
capabilities: smbios-2.3 dmi-2.3 smp-1.4 smp
configuration: administrator_password=enabled boot=normal chassis=space-saving cpus=1 power-on_password=enabled uuid=44454C4C-3700-1054-8042-C7C04F523431
   description: Motherboard
   product: 0F5949
   vendor: Winbond Electronics
   physical id: 0
   version: A00
   serial: ..CN70821436B0UU.
      description: BIOS
      vendor: Winbond Electronics
      physical id: 0
      version: A05
      date: 12/02/2003
      size: 64KiB
      capacity: 448KiB
      capabilities: pci pnp apm upgrade shadowing escd cdboot bootselect edd int13floppytoshiba int5printscreen int9keyboard int14serial int17printer acpi usb ls120boot biosbootspecification netboot
      description: CPU
      product: Intel(R) Celeron(R) CPU 2.40GHz
      vendor: Intel Corp.
      physical id: 400
      bus info: cpu@0
      version: 15.2.9
      slot: Microprocessor
      size: 2400MHz
      capacity: 3600MHz
      width: 32 bits
      clock: 400MHz
      capabilities: boot fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe up pebs bts cid xtpr
      configuration: id=0
         description: L1 cache
         physical id: 700
         size: 8KiB
         capacity: 8KiB
         capabilities: internal write-back data
         description: L2 cache
         physical id: 701
         size: 128KiB
         capacity: 128KiB
         capabilities: internal varies unified
      description: System Memory
      physical id: 1000
      slot: System board or motherboard
      size: 1GiB
      capacity: 1GiB
         description: DIMM SDRAM Synchronous 266 MHz (3.8 ns)
         physical id: 0
         slot: DIMM_1
         size: 512MiB
         width: 64 bits
         clock: 266MHz (3.8ns)
         description: DIMM SDRAM Synchronous 266 MHz (3.8 ns)
         physical id: 1
         slot: DIMM_2
         size: 512MiB
         width: 64 bits
         clock: 266MHz (3.8ns)
      description: Host bridge
      product: 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface
      vendor: Intel Corporation
      physical id: 100
      bus info: pci@0000:00:00.0
      version: 01
      width: 32 bits
      clock: 33MHz
      configuration: driver=agpgart-intel
      resources: irq:0 memory:e8000000-efffffff
         description: Display controller
         product: 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device
         vendor: Intel Corporation
         physical id: 2
         bus info: pci@0000:00:02.0
         version: 01
         width: 32 bits
         clock: 33MHz
         capabilities: pm bus_master cap_list
         configuration: driver=i915 latency=0
         resources: irq:16 memory:e0000000-e7ffffff memory:feb80000-febfffff
         description: USB controller
         product: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1
         vendor: Intel Corporation
         physical id: 1d
         bus info: pci@0000:00:1d.0
         version: 01
         width: 32 bits
         clock: 33MHz
         capabilities: uhci bus_master
         configuration: driver=uhci_hcd latency=0
         resources: irq:16 ioport:ff80(size=32)
         description: USB controller
         product: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2
         vendor: Intel Corporation
         physical id: 1d.1
         bus info: pci@0000:00:1d.1
         version: 01
         width: 32 bits
         clock: 33MHz
         capabilities: uhci bus_master
         configuration: driver=uhci_hcd latency=0
         resources: irq:19 ioport:ff60(size=32)
         description: USB controller
         product: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3
         vendor: Intel Corporation
         physical id: 1d.2
         bus info: pci@0000:00:1d.2
         version: 01
         width: 32 bits
         clock: 33MHz
         capabilities: uhci bus_master
         configuration: driver=uhci_hcd latency=0
         resources: irq:18 ioport:ff40(size=32)
         description: USB controller
         product: 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller
         vendor: Intel Corporation
         physical id: 1d.7
         bus info: pci@0000:00:1d.7
         version: 01
         width: 32 bits
         clock: 33MHz
         capabilities: pm debug ehci bus_master cap_list
         configuration: driver=ehci_hcd latency=0
         resources: irq:23 memory:ffa80800-ffa80bff
         description: PCI bridge
         product: 82801 PCI Bridge
         vendor: Intel Corporation
         physical id: 1e
         bus info: pci@0000:00:1e.0
         version: 81
         width: 32 bits
         clock: 33MHz
         capabilities: pci normal_decode bus_master
         resources: memory:fd000000-feafffff memory:f0000000-f7ffffff
            description: VGA compatible controller
            product: NV34 [GeForce FX 5200]
            vendor: NVIDIA Corporation
            physical id: 4
            bus info: pci@0000:01:04.0
            version: a1
            width: 32 bits
            clock: 66MHz
            capabilities: pm vga_controller bus_master cap_list rom
            configuration: driver=nouveau latency=64 maxlatency=1 mingnt=5
            resources: irq:16 memory:fd000000-fdffffff memory:f0000000-f7ffffff memory:fea00000-fea1ffff
            description: Ethernet interface
            product: BCM4401 100Base-T
            vendor: Broadcom Corporation
            physical id: 9
            bus info: pci@0000:01:09.0
            logical name: eth0
            version: 01
            serial: 00:0f:1f:47:3b:3a
            size: 100Mbit/s
            capacity: 100Mbit/s
            width: 32 bits
            clock: 33MHz
            capabilities: pm bus_master cap_list rom ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
            configuration: autonegotiation=on broadcast=yes driver=b44 driverversion=2.0 duplex=full ip= latency=64 link=yes multicast=yes port=twisted pair speed=100Mbit/s
            resources: irq:17 memory:fe9fe000-fe9fffff memory:fe000000-fe003fff
         description: ISA bridge
         product: 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge
         vendor: Intel Corporation
         physical id: 1f
         bus info: pci@0000:00:1f.0
         version: 01
         width: 32 bits
         clock: 33MHz
         capabilities: isa bus_master
         configuration: latency=0
         description: IDE interface
         product: 82801DB (ICH4) IDE Controller
         vendor: Intel Corporation
         physical id: 1f.1
         bus info: pci@0000:00:1f.1
         logical name: scsi0
         logical name: scsi1
         version: 01
         width: 32 bits
         clock: 33MHz
         capabilities: ide bus_master emulated
         configuration: driver=ata_piix latency=0
         resources: irq:18 ioport:1f0(size=8) ioport:3f6 ioport:170(size=8) ioport:376 ioport:ffa0(size=16) memory:feb7fc00-feb7ffff
            description: ATA Disk
            product: Maxtor 6Y080L0
            vendor: Maxtor
            physical id: 0
            bus info: scsi@0:0.0.0
            logical name: /dev/sda
            version: YAR4
            serial: Y2G69FQE
            size: 74GiB (80GB)
            capabilities: partitioned partitioned:dos
            configuration: ansiversion=5 signature=0007c431
               description: EXT4 volume
               vendor: Linux
               physical id: 1
               bus info: scsi@0:0.0.0,1
               logical name: /dev/sda1
               logical name: /
               version: 1.0
               serial: 4783b86d-db77-401b-84cd-7c263eee6cd9
               size: 73GiB
               capacity: 73GiB
               capabilities: primary bootable journaled extended_attributes large_files huge_files dir_nlink recover extents ext4 ext2 initialized
               configuration: created=2012-06-22 22:45:10 filesystem=ext4 lastmountpoint=/ modified=2012-06-22 23:39:51 mount.fstype=ext4 mount.options=rw,relatime,errors=remount-ro,user_xattr,barrier=1,data=ordered mounted=2012-06-22 23:41:12 state=mounted
               description: Extended partition
               physical id: 2
               bus info: scsi@0:0.0.0,2
               logical name: /dev/sda2
               size: 1020MiB
               capacity: 1020MiB
               capabilities: primary extended partitioned partitioned:extended
                  description: Linux swap / Solaris partition
                  physical id: 5
                  logical name: /dev/sda5
                  capacity: 1020MiB
                  capabilities: nofs
            description: SCSI CD-ROM
            physical id: 1
            bus info: scsi@1:0.0.0
            logical name: /dev/cdrom
            logical name: /dev/sr0
            capabilities: audio
            configuration: status=nodisc
    *-serial UNCLAIMED
         description: SMBus
         product: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller
         vendor: Intel Corporation
         physical id: 1f.3
         bus info: pci@0000:00:1f.3
         version: 01
         width: 32 bits
         clock: 33MHz
         configuration: latency=0
         resources: ioport:eda0(size=32)
         description: Multimedia audio controller
         product: 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller
         vendor: Intel Corporation
         physical id: 1f.5
         bus info: pci@0000:00:1f.5
         version: 01
         width: 32 bits
         clock: 33MHz
         capabilities: pm bus_master cap_list
         configuration: driver=snd_intel8x0 latency=0
         resources: irq:17 ioport:ee00(size=256) ioport:edc0(size=64) memory:feb7fa00-feb7fbff memory:feb7f900-feb7f9ff

Hope that helps to make a proper assessment..

  • Before disabling Apport crash reporting, did you ever try actually reporting a bug from the crash (when the error came up)? If so, can you edit your question to include a link to the bug? Jun 23, 2012 at 23:49
  • I submitted multiple tickets, or at least I believe I did. The idea to disable the apport crash reporting came after Googling the problem and finding that other users were experiencing false positive GPU hangs while this was enabled. I don't believe any of my bug tickets came with a tracking number, or may I submitted incorrectly. It has occurred to me that these items might be related, if that's what you're getting after. Should I turn the crash reporting back on?
    – Stick
    Jun 25, 2012 at 22:06

3 Answers 3


I believe that this thread probably holds the answer: How to install drivers for NVIDIA GeForce FX 5200 on Precise

However, I want to make sure I do this correctly.

First of all, I'm not quite sure how to read the launchpad site: https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-173-updates/173.14.35-0ubuntu1/+build/3597638 - what do I grab, the binary or the built file? Do I want/need to do this through my browser, or would apt-get be better (and if it is, precisely what steps do I take to install this file)? Basically, how do I read this webpage and how do I know what to download?

Additionally, I've heard tell that nvidia's drivers "mutilate the free Xorg/mesa-stack beyond recognition" and make a hardware swap more difficult than they need to be. I don't see myself removing the card or really plunking much money into this old beast, so I don't think I care about this, but in the event that I need to undo whatever it is that I'm contemplating doing, what's the right way to do it? I'm pretty sure that if I'd just known a little more about what I was getting into the first couple of times around, I would not have needed to reinstall Ubuntu three times in a week.

I really, really like this OS. I just want to learn to use it right and not pebkac it into perdition.


The nvida 173 is not updated to work with 12.04. As from 12.04 its using new xorg server. I am suffering in same problem for old desktop pc which has nvdia chipset (NVIDIA GeForce 7050/nForce 610i). So until nvidia updates (it is not going to happen any sooner) you should stick to open source driver or consider to move to lubuntu. Or you can go back to oneric (ubuntu 11.10) at least.

Lubuntu working flawlessly and my old grandpa pc is very pleased with it.

If you are having black screen till now. Just remove all nvia-drivers. There should be an nvidia-uninstall utility if you have downloaded .run file from Nvidia server. Then remove the xorg file. Ubuntu will create one.

sudo rm /etc/X11/xorg.conf

  • Well, the trouble doesn't really start until I actually try to install the drivers. I can use the computer prior to trying any of this, but it tells me under System Settings > Details that my Graphics driver is "Unknown". I've seen a lot of other users that are reporting similar troubles with similar hardware, and some of them seem to have answers while others don't. I'm just going to be leaving it alone for now, since it doesn't seem to matter what course of action I take, it always ends up breaking the computer. I'm not keen on Yet Another Reinstall just now... :/
    – Stick
    Jun 23, 2012 at 21:56
  • yes , by default the open source nouveau is used so there is no problem. However it is bit laggy in such old system.
    – Web-E
    Jun 24, 2012 at 4:53

The good reassuring way to fix this issue is to replace some basic hardware to start with.

  1. Purchase a newer CPU than the original Intel 4 that came with the machine.(Upgrade CPU)
  2. Purchase 2-1 GB Ram sticks giving you 2 GB of RAM.
  3. Purchase 1 modern/newer video card of your choice to install into slot on motherboard.
  4. Replace 32 GB hard drive (if that's what you are currently using) with 40-80 GB hard drive or higher. (More GB the better).

Install all applicable mentioned hardware above into designated slots/inputs on machine and mother board then restart your machine.

After restarting your machine connect to the internet and let any automatic updates run and install (always do a restart when prompted to do so and allow the machine to restart during automatic updates process). This should install all and any or most of the up to date software drivers for the new hardware installed. After automatic update is finished restart and check for updates in the start menu. If any show run them and restart machine again.

With the upgraded hardware equipment and drivers updated and installed on your PC, it should run the 1024 by 768 true color and you should be able to adjust your resolution to what you want with no more video graphics issues.

God Speed Brother,


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.