Playing flash videos (youtube and standalone flash) gives me choppy audio and video.

It seems intermittent, I was playing youtube videos earlier with no problems ... now I can't.


  • 64 bit 12.04
  • Google Chrome 64 bit
  • Nvidia drivers from PPA
  • Flash plugin version:

Could anyone offer any advice? Thank you.


  • So, what have you done in the meantime? What else do you have running? Who is hogging the CPU? That's almost always the cause of choppy video, especially when you have a local copy cached. htop and atop are your friends. Jun 22, 2012 at 20:37
  • I have an i7 and a NVS 4200m, no one is hogging the CPU. I am running Blender, but that's Python and its single threaded. I am not doing any rendering. This is a problem in the OS/drivers/settings.
    – Constantin
    Jun 22, 2012 at 20:50
  • I'm running the same flash plugin and on a Core2, which is much slower than your box, yet I'm not having any problems. How old is your system drive? The original HDD in my system started slowing down and giving choppy access which blew performance out of the water - replaced it and everything's much better now. Jun 22, 2012 at 21:06
  • I specifically pointed out atop because it will show process exits which can kill your performance without otherwise registering activity. Jun 22, 2012 at 21:07
  • Hi Andrew, I would like to reiterate, this is not a hardware issue. The closest related hardware issue is the Optimus technology my laptop runs, but that is disabled... The problem lies in 12.04. I was running 10.04 perfectly a few days ago ... I don't know why I upgraded, I wish I hadn't.
    – Constantin
    Jun 22, 2012 at 21:10

9 Answers 9


I have experienced this too. Everything works fine but after a period of time, the sound becomes choppy in flash videos.

Restarting pulseaudio worked for me. To kill pulseaudio:

pulseaudio -k

To restart pulseaudio:

pulseaudio -D

Another way to do it, but you would be setting pulseaudio to be run a system wide daemon.

To do this, in /etc/default/pulseaudio, set:


Then run:

sudo /etc/init.d/pulseaudio restart

What I tried in the same situation was:

  • remove the flash plugin installed by firefox itself, install the one from the repository (apt-get install adobe-flashplugin). The problem changed (instead of slow and choppy it was now too fast and only clicks for audio).
  • try to use gnash instead, but the gnash packages in the repository seem to not install a firefox plugin at all.
  • switch youtube to html5, but the video I wanted wasn't available in WebM, and installing x264 and chromium didn't help either

In the end, I used the DownloadHelper addon to simply download the video (but that is of course a VERY ugly solution for only a few use cases.


Some people in forums suggests to right click->settings->display and disable hardware acceleration.


Disable hardware acceleration by right clicking in flashplayer window >settings>un-check hardware acc. I had terrible playback and frequent crashing in both chrome and firefox. Was impossible to watch anything. Simply right clicking and on the flash player and disabling hardware acc. FIXED jerkiness right away. Now seems playback smoothness depends on CPU load. TRY FIRST!! Less crashing already.

UBUNTU 12.04, NVidia 6600GT, Accelereted Graphics Driver 304-update


I had the same problem with choppy audio and video. I ended up downgrading to flash player 64-bit, which you can find at adobe's archived flash players page

  • Can't wait to try this tomorrow, thank you for the tip! I'll keep you posted.
    – Constantin
    Jun 25, 2012 at 0:48

Try using the alternative Flash player:

sudo apt-get -y install browser-plugin-gnash

If your video shows blueish, right click the video and click Settings. Turn off video acceleration.

I hope I understood your problem and my answer helped! Good luck!


Chopping audio usually is the results of 2 things...

1)faulty hardware acceleration support for flash player. If that is the case just disable it as indicated above.

2) aggressive cpu power throttling. To diagnose that:

sudo apt-get install cpufreq-utils


sudo cpufreq-selector -g performance (this will change the cpu throttling governor from "ondemand" to performance.

Now check to see if your problem is fixed.

Also... cranking up the sound quality settings in pulse audio might also help:

sudo nano /etc/pulse/daemon.conf

Scroll down where it says default-sample-rate and change it to 48000 (dont forget to remove the semi-colon !! ) Also if you have a relatively good cpu you can improve the audio quality a little more by moving a few lines up, to the "resample-method" line and change the speex-float number to 5 . Ctrl+o and ctrl+x to save and exit. Restart pulse audio or the whole system for the settings to kick in.


After trying jlynch's suggestion and getting "Daemon startup failed", my solution was to follow the instructions here to disable timer-based scheduling and restart Pulseaudio.

I am on Ubuntu 14.04 w/ flash


Actually this is silly but have you tried with lower volume? I got the same symptom. Just to emphasize, the symptom was not distorted audio, it was choppy (mute/unmute type of effect). And as many songs have an in crescendo structure, the song will start fine and will get choppy. That was my case.

If that solves it, you may simply lower the volume control (the bar in the sound controller to 100%, not the volume per-se, although both are related).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.