I'm kind of new to this, so please stay with me. I have an ubuntu laptop from system 76. I keep it relatively up-to-date, and last night it prompted me to upgrade to 12.04. I started the upgrade and went to sleep. When I woke up, it had finished downloading packages, and looked like it had just started installing. A few hours later, it was in the same place and everything seemed totally locked up. AFter about 3 hours of no movement, I decided to risk a reboot. Well, it didn't go so well.

I've entered some sort of recovery terminal and hope there are some magic commands I can enter to finish the upgrade.

In the meantime I started a download of Ubuntu 12.04 LTS on another computer.

What do I do from here? If I end up needing to use the downloaded installer, how can I finish the upgrade using that? I have some very important files on this computer. Though they are backed up, it would still be a tremendous hassle if I can't access them.


EDIT: If I need to go the use an installer file route, I'm downloading the file on a Mac. Can I just follow the instructions on the website to put it on a flash drive, or since I hope to use it to boot an Ubuntu computer do I need to go about things differently?


The easiest route to a working computer is probably going to be a new install from CD or USB.

  1. Download the ISO
  2. Follow the instructions on the download page for burning it to USB/CD.
  3. Boot into it, pick Try Ubuntu
  4. Run around and rescue your old files. Stick them on an external disk or transfer them over the network. Whatever works for you, just keep them safe.
  5. Then run the installer from the desktop.

By the time you get to the installer, you could choose to just install over the top (without wiping anything). This might work. It might not. Either way, you'll be left with cruft from the past install.

I would just nuke the disk and do a completely fresh install and 20 minutes later when it's finished installing, just copy back my backed-up files.

Alternatively, if you like pain without the guarantee of success you can try fixing it:

  1. Hold shift when booting to enter the grub menu
  2. Select the rescue mode option
  3. Select the root prompt with networking
  4. Remount root with this: mount -o remount,rw /
  5. Run dpkg --configure -a to finish the installation process. This assumes this part had started before it crashed. If it was still downloading packages it probably wouldn't have broken the entire system.
| improve this answer | |
  • THanks for the help! I have a quick question, I tried going the pain without success route, and holding down shift doesn't do anything. When I run the Grub tool in the recovery boot option, I get the error "cannot create /boot/grub/grub.cfg.new: Read only file system. Also, I have a second hard drive in this laptop that I used the Ubuntu backup tool to backup to. Does this in anyway help me? – AbJH Jun 22 '12 at 17:45
  • When I run from the install disk and go to install Ubuntu I am given three options, Install Ubuntu 12.04 LTS Alongside Ubunutu 12.04 LTS (It says this computer currently has Ubuntu 12.04 LTS on it) Erease Ubuntu 12.04 LTS and reintsall Something Else – AbJH Jun 22 '12 at 17:50
  • I tried using 'boot-repair' and though I updated the PPA it says "Please Enable a Repository con tainting the [grub-pc] packages in the software sources of Ubuntu 12.04 LTS (sda1). Then try again." – AbJH Jun 22 '12 at 18:03

Try booting from the install disk as a live disk. Then search for and install the Boot-Repair package. It may not show in the software list, but is downloaded from Canonical. Run this package to fix any boot problems that you may be having. You can also use it to create a log of your boot failures and it will upload it to pastebin and gives you a link. If your problems are still unresolved, copy the log data from pastebin here for more accurate results.

Reference: Boot-Repair

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.