0

I am dual booting Ubuntu 12.04 on a Lenovo G770. The internal mic works fine in Windows 7. The mic is recognized and unmuted, but it just isn't detecting any sound. I tried messing around with pavucontrol settings, but to no avail.

0

It may have something to do with hardware configuration in Sound Settings. You can get to sound settings by clicking on the volume icon in the upper tray. I'm not at my Ubuntu machine right now, but I always put mine on Full Analog Duplex and it allows the mic to work.

1
  • Nah I don't think it's that. It's set to Analog Stereo Duplex right now. I had to go through PulseAudio Volume Control to configure that though, can that be done in the sound settings? – Abundant Victory Jun 22 '12 at 19:01
0

I also have a G770, and I (finally) got my internal microphone working yesterday by following directions posted here.

Here's what I did:

  1. Opened "/etc/modprobe.d/sound.conf" with sudo rights (in my case this file did not exist, so I simply created it)

  2. Added the following line to "sound.conf": "options snd-hda-intel model=asus"

  3. Saved "sound.conf" and rebooted

BOOM, working microphone!

1
  • Any luck with this method, Abundant Victory? – mblasco Aug 16 '12 at 16:39
0

Open your terminal and type alsamixer there you will open a tool to manage all the sound devices, line ins, line outs etc.

enter image description here

2
  • addition to that. here you can find most of the commands to manage audio in linux. wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture just take a look. – Dulara Malindu Oct 12 '18 at 2:28
  • 1
    Hi, welcome to askubuntu. when adding images it is usually better to make them embedded as opposed to linked. I made the change for you, which will be visible once accepted. – Jeff Oct 12 '18 at 2:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.