I tried to install Dropbox using How to install Dropbox?, or with apt-get install nautilus-dropbox.

Dropbox loads until 99% and then hangs, causing the system to go to 100% cpu usage.

If I reboot or close the terminal, I sometimes get dpkg errors which prevent me from using apt-get or Software Center to perform any package management functions.

I would like to resolve all these and just get Dropbox working. How do I do that?

  • Note: This question is possibly answered in two parts:
    1. The accepted answer tells you how to install Dropbox.
    2. But if you have dpkg errors, see this answer before you use answer 1 to install Dropbox.
  • Can you confirm this is Ubuntu 12.04, 32/64bit ?
    – david6
    Commented Jun 24, 2012 at 11:28
  • If that post doesn't solve it for you, unfortunately it's quite possibly another bug.
    – ish
    Commented Jun 26, 2012 at 10:44
  • Added a 12.04 tag for clarity Commented Jun 27, 2012 at 16:48

9 Answers 9


There already is a bug filed: 1016559

If you have a LaunchPad account, don't forget to add your name to the bug.

Work arounds are listed here.

  • Download the Dropbox .deb file from: https://www.dropbox.com/install?os=lnx
  • Open the .deb with Ubuntu Software Center and begin installation
  • When you see the screen saying "Start Dropbox to finish installation", press CLOSE
  • Install the dropbox daemon (nautilus-dropbox) using this command (from https://www.dropbox.com/install?os=lnx):

    cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86_64" | tar xzf -

    [ for 32bit, just change detail to ?plat=lnx.x86 ]

  • Restart computer

Now you should have Dropbox working, including the notification icon and the Dropbox icon overlays in Nautilus.

  • 1
    The bug still persists in 2015 and I solved with this answer
    – Zac
    Commented May 12, 2015 at 6:18

If you have dpkg errors from trying to manually install, fix them first!

  • Run sudo dpkg -r nautilus-dropbox
    • You may get an error the first time, followed by a popup saying "Dropbox requires Nautilus to be restarted -- just Close it.
  • Run sudo dpkg -r nautilus-dropbox again, and it should end with Removing nautilus-dropbox ...

That's it! Do a sudo apt-get update just to refresh everything. Then follow the steps in the accepted answer to successfully install Dropbox.

  • My problems with the dpkg lock persist.
    – Esso
    Commented Jun 25, 2012 at 19:40
  • It was caused by the 99%-issue, but okay.
    – Esso
    Commented Jun 25, 2012 at 20:05

I couldn't uninstall dropbox nor use sudo dpkg --configure -a because of a lock on dpkg base.

To resolve it I had to kill all dropbox processes (you can find them by using ps -a | grep dropbox) then use sudo kill -s 15 pid_of_dropbox.

After that all problems I succeded to uninstall dropbox but it took me while to find how to do it.


The accepted answer didn't work for me maybe because things have changed since or my situation was not exactly as the answer-providers? There was a missing step needed before it all came together. Maybe there's not a lot of difference as the Dropbox daemon would have started when the system was restarted as advised.

However, the Dropbox-recommended way gives immediate success feedback and is less Windowsy than the accepted answer. Hope this helps!

The instructions I reproduce below from the Dropbox website worked for me on Ubuntu Desktop 12.10

Install Dropbox via command line

The Dropbox daemon works fine on all 32-bit and 64-bit Linux servers. To install, run the following command in your Linux terminal.


    cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86" | tar xzf -


    cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86_64" | tar xzf -

Next, run the Dropbox daemon from the newly created .dropbox-dist folder.

  • This solution solves the always "Connecting..." status problem on my Dropbox installation on Ubuntu 12.04.5
    – Aryo
    Commented Jan 10, 2016 at 12:47

After you start Ubuntu, and you are at the login screen, you need to press Control Alt F1. You will then see a screen with a login prompt. Log into your account from there. Next, you will need to run the following commands:

sudo apt-get -y install nautilus-dropbox && sudo apt-get purge nautilus-dropbox

This will install Dropbox on your system, since it was not installed properly before and might not be removed correctly, and then fully Dropbox.


Well, I had exactly the same problem; I also followed the link you gave and it didn't solve it for me! The thing is, that I did that 3 days ago and I don't quite remember the whole process very well. Sorry for this...

These are the steps I did and solved the problem (NOTE THAT the fact that it worked for me doesn't mean that it will work for you!):

  1. Run this from the terminal (to open the terminal hit Ctrl+Alt+T):

32 bit

wget -O ~/dropbox.tar.gz "https://www.dropbox.com/download?plat=lnx.x86"

64 bit

wget -O ~/dropbox.tar.gz "https://www.dropbox.com/download?plat=lnx.x86_64"
  1. Open nautilus to your home directory and untar the dropbox.tar.gz file

  2. A hidden directory (.dropbox-dist) will be created. Click on the icon, right from your username on the upper right corner of your screen, and then click on startup applications. Click on add: add

  3. In the 'Name' field add 'Dropbox', and in the 'Command' field click on 'Browse...', then head to your home directory, give Ctrl+H to reveal hidden files, click on dropbox-dist and then select the file dropboxd. In the 'Comment' field, add whatever you want.

  4. That is the part that I don't remember very well...Open a terminal and give

    cd ~/.dropbox-dist;./dropboxd

It will ask you for your account info as usual, I think, or it will say that dropbox isn't installed (and it will say to run dropbox -i start). Do whatever necessary (sorry :( i don't remember what I did) so as to fill your account info and such and to login into your dropbox account!

  1. After all this, check if dropbox is running (open system monitor), and if it is, then stop it (kill it or whatever :D). Install hamster-indicator and set it to start on system startup.

  2. Restart your computer!

  3. Now you should have the dropbox running and a working indicator of it! You can now uninstall hamster-indicator (I told you to install it so as to have a working indicator, that's how I fixed mine!)

Sorry if this don't work for you....


For 32 bit machines make sure to use:

cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86" | tar xzf -

... as indicated in the instructions. I was not paying attention and thought the warning applied only to the original package downloaded from the dropbox web site, and had to redo the whole thing (the instructions provided above are for 64 bit).

The answer provided works if you follow the directions exactly. Other solutions, that I found elsewhere, did not work.


You can find the complete solution here.

  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – jrg
    Commented Jun 27, 2012 at 16:55

I (believe) followed all the instructions here and could not finish installing Dropbox correctly. I had read in a recent post in


that the installation bug was fixed but apparently something I have done before is not permiting me to finis my installation. I even followed the purge instructions posted in


but still could not get Dropbox to run.

When I followed the workaround and finally typed ~/.dropbox-dist/dropboxd I got:

Traceback (most recent call last):
  File "__main__dropbox__.py", line 16, in <module>
  File "explicit_imports.py", line 11, in <module>
  File "ui/common/selective_sync.py", line 12, in <module>
  File "arch/__init__.py", line 24, in <module>
  File "arch/posix_common/util.py", line 16, in <module>
ImportError: /home/ale/.dropbox-dist/netifaces-0.5-py2.5-linux-i686.egg/netifaces.so: wrong ELF class: ELFCLASS32

I am running Ubuntu 12.04 on 3.2.0-26-generic kernel x86_64. So I deleted the /.dropbox-dist/netifaces-0.5-py2.5-linux-i686.egg/ folder and now dropbox started and recognized everything.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .