I recently installed Ubuntu 12.04 on my computer with a USB stick cause I don't have a CD drive. The normal ISO didn't work, so I used the text installer and completed all the steps somehow. Eventually it showed "Finishing Installation" and rebooted and I was met with a prompt saying "Localhost login tty1" or something.

I searched some old forums and tried out the login and password as root, guest, ubuntu etc but all in vain. I used the rescue mode and tried to install ubuntu-desktop with:

sudo apt-get install ubuntu-desktop

it says it is not installed and attempts to install. So I think I found the problem. The desktop is not istalled. But when I run this command it says it wants some disk space. I press enter and then it asks to insert the ubuntu CD in /media/cdrom/ and press Enter again. But as I told, I don't have a CD drive, so can anyone help me out?


Can you drop to a root prompt from rescue mode?

Then you can manually mount your usb device to /media/cdrom/ by first creating that directory with mkdir /media/cdrom/ then mount /dev/sdx /media/cdrom where sdx should be replaced with the drive letter for USB device(unmount USB device if automatically mounted). Then you should be able to install. After that unmount the usb umount /media/cdrom and delete rm /media/cdrom.

  • thanks for replying but when I try to mount it says this : – Yash Jun 22 '12 at 14:58
  • @Yash Is something missing here? – Samik Jun 22 '12 at 15:04
  • it says that /dev/sdb1 is already mounted or /media/cdrom is busy. – Yash Jun 22 '12 at 16:03
  • @Yash As I've mentioned earlier unmount USB device with umount if it is automatically mounted on insertion, just run mount and it'll show you the mounted devices(that way you'll also know if /media/cdrom/ is really occupied). After unmounting don't remove the USB, keeping it inserted issue the mount command to remount the USB device at /media/cdrom – Samik Jun 22 '12 at 16:09
  • So when I run just mount it displays a list in which there is no mention of the usb stick or /media/cdrom and still it says that /dev/sdb1 is already mounted or /media/cdrom is busy. – Yash Jun 22 '12 at 16:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.