I get this error when trying to use apt-get:

E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/) is another process using it?  

How can I fix this?

  • 19
    This is also true if you reboot? Maybe some old apt thread is locking the file, you need to find out which and kill it or just rebooting will do it. – Bruno Pereira Jan 29 '12 at 11:19
  • 4
    This procedure almost always fixes this problem, and when it doesn't, its output (the text from the Terminal) is sometimes useful. If you decide to do it, you can add this text to your question. – Eliah Kagan Jun 6 '12 at 9:10
  • 58
    You can use sudo lsof /var/lib/dpkg/lock to find the process that owns the lock file (if empty, assume the lock is left over from a previous boot and can be sudo rmd), then consider doing a sudo kill -9 <PID> (get <PID> from lsof output. – waltinator Mar 17 '14 at 22:01
  • 11
    This can be a sign that something else is installing or removing software and has locked the apt database while it performs the actions. – Foreever Feb 3 '15 at 4:32
  • 6
    On my Ubuntu 18.04 VM there is a process called unattended-update, which is runned by a process like root <pid> <ppid> 0 15:58 ? 00:00:00 /bin/sh /usr/lib/apt/apt.systemd.daily lock_is_held install, which seems to run apt update every time I turn the machine on. Depending on the size of the update (which often corresponds to how long ago since I used that machine the last time), this can use from 1-10 minutes to complete. After that, the lock is freed for manual apt installs and updates. Try: sudo ps aux|grep apt or `sudo ps aux|grep unattended. – Kjetil S. Dec 15 '18 at 15:19

24 Answers 24


This should be used as last resort. If you use this carelessly you can end up with a broken system. Please try the other answers first before doing this.

You can delete the lock file with the following command:

sudo rm /var/lib/apt/lists/lock

You may also need to delete the lock file in the cache directory

sudo rm /var/cache/apt/archives/lock
sudo rm /var/lib/dpkg/lock

After that, try opening Synaptic again.

| improve this answer | |
  • 13
    ok... but why happened this? – Jaime Hablutzel May 26 '12 at 22:40
  • 41
    @jaime: probably apt-get (or some GUI frontend to it) was halted while executing, leaving apt in a locked state. – bouke Sep 13 '12 at 12:15
  • 10
    I would accept this as the best answer. correct one. – Anwar Apr 6 '13 at 14:37
  • 9
    @AnwarShah no, there are other considerations before going around removing files of the system. – Braiam Dec 31 '13 at 14:47
  • 23
    rm /var/lib/dpkg/lock; dpkg --configure -a: – WitchCraft Jan 15 '14 at 15:07

I see pretty much all the answers recommend deleting the lock. I don't recommend doing that as a first measure; maybe if there is no alternative. The lock is placed when an apt process is running, and is removed when the process completes. If there is a lock with no apparent process running, this may mean the process got stuck for some reason.

If you try

ps aux | grep [a]pt


pgrep -a apt

that will catch processes containing the word apt, at least. If you see an apt-get process or an aptitude process that looks stuck, you can try

sudo kill processnumber

and if that doesn't work try

sudo kill -9 processnumber

This should kill the process and may remove the lock. Killing an apt or aptitude process is harmless unless it is actually in the middle of package installation. In any case, if the process got stuck, you probably don't have a choice but to kill it.

Killing a dpkg process directly, if present, is not a good idea, because if dpkg is active, it is probably manipulating the package database, and killing it may leave the package database in an inconsistent state; i.e. corrupted.

Killing an apt-get or aptitude process is in general much safer.

| improve this answer | |
  • 19
    @Link I don't think killing dpkg is a good idea, because usually dpkg is manipulating the package database directly, and this could cause corruption. – Faheem Mitha Sep 14 '13 at 20:17
  • 19
    If killing dpkg can corrupt its database, dpkg was badly designed. Period. – Jay Sullivan Nov 18 '14 at 3:36
  • 10
    for me, this resulted in an error dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. when running sudo apt-get dist-upgrade again. Running the command then resolved the issue. I love Nix! – Wayne Phipps Jun 26 '15 at 13:17
  • 5
    Note, killall apt-get does the same thing as your ps/kill combo. – Cerin Jan 15 '16 at 22:09
  • 3
    Note that I found that I needed to run sudo dkpg --configure -a after killing the rogue apt process in order for things to return back to normal. – starbeamrainbowlabs Oct 17 '16 at 18:35

Remove your /var/lib/dpkg/lock file and force package reconfiguration.

sudo rm /var/lib/dpkg/lock
sudo dpkg --configure -a

It should work after this.

| improve this answer | |
  • these commands helped, but now when I tried to install again, got this reply : Could not get lock /var/cache/apt/archives/lock - open. I think I would have to do like previous unlocking problem, but please tell me the exact keywords for command. I'm an absolute beginner. – kern Jan 29 '12 at 11:38
  • 1
    sudo - execute command as root, rm - remove file. Maybe try sudo rm /var/cache/apt/archives/lock – kubahaha Sep 24 '12 at 13:56
  • 5
    This is not a good suggestion: blindly removing the luck may corrupt dpkg's state. – poolie Feb 2 '15 at 18:09
  • 6
    Why won´t it fix itself nowadays? – Marian Klühspies Nov 1 '16 at 12:19
  • 2
    This worked for me. The aws above didn't. – 1rq3fea324wre May 1 '17 at 22:53

The most likely way to hit this is:

  • boot Ubuntu
  • start a terminal
  • type sudo apt-get install whatever

and the command-line apt overlaps with update-manager automatically polling.

So if you try again in a few minutes that should fix it.

| improve this answer | |
  • 23
    Great hint in contrast to the half-dozen replies suggesting to just remove the file ;-) I randomly ran in the issue and most likely this is it! – Alex Jan 21 '14 at 16:14
  • 2
    Safe enough, had to wait a little before sudo apt-get install could work. – sargas May 11 '15 at 17:56
  • Well This is not working always, yes I have used reboot many times. If it's not suitable try this askubuntu.com/a/315791/378845 before you remove locks – Menuka Ishan Oct 23 '16 at 7:03
  • @menuka, why not just let it finish. – poolie Dec 24 '16 at 14:38
  • 1
    you may combine this with executing ps aux | grep apt to see if something is changing or monitoring with system monitor before killing anything... – Eugenio Miró Jul 19 '18 at 15:12

You will get this message if you forget to use sudo when executing an apt command.

Otherwise this is a sign that something else is installing or removing software and has locked the apt database while it performs the actions. The programs that can do this are:

  • The Software Center
  • The Update Manager
  • The apt link installer (I think this now goes through SC)
  • The apt-get or aptitude command line utilities.
  • The Synaptic Package Manager

IMPORTANT: only try the below as a last resort since it can crash your system. First try killing any running instance of apt or aptitude as described in Faheem's answer.

You can force the lock off by removing the file, but it's not recommended without first closing the program that's holding the lock safely, since you could cause corruption or interrupt an installation (bad). The command provided by João should close the program that holds the lock and then remove the lock but won't protect you from install interruption:

sudo fuser -cuk /var/lib/dpkg/lock; sudo rm -f /var/lib/dpkg/lock   

And the same command can be used for the apt cache lock:

sudo fuser -cuk /var/cache/apt/archives/lock; sudo rm -f /var/cache/apt/archives/lock
| improve this answer | |
  • 5
    I was updating my software when I got the error message. – raindrop Aug 16 '13 at 22:04
  • 21
    This crashed for me- – umpirsky Sep 21 '14 at 17:33
  • 5
    sudo fuser -cuk /var/cache/apt/archives/lock directly rebooted my computer. apt-get is now unlocked. – Maxime R. Dec 4 '14 at 21:47
  • 16
    This crashed my entire server. – 에이바 Jan 5 '15 at 21:28
  • 5
    Killing apt or dpkg half way through is not a great idea. – poolie Feb 2 '15 at 18:12

Only one program can hold the lock. Make sure that you are not running aptitude, synaptic or adept. Close the program and run it again it should work.You may either have synaptic open, or have another terminal window open running apt-get, or have the update manager running.Check it and see if any of those are running,if any of them is running close it and try again.

Try this command in terminal to find what is running

ps -e | grep -e apt -e adept | grep -v grep

If that doesn’t print anything, type the following in terminal to remove the lock

sudo rm /var/lib/dpkg/lock    
sudo rm /var/cache/apt/archives/lock

Now you can install any Packages.

| improve this answer | |
  • 9
    Deleting the lock file is, what I would consider, a dangerous thing to do. If another process is locking for a valid reason - and you remove that lock file and force an install with what you were doing prior - you could seriously, in a negative way, affect your system. – Marco Ceppi Nov 30 '10 at 5:49
  • 5
    That's why i have given that in Note.If all the above fails the only way is to remove the lock.It wont cause any problem as long as dpkg and apt-get/aptitude processes aren't running – karthick87 Nov 30 '10 at 5:55
  • pgrep -f 'apt|adept|dpkg' is a lot shorter. – dhchdhd Sep 12 '17 at 21:38
  • Thx! this works. pgrep -f 'apt|adept|dpkg' and then sudo skill (number) , kill all number and then install works! – creator Mar 6 '18 at 0:22
  • @Barry that would match with the whole path+process. I think pgrep -a 'apt|adept|dpkg' is a better shorter equivalent. – Pablo Bianchi Mar 5 '19 at 17:01

So far the best way to get it working without breaking a possible background running installation ( as it could happen by removing the lock file), is stopping the service using apt:


# sudo apt-get upgrade
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?`


sudo systemctl stop apt-daily.timer

After upgrading the system I suggest re-enabling it, as the bug locking it could be fixed with the upgrade.

sudo systemctl start apt-daily.timer

I haven't verified this error gets fixed after upgrading. I'll add a new comment once I have that verified

| improve this answer | |
  • After upgrading the system and starting the apt-daily.timer service again I'm not facing this issue so far. – Jairelee Feb 2 '17 at 10:41
  • This is probably the cleanest method compared to all those higher voted answers above. It worked in my case flawlessly, thank you! – CygnusX1 Oct 25 '17 at 19:45
  • This worked flawlessly on 17.10 as well – Elder Geek Dec 6 '17 at 4:59
  • Worked on 17.10 +1 – Eng.Fouad Feb 13 '18 at 9:27
  • 2
    Working fine in 18.04. :) – Naveen Kumar V Jun 7 '18 at 2:56

First of all we should check what process created the lock file using lsof:

sudo lsof /var/lib/dpkg/lock

or in another situation where /var/lib/apt/lists/lock is problematic:

sudo lsof /var/lib/apt/lists/lock

The output will be close to something like:

apt-get   12127 root   4uW  REG  252,1        0    86   /var/lib/apt/lists/lock

Then we should check what the commad is doing, we can find it out using ps, pgrep etc; the command is apt-get so I run:

pgrep apt-get -a

The -a switch lists the full command for me, in my case it's:

 pgrep -a apt-get
 12127 apt-get update

we can see that it's running update subcommand, I could run something like this too:

ps -f 12127

which produces:

root     12127 12126  0 09:39 pts/0    S+     0:00 apt-get update

In this case I would wait for some minute for resource to be freed and if after 2 or 3 minute problem still exist or the command was something that I didn't care about or was not harmful for system (like this apt-get update) I send a SIGTERM to the process:

sudo kill -15 12127

It should do the work, If it didn't I'm going to send SIGINT this time (It's like pressing CTRL+C):

sudo kill -2 12127

If it didn't work too, we should send an SIGHUP (kill -1), and finally if nothing works I simply kill the process:

sudo kill -9 12127


sudo pkill -9 apt-get

Then I remove busy resources:

sudo rm /var/lib/apt/lists/lock
| improve this answer | |
  • One small thing is that /var/lib/dpkg/lock rather than /var/lib/apt/lists/lock is the file in the question. – Chai T. Rex Apr 24 '17 at 21:12
  • 1
    Thank the root gods that someone finally mentions pgrep and pkill. – dhchdhd Sep 12 '17 at 21:39
  • 1
    This should be the accepted answer. – Marwan Nabil Jul 10 '18 at 10:31
  • if a install or upgrade caused this a dpkg --configure -a might be needed as well – LUXS Apr 20 '19 at 7:52
  • This works for me – Sundeep Sep 26 '19 at 7:22

This error may be caused by the Update Manager trying to automatically refresh the list of packages in background, usually right after your login, thus locking the directory.

In this case just wait few seconds (or more, if your last update was long ago) for it to complete or launch Update Manager to check the status.

| improve this answer | |
  • I had this right after installing Ubuntu 16.04. Turns out that there was a background process in the Ubuntu Software Center that was waiting for me to manually install some updates. – jvriesem May 12 '16 at 21:16
  • Ditto after a fresh install of 16.04. It too much longer than "a few seconds" in my case (I had time to read this whole Q&A page!) but after refreshing ps a few times I could see dpkg was updating a whole load of stuff and I waited patiently for it all to finish. I then ran Software Updater until everything was up-to-date before trying to install anything new. – Charlie Joynt Mar 2 '17 at 21:51

Don't be so fast to remove something, it may totally damage your system; rather wait until the currently installing or uninstalling program finishes its task and after that you will get access. If you think that there is nothing currently installing or uninstalling, then just reboot your system with the command sudo reboot.

| improve this answer | |
  • 1
    This looks like a comment rather than an answer. Could you move this instead as a comment to the answer it was responding to? – jvriesem May 12 '16 at 21:15
  • 4
    @jvriesem I think this is a very important answer, because the point he's making is what is missing from many other answers! – Volker Siegel Jul 2 '16 at 10:31
  • @jvriesem This is usually the correct answer. I run into this problem quite often with my linux containers when I don't use them a long time. Just wait. Yes it may be a while. But let it do its job before going in and disrupting things. – earth2jason Mar 23 '19 at 13:57
  • This should be the first thing to try. This answer most of the time fixes the problem. I had it maybe 4-5 times yet, and a reboot always solved it. – Jan Jul 2 '19 at 6:47

This will happen if you have 'Update Manager' running in parallel for any update check or install as install process places Lock. If you're facing the same error without 'Update Manager' running you have to remove it from /var/lib/dgkg/lock, which definitely you can't do it manually

sudo fuser -cuk /var/lib/dpkg/lock
sudo rm -f /var/lib/dpkg/lock

works fine. Taken from: https://askubuntu.com/a/15469/68707

| improve this answer | |
  • 1
    This was the problem in my case! – LondonRob Sep 19 '14 at 13:12
  • 1
    Better solution since fuser command used to track down other process (if still alive) – Lars Nordin Mar 18 '15 at 11:50

If you have security updates set to auto-install this will happen frequently. I literally wait 30 seconds and it fixes the issue. Just throwing this out there in case anyone else encounters this issue.

| improve this answer | |
  • 1
    Depending on how long the distro has been booted, it could be as long as a half hour. But it's probably ideal to let your distro finish its job before disrupting things. – earth2jason Mar 23 '19 at 13:58

In my case, I had to wait for several minutes for the lock to be released (looks like apt used to hold it). This all happened right after system boot.

| improve this answer | |

Just sudo rm -f /var/lib/apt/lists/lock and try again.

apt-fast MAY be responsible for not unlocking properly; this happens sometimes when you abort apt-get or dpkg too.

| improve this answer | |

I have had this issue numerous times. For me, it was almost always caused by apt-get or some GUI that called it getting hung for some reason. I had to kill it which left various locks in place.

The other answers bring up very good points about making sure no updates are currently running before doing anything drastic like removing lock files. However, once you are sure that's not the case, the following usually works for me. I got it by reading many answers to questions like this one.

While most or all of this is presented in the other answers, this distills the fix down to a few commands.

sudo fuser -vki /var/lib/dpkg/lock
sudo fuser -vki /var/cache/apt/archives/lock
sudo fuser -vki /var/cache/debconf/config.dat
sudo dpkg --configure -a

Use for unlocking the package system after an update of some kind crashed or terminated without finishing in some other way. These commands should be run in the order presented.

| improve this answer | |
  • At least in Ubuntu 19.10 there may also be /var/lib/dpkg/lock-frontend – jarno Dec 20 '19 at 16:20

I don't see this answer anywhere above but on Ubuntu 16.04, I encountered this problem as well. The cause was the time on my computer was set into the future. (This is because I'm on a Windows+Ubuntu dual boot system and I guess I have messed up local time vs UTC time.)

One odd thing was that the locked file's date and time was the exact date and time that I ran the program.

I then used "fuser" as described in earlier posts and apt worked, but I was getting complaints about needing to run dpkg -a -reconfigure. When I did that, I got errors like:

newline in field name #padding

in files like '/var/lib/dpkg/updates/0003'.

All of this was very strange as I've never seen it before. So, I thought these were symptoms and changed my data and time manually. I knew there was a problem with the date/time when I logged in, but was ignoring it. (Previously, it was setting it automatically via the Internet and NTP).

Then, all of the above problems were fixed... Hopefully, this helps someone else! The most notable symptom is perhaps the date/time of the lock file being the exact date/time that you are trying to run the command.

| improve this answer | |

In my case, X crashed while apt-get was still removing old kernels. I used the System Monitor to confirm it was still running and not stuck. Everything was fine once the process finished.

| improve this answer | |

Check the Launcher to see if Software Updater is running. If so maximize it and have a look at what it is doing. If it is still checking, then wait for it to complete. When it completes it might tell you the software is up-to-date so close the app. If it says there are updates available, either do the update or click "remind me later". After this this app closes you can go back to using apt-get or apt.

If Software Updater is not running, just use the Dash to invoke it and the wait for completion and then decide if you want to update or click "remind me later". After this this app closes you can go back to using apt-get or apt.

| improve this answer | |

In my case I was getting the same message by not realizing I had switched to root user and was trying sudo apt-get. Once I realized this I just ran apt-get, and it worked. Silly, but it might still explain the error for some.

| improve this answer | |
  • 2
    That's not the cause of the issue, since you can run sudo as root (and even if you couldn't, it wouldn't produce this error message). More likely what happened was that the other process finished while you were writing the next command. – wjandrea Oct 24 '17 at 5:06
  • Sometimes it does produce that same error message. – karel Dec 23 '17 at 0:31
sudo killall -9 apt && sudo killall -9 dpkg

Use at your own risk

| improve this answer | |

in my case, after:

  1. Open Firefox.
  2. Open terminal

I typed

sudo apt update
sudp apt upgrade
then I get that problems

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
I fixed that, running the command that was showed me after run sudo apt update

apt list --upgradable

This command will show you a list of programs in my case only Firefox, I closed Firefox, then could ran the command again without problems.

sudo apt upgrade
| improve this answer | |

For people who are interested in proactively preventing this bug in their scripts, I found that the -q flag on apt upgrade -yq was causing this issue for me. During the upgrade process I guess it would occasionally give me warnings (something along the lines of updating the desktop, would I like to continue), and if these warnings were suppressed, then I guess that causes apt to not unlock the files it was protecting and it got stuck.

Admittedly, I had trouble reproducing this error 100% of the time, but eliminating that -q option completely fixed the issue for me.

| improve this answer | |

Like most everyone else I waited for the lock to be removed. After 30 minutes I gave up and hard booted to a different distribution. From there I used the internet for some research which landed me here.

It turns out unattended-upgrades.service is running. I found that be rebooting into the broken system and running:

sudo systemctl disable apt-daily.service
sudo systemctl disable unattended-upgrades.service
sudo systemctl disable apt-daily-upgrade.service
sudo systemctl disable apt-daily-upgrade.timer
sudo systemctl disable apt-daily.timer
sudo shutdown -r # Note it will take a couple minutes to reboot

allowed me to get the broken system working again for:

sudo apt update
sudo apt upgrade
sudo apt install -f

However it didn't fix the kept-back packages and impossible situation reported by apt in the first place. It would appear this was causing apt to lock up at boot in the first place.

| improve this answer | |

I have tried the top upvoted answers on this page and they always worked for me without exception, however I discovered an easier way to solve this problem. First some theory. What happens before a user gets this error message?

E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/) is another process using it?  

/var/lib/dpkg/lock is locked, so the terminal temporarily can't use it, but what process is it locked by? This depends on the circumstances. If you have booted the computer a few minutes ago it is probably locked by the Software Updater app. Try closing the terminal and running the Software Updater app. After Software Updater finishes it will remove its own lock without the user needing to run any commands in the terminal.

Another case where this answer is useful is in a VM when booting an Ubuntu guest OS that has been inactive for a while. Normally the Ubuntu guest OS starts to update almost immediately. The updating process frequently locks out commands that require installing, removing or updating software until it finishes. Open the Software Updater, let it finish running and install whatever updates that you want to install. The Software Updater will remove its own lock when it finishes.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.