Error message:

(initramfs) unable to find a live medium containing a live file system

I got this error while trying to install Ubuntu 10.10 from a bootable USB stick on to Asus X64J series laptop. After getting this error the installation fails to start.

I have used the same USB stick on some other laptops and the installation started as usual. Any help will be appreciated.

  • 6
    Same problem but changing USB socket didn't help. What did work was to unplug/replug the thumb drive while the "UBUNTU...." cycle (system looking for file system I assume). System found thumb-drive and install continued normally. Dec 21, 2018 at 21:47
  • switching usb socket when the ubuntu logo was up worked for me! Jun 10, 2019 at 7:36
  • @steven thanks for the trick ;) I replugged the pendrive during the Ubuntu load step and it took me out of the misery(although it showed some error exists).. But, still the track pad doesn't work which I guess can figure it out once I have the OS installed.
    – Akhil
    Jul 15, 2021 at 6:40
  • 1
    Dual booting didn't use to be this hacky... Aug 18, 2022 at 4:03

12 Answers 12


Try changing the following:

  • Switch from a USB 3.0 socket to 2.0
  • Try using a USB hub
  • (If booting from a USB stick) try using a different USB stick

I'm using 10.04 Ubuntu on Asus 1015PEM, but reports of this affecting 18.04 and newer versions of Ubuntu are still occurring.

In 22.04, the USB is UEFI bootable only, but the installed 18.04 is not, hence in the BIOS you need to set back and forth.

  • 5
    Having no USB2.0 ports, disabling USB 3 in BIOS worked for me.
    – Alex
    Mar 31, 2016 at 23:38
  • 3
    @Alex But I don't have that option in my BIOS! What should I do?
    – Mygod
    Jul 17, 2016 at 14:32
  • @Mygod, really not sure sorry. Are you sure it's not in there somewhere?
    – Alex
    Jul 18, 2016 at 7:35
  • 2
    this helped. For me it's opposite, my usb disk was 3.0 and I had to plug it into the 3.0 socket for it to work.
    – fchen
    Aug 5, 2017 at 17:45
  • 1
    i have the taichi x399 and there are NO usb 2.0 ports. what do i do? Jun 18, 2018 at 23:57

Here is what I found looking around for this error message:

Data integrity

Check that the hash of the ISO you downloaded matches the official one. Also try different USB sticks or DVD burners, there may be data corruption on the stick or wear on the drive mechanics you want to rule out.


Hardware issues

To rule out hardware issues you can try a different computer, if available. Remember that you can usually install Ubuntu by installing the target harddrive in another computer and complete the installation there, which may be the quickest workaround in such a situation.

Cause analysis and general advice

The cause of the issue seems to be that the USB or SATA device isn't available or detection is too slow at the time the kernel takes over during the boot process, so that it can't find the image of the live OS to load. Similar to the recommendation in the data integrity section above, try burning optical installation media when you are unable to boot from USB and vice versa. If that's not possible because your computer only has USB 3.0 ports and no internal optical drive, try booting from an integrated SD card reader. Also look out for available firmware updates for your computer that may fix the issue. If you are trying to install from an ISO of an older release, then please try the latest ISO.

As a last resort you can try to use the minimal ISO, which doesn't seem to load another filesystem except initrd but requires a working Internet connection for installation. I would recommend this for Intel Macs from Apple that have this issue.

Hardware issues on laptops and desktops

There seem to be issues on laptops from Dell, Lenovo, Toshiba, Sony and may be other manufacturers. Non-custom built desktops may also be affected and as far as I am aware this is specific to modern AMD processors.

Try changing the firmware settings (BIOS/UEFI) for SATA (set to AHCI mode) when using optical media or use another (non 3.0) USB port when using USB, this seems to work in most cases.

Hardware issues on Gigabyte mainboards

There apparently was or still is an issue on some Gigabyte mainboards with the IOMMU on AMD platforms (Intel calls this VT-d).

I found the following post on the forums (1, 2):

Turns out the IOMMU needs to be enabled in the BIOS. This problems seems to be exclusive to Gigabyte boards.

As well as this answer here on AU:

Gigabyte UEFI boot issues - The partition size of the created USB Installer device needs to be under that of 4GB. Others found UEFI/BIOS update solved issue of 4GB FAT limit.

  • Was the IOMMU stuff for me !! You are a god !
    – TOPKAT
    Apr 8, 2019 at 18:15

I recieved the same error, “unable to find a medium containing a live file system”, when installing from a SATA DVD drive. Installing using USB 2.0 stick worked though.

  • 1
    I am installing Ubuntu 18.04 form the usb stick. I am still getting this error... Aug 22, 2018 at 14:14
  • 1
    Hi Salman, this error means that either your PC tried to boot from another disk than your desired USB stick OR that the data read from the stick is somehow corrupted. 1. This is an old question, try to open your own. 2. Try to use your phone to take a photo of your screen when you select the boot device and upload that into your question. 3. Try to write your current ISO to another USB stick OR try to write another ISO to your current USB stick;; OR try to boot the same stick in another computer / another USB port ? 4. Try to verify the ISO written on the stick (dont know how)
    – BogdanBiv
    Aug 22, 2018 at 20:05
  • Thanks for the prompt response. I tried another usb stick and that worked fine, thanks :) Aug 22, 2018 at 20:14

The content of the USB may have been corrupted. I had this about some months ago. If you have a second PC with Ubuntu try to create a new bootable Live USB from System --> Administration --> StartUp Disk Creator.


You need change your bios from IDE to ACHI.

  • It should have been a solution for me, but Acer Aspire All-in-One BIOS is short of configuration options. I solved the issue by setting "USB Emulation" to "HDD". Jun 22, 2013 at 2:58

ya you should first make the default booting device to usb drive. i think you have chosen unetbootin for burning which is not useful i myself faced same problem. use multi boot iso which is good...

  • 1
    I am not burning anything since I use an USB stick
    – dds
    Nov 30, 2010 at 19:39

Assuming that the data on your stick are o.k. (did you try to boot with this very stick on another machine?), check that BIOS is set for booting from "USB-HDD" or something like that as first boot device.

Edit: I can see this was done. Maybe other BIOS settings for USB or HD access need to be corrected. Your error indicates mounting problems.

From here we can only guess. Try switching from IDE to AHCI, deactivate BIOS support for any non-existent devices, check your BIOS is up to date etc. I do believe it is some BIOS issue we have here.

  • 2
    c'mooon... it should be already booted to able to display any error about live file system. otherwise it would continue to boot from HDD and if HDD doesnt have a OS it would say some error other than live file system
    – dds
    Nov 30, 2010 at 19:38

Greetings. I just solved this. Packard Bell TK85. My boot sequence was USB, CD, HD. I changed it to USB, HD, CD and it worked.

  • I'm installing from a DVD and this advice worked for me too.
    – Mario S
    Dec 23, 2015 at 0:48

Try changing the following:

  • Switch from a USB 3.0 socket to 2.0 or vice versa
  • Use a USB hub (this might switch you from USB 3.0 to USB 2.0 or vice versa)
  • If booting from a USB stick, use a different USB stick

I've hit this on a few different laptops (Dell XPS 9350, Razer Blade Stealth 13 2019). The above eventually got me working but it was trial and error.

Dell XPS 9350 specifics: I had to switch to Legacy ROM mode in the advanced boot section and switch to legacy boot instead of UEFI in the regular boot option.


The thing that solved this problem for me was having the Optical drive plugged into the right socket on the motherboard.


I solved this by using a USB 2.0 hub as a go-between.

  • There must have been some confusion about compatibility standards. Mar 23, 2019 at 19:48

I have an MSI MPG X570 main board, and tried booting from:

  • the internal DVD drive
  • an external DVD drive, connected to both USB 2.0 and USB 3.1 ports
  • an USB stick on USB 2.0 and 3.1

but I got the error every time.

The solution is simple: Just completely disconnect the SATA DVD drive, and boot from a stick or DVD drive connected to USB. (As found in this thread)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .