I was a huge fan of Gnome-shell, much better than Unity-shell, but I'm unable to run it since a few weeks. When I try to log in with Gnome-shell session, I'm able to see only the background image. None of startup apps appear, nor top panel.

If I start Unity session and type in Ctrl+Alt+F1 terminal:

user@home-PC:~$ gnome-shell --replace
Window manager error: Unable to open X display

or in gnome-terminal after:

user@home-PC:~$ gnome-shell --replace
Segmentation fault (core dumped)

it freezes until I type unity/gnome-panel --replace in Ctrl+Alt+F1 terminal.

EDIT vol. 2.0:


I found what was the problem. Actually very simple, but never met this before. The PPA had two versions, first one, the normal 3.4, but the second one was 3.5 or even higher, which does not work on Ubuntu 12.04. I've checked mine with:

gnome-shell --version

So the only thing I had to do is to select the correct version to install, then everything works fine. Thanks for the help. :)


I reset my Gnome-shell settings following steps from here:

rm -rf .gnome .gnome2 .gconf .gconfd .metacity .cache .dbus .dmrc .mission-control .thumbnails ~/.config/dconf/user ~.compiz*

and right after it:

gnome-shell --display=:0 --replace

and it worked fine, even after rebooting.

After that I added some ppa-s and installed some gnome-shell-extensions and gnome-tweak-tool and rebooted. After trying to login, Gnome-shell crashed again, this time in terminal:

user@home-PC:~$ gnome-shell --replace
(gnome-shell:4067): GLib-GIO-ERROR **: Settings schema 'org.gnome.desktop.a11y.magnifier' does not contain a key named 'invert-lightness'
Trace/breakpoint trap (core dumped)

So I need help again. :(


I've tried several things:

Renaming ".gconf" in user "Home". DISPLAY=:0 gnome-shell --replace

STATUS: still not working Gnome3.

purge fglrx:

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

and reinstall it via Graphic interface or using this.

STATUS: still not working Gnome3.

purge gnome-shell:

sudo apt-get purge alacarte cups-pk-helper gir1.2-accountsservice-1.0 gir1.2-caribou-1.0 gir1.2-clutter-1.0 gir1.2-cogl-1.0 gir1.2-coglpango-1.0 gir1.2-folks-0.6 gir1.2-gconf-2.0 gir1.2-gdesktopenums-3.0 gir1.2-gee-1.0 gir1.2-gjsdbus-1.0 gir1.2-gkbd-3.0 gir1.2-json-1.0 gir1.2-mutter-3.0 gir1.2-networkmanager-1.0 gir1.2-panelapplet-4.0 gir1.2-polkit-1.0 gir1.2-telepathyglib-0.12 gir1.2-telepathylogger-0.2 gir1.2-upowerglib-1.0 gir1.2-xkl-1.0 gjs gnome-applets gnome-applets-data gnome-contacts gnome-icon-theme-full gnome-panel gnome-panel-data gnome-session-fallback gnome-shell gnome-shell-common gnome-themes-standard indicator-applet-complete libcaribou-common libcaribou0 libclutter-1.0-0 libclutter-1.0-common libcogl-common libcogl-pango0 libcogl9 libgjs0c libmozjs185-1.0 libmutter0 libpanel-applet-4-0 mutter-common python-gmenu

and reinstall gnome-shell:

sudo apt-get install gnome-shell

STATUS: still not working Gnome3.

One of my biggest mistakes: purge and reinstall all gnome* packages - doesn't work, even I lost some apps, now Unity and Gnome-panel work fine, except Gnome3

STATUS: still not working Gnome3.

reinstalling all available Ubuntu packages:

sudo dpkg-reconfigure -phigh -a


** (accounts-daemon:7108): WARNING **: Failed to acquire org.freedesktop.Accounts
** (accounts-daemon:7108): WARNING **: Could not acquire name

and after 30-40 minutes the finished.

STATUS: still not working Gnome3.

So I hope anybody help me, I love Gnome-shell, but I'm disabled to use it. Thanks in advance. :)

  • +1 I have the same problem. Tried every workaround and nothing helps!! Now using gnome-classic-session with Avant Windows Navigator.... :( – Ravi Jun 28 '12 at 15:06
  • @Ravi Check my last update of the post. Hope it helps. :) – user72274 Jul 9 '12 at 0:21
  • Hi I already solved my problem! I reinstalled nvidia driver after installing gnome 3 and now all is working fine.... – Ravi Jul 9 '12 at 10:03

Let's try resetting GNOME settings to the default and see if that helps.

I am guessing one of the configuration files in your home directory is causing these problems and removing them would possibly work for you.

| improve this answer | |
  • I've deleted them and the result is that it worked... once, now I have new problem after "gnome-shell --display=:0 --replace". Terminal returns "(gnome-shell:4067): GLib-GIO-ERROR **: Settings schema 'org.gnome.desktop.a11y.magnifier' does not contain a key named 'invert-lightness' Trace/breakpoint trap (core dumped)". (I'll edit my first message). – user72274 Jun 21 '12 at 17:56
  • @user72274 I would guess the PPA's are causing you these problems. I suggest purging and see if that helps. If it still doesn't help, open a new question. I don't see how this problem is the same as the previous one. Thanks. – jokerdino Jun 22 '12 at 2:02

Thank you original poster. The following command worked well. This did give me some errors, but at least got gnome-shell back up so I could finish up/save what I was doing and then reboot/logout.

Ctrl + Alt + F1 (or whatever shell you want) login

run the following command: gnome-shell --display=:0 --replace

Go back to X --> Ctrl + Alt + F7

And gnome-shell restarts.

| improve this answer | |

I've solved my problem. Version compatibility. Check in my first post above. :)

| improve this answer | |
  • 2
    It would be better if you instead edited this answer to incorporate your solution so people don't have to search for it. :P – Christopher Kyle Horton Nov 29 '12 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.