46

I'm using Ubuntu and I'm trying to connect to another machine in a different network using remote desktop.

In Windows7 I have made the following in order to activate remote desktop:

  1. I've gone to computer -> properties -> remote settings
  2. I've selected the option: "Allow connections from computers running any version of Remote Desktop
  3. I've opened "Windows Firewall with Advanced Security"
  4. In inbound rules I've enabled the rules for remote desktop (public and domain)

I have also installed Remmina in the Ubuntu machine.

For configuring it I did the following steps:

  1. Selected the RDP protocol
  2. In the server input I have written the Windows machine public IP.
  3. In username / password I have typed my login credentials (the same as my Windows admin account)

But when I try to connect I get this error message:

"Unable to connect to RDP server 89.130.251.160"

If I ping my Windows7 machine, I have a correct response.

Any suggestions?

4
  • 1
    you opened the right ports on the machine and the modem/router?!
    – Dr_Bunsen
    Jun 21 '12 at 12:43
  • Try launching this command from Ubuntu: telnet 89.130.251.160 3389 What do you get as an output?
    – koni_raid
    Jun 21 '12 at 14:12
  • For me it was something really stupid, I typed the wrong password. If you choose RDP as protocol, you'll get a Windows screen telling you that the username or password is incorrect. However, when you use NLA (the default), it just says "Unable to connect". This is very misleading, although technically correct ;)
    – chris166
    Jan 31 '16 at 10:31
  • The biggest problem you will usually face is that Windows machines have a UTF8 usernames with whitespace i.e. "Marko Šhelčič"... This will not work with Remmina! You have to change the user name on the Windows machine to have no whitespace and only ASCII characters for maximum compatibility... I tried all the answers and I couldn't make it work. And then I tried to change the user name... Now it works.
    – 71GA
    May 7 at 9:02
75

Make sure port 3389 is opened on your firewall and router.

In Remmina edit your connection, click the "Advanced" tab and choose RDP under the "Security" option and save.

Remmina Advanced Settings dialog

4
  • 7
    did that, doesn't help Jun 5 '13 at 22:23
  • 6
    Why is RDP not the default choice?
    – Nemo
    Feb 27 '14 at 17:59
  • 7
    This helped me, but I'm confused: Why might a connection work for a while without this change then suddenly require it?
    – Sam
    Jun 17 '14 at 11:20
  • 3
    For what it's worth, I had to change the "Security" settings from "Negotitate" to "RDP" today to get it working from my Ubuntu 16.04 session. It had previously been working on the "Negotiate" setting. I don't know if it was an Ubuntu or Windows update that broke it.
    – John T
    Jun 6 '16 at 3:28
30

Just delete the server causing problem from the file ~/.freerdp/known_hosts and it will work.

6
  • 6
    did that, doesn't help Jun 5 '13 at 22:24
  • This worked for me too after a server I'd been connecting too just stopped working! Aug 12 '15 at 0:53
  • I just deleted the whole file lol but it worked thanks. Negotiated settings seems the most sensible... Nov 16 '16 at 0:46
  • I don't have the .freerdp folder in my home directory. Dec 25 '16 at 2:20
  • Wow, this just worked for me. Same issue as OP. Deleted this file. Works again.
    – Halsafar
    Mar 20 '17 at 18:52
7

For me deleting the offending host in ~/.freerdp/known_hosts and changing the Security setting to NLA worked.

RDP used to work, but does not anymore for the Windows 7 machines I work with.

1
  • chattr +i ~/.freerdp/known_hosts This worked for me
    – Ajay Kurmi
    Aug 8 '17 at 10:29
2

None of these solutions were actually right for me. But on my machine, the Color Depth setting MUST be set to "True color (32 bpp)" to work. This may be different depending on your Windows settings, but it appears that any other setting will just fail with "Unable to connect" message.

enter image description here

All other settings are default, created by the new connection in Remmina.

2
  • 1
    Omg that sounds a bit bizarre, a screen setting interfering a connection ...
    – m3nda
    May 12 '17 at 15:05
  • It took took me a while to figure out where this setting was, but once I clicked on the "+" sign, rather than trying to just connect, I seen the various settings that could be adjusted. I am using Ubuntu 18 and Windows 7. You may want to add where to find this setting in your answer! Thanks for the help!!
    – Gordster
    Sep 19 '19 at 18:44
1

When deleting the host from ~/.freerdp/known_hosts doesn't work, try checking the windows remote desktop settings.

For me disabling "Allow connections only from computers running Remote Desktop with Network Level Authentication (recommended)" did the trick. (search for "allow remote access to your computer" in control panel.

enter image description here

0

I had similar problem when trying to connect a PC running Precise from a laptop running Precise also. Since I had other 2 successful connections one of which was a PC running Windows XP and the other running Lucid. Both used VNC protocol (blue monitors icons) but the one with the problem was set with RDP (flower icon). Just go to the main window of Remina, right-click the connection in question, choose Edit and change protocol to VNC. Hope this will help.

0

I have the same problem. In my case the remote server is wondows2012R2 which was new installed and i connected to it latest when it was windows 2008R2.

In each case i try, i got that error message, so suddenly, i didn't change the Advanced -> Security to RDP and stay on Negotate and it take the new server certificate and connect.

Not the answer you're looking for? Browse other questions tagged or ask your own question.