After fresh install 12.04 I && updating apt and system restart, I always get this annoying message after reboot :

Failure to download extra data files

The following packages requested additional data downloads after package installation, but the data could not be downloaded or could not be processed.


The download will be attempted again later, or you can try the download again now. Running this command requires an active Internet connection.

But if I run attempt now, it shows flashing terminal window and like nothing happen. It'll happen again when I restart system.

I found someone have this problem too, but he haven't replied yet.

  • I'm a newbie here, please help.

11 Answers 11


Solution 1:

Connect to the internet and run this command below, to fix the error

sudo apt-get install --reinstall ttf-mscorefonts-installer  

This will reinstall the package, and download the data files needed to configure the package. Wait for some times to finish downloading. The download size is approximately 4MB.

Solution 2:

  1. Connect to the internet and go to this sourceforge link and download all the .exe files there except wd97vwr32.exe file.

  2. Copy those files in your home directory.

  3. Run this command to configure the package

    sudo dpkg-reconfigure ttf-mscorefonts-installer
    • This will ask you whether you have downloaded microsoft fonts or not. Use Tab to select OK, and hit Enter.
    • Then again you will be asked to enter the directory name for the downloaded files, Type the location of your home directory and use Tab to select OK, and hit Enter.

      For example, if your login name is anwar, the location will be /home/anwar, because I copied the downloaded files there.

Done! you have successfully configured and setup the package.

Note: If the files cannot be downloaded due to 404 error, check the "Can't download?" section

What was the cause of the problem?

This package ttf-mscorefonts-installer is used to download Microsoft's font files (those files are made freely available by Microsoft) from the Internet and install them. Since you must accept the EULA of Microsoft to use those font files, those fonts cannot be included in the package like other Free (Free as freedom) packages.

The problem was, somehow you get disconnected from Internet before downloading those files. So, is the message asking to download more data files.

Can't download?

If you can't download the files due to 404 errors, I have prepared a tar.gz archive of the downloaded contents. You can download it from this dropbox link and extract it to a folder. If you extract it to /tmp/, you'll type that directory after the dpkg-reconfigure command in Solution 2.

  • 3
    Solution 1 solved my problem on 14.04 LTS (Trusty Tahr). Shift-Tab to select "OK", then Enter and Enter again. Commented May 10, 2014 at 16:19
  • 4
    Solution 1 didn't work for me. I get the message "Hashtype mismatch" when it tried to download the font andale.ttf. Apparently the same problem is discussed and fixed at askubuntu.com/questions/543673/mscorefonts-problems Commented Aug 29, 2015 at 14:10
  • 12
    Solution 1 fails for me because of an error 404 (file not found) regarding downloads.sourceforge.net/corefonts/andale32.exe. Solution 2 fails for me because the command sudo dpkg-reconfigure ttf-mscorefonts-installer does not allow me to configure the package. (Ubuntu 16.04 LTS)
    – marianoju
    Commented Nov 29, 2016 at 8:51
  • 1
    @Anwar a) I am glad that the SourceForge link works for you, but please see answers.launchpad.net/ubuntu/+question/404484 for a log file with multiple error 404 I encountered while trying to reinstall (not only with andale32, but also comic32 and arial32). b) Shouldn't sudo dpkg-reconfigure allow me to reconfigure even if the font has already been configured? c) I did check and mscorefonts-eula license has already been accepted, so that is not the issue here.
    – marianoju
    Commented Dec 5, 2016 at 12:07
  • 2
    b) dpkg-reconfigure doesn't do anything if the package is already configured. In this case, i simply suggest to remove the package using sudo apt-get purge command and re-install.
    – Anwar
    Commented Dec 5, 2016 at 12:12

I went to Debian's site and downloaded the ttf-mscorefonts-installer_3.6 and installed it using Gdeb, installed successfully.

Command-line example:

wget http://httpredir.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.6_all.deb
sudo dpkg -i ttf-mscorefonts-installer_3.6_all.deb

None of the other solutions posted here worked for me.

  • 10
    Should be the accepted answer ;)
    – blong
    Commented Dec 27, 2016 at 18:02
  • 2
    Works well, is there any https link though?
    – Mark
    Commented Jan 6, 2017 at 9:17
  • 3
    +1 this works really good :) but why hasn't this version ended up in Ubuntu's repository tho..
    – retrixe
    Commented Jan 11, 2017 at 13:35
  • 2
    I installed this using gdebi and worked!
    – eri0o
    Commented Jan 16, 2017 at 1:35
  • 2
    Real cause is bug bugs.launchpad.net/ubuntu/+source/msttcorefonts/+bug/1607535 - it may be fixed in Ubuntu because backporting takes too much time for some reason. Commented Jan 24, 2017 at 17:33

I had the same issue... So, this is my workaround to fix it:

sudo apt-get remove --purge ttf-mscorefonts-installer
cd /var/lib/update-notifier/package-data-downloads
sudo rm partial/*
sudo rmdir partial
sudo mkdir partial
sudo chmod 777 partial
sudo apt-get --purge --reinstall install ttf-mscorefonts-installer
sudo rm partial/*
sudo rmdir partial
sudo mkdir partial
sudo chmod 744 partial
  • Thanks, I've been getting this bug on Ubuntu 16.04 and 16.10 and most solutions weren't helping me. This one seemed to fix it right away, got Times New Roman working in Libre Office Writer, and got texts to display properly again in Firefox. Big help.
    – Alex
    Commented Oct 28, 2016 at 22:13
  • As previous comment, worked for me on 16.04 when others didn't. Thanks :)
    – Teknogrebo
    Commented Dec 20, 2016 at 8:19
  • 1
    This worked once for me, but now I'm getting E: Failed to fetch https://iweb.dl.sourceforge.net/project/corefonts/the fonts/final/arialb32.exe 404 Not Found. It looks like good old Sourceforge is removing the necessary files.
    – Cerin
    Commented Jan 18, 2017 at 16:53

If you're getting:

Get:1 http://downloads.sourceforge.net/corefonts/andale32.exe [969 B] Err:1 http://downloads.sourceforge.net/corefonts/andale32.exe
Hash Sum mismatch Fetched 969 B in 1s (660 B/s)
W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/andale32.exe' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied) E: Failed to fetch http://downloads.sourceforge.net/mir...ourceforge.net Hash Sum mismatch

E: Download Failed

Try this:

sudo rm -rf /var/lib/update-notifier/package-data-downloads/partial/*

Followed by:

sudo apt-get --purge --reinstall install ttf-mscorefonts-installer

See this thread for more details.

  • 1
    Just tried that but now I get an issue with arial: Err:1 downloads.sourceforge.net/corefonts/arial32.exe Hash Sum mismatch Commented Oct 27, 2016 at 13:35
  • Worked fine on Lubuntu 16.04! Thx!
    – Uilian
    Commented Nov 15, 2016 at 11:43
  • _apt privilege error came again but this time it was far better. I saw fonts installing one by one. No Error. Only Warnings. Now Fonts appear in LibreOffice. Commented Nov 16, 2016 at 18:05

Mine works with reinstalling it (found the command here and just try it out but then it worked. lol)

Uninstall command

sudo apt-get remove --purge ttf-mscorefonts-installer

Install command

sudo apt-get install --reinstall ttf-mscorefonts-installer  
  • This answer works for me unlike accepted one. Purge before reinstal is a key.
    – Yuri Gor
    Commented Dec 7, 2016 at 15:14
  • Fails with: Err:1 http://downloads.sourceforge.net/corefonts/arialb32.exe Redirection from https to 'http://downloads.sourceforge.net/mirrorproblem?failedmirror=vorboss.dl.sourceforge.net' is forbidden [IP: 443] E: Failed to fetch https://vorboss.dl.sourceforge.net/project/corefonts/the fonts/final/arialb32.exe Redirection from https to 'http://downloads.sourceforge.net/mirrorproblem?failedmirror=vorboss.dl.sourceforge.net' is forbidden [IP: 443] E: Download Failed Commented Mar 19, 2019 at 7:28
  • Same here @SergeStroobandt Commented May 6, 2020 at 15:09
  • 1
    @FabianoLothor Try my answer instead! Commented May 6, 2020 at 17:06

Stop the nagging, install & refresh font cache

To stop the nagging about Failure to download extra data files, first remove the partial download:

$ sudo rm -R /var/lib/update-notifier/package-data-downloads/partial/

Then, download and install the Debian version of this package:

$ wget http://httpredir.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.6_all.deb
$ sudo dpkg -i ttf-mscorefonts-installer_3.6_all.deb
$ rm ttf-mscorefonts-installer_3.6_all.deb

Finally, grab this opportunity to update the font cache:

$ sudo fc-cache -f -v

For Ansible automation

- name: 'Removing buggy MicroSoft™ core fonts installer.'
    pkg: ttf-mscorefonts-installer
    state: absent

- name: 'Removing partial download of MicroSoft™ core fonts.'
    path: '/var/lib/update-notifier/package-data-downloads/partial/'
    state: absent

- name: 'Installing Debian MicroSoft™ core fonts installer.'
  # https://askubuntu.com/a/1127190/164341
      deb: 'http://httpredir.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.6_all.deb'

The above question is related to this other one.

None of the solutions provided at both questions worked for me. Hence, I decided to:

Manually install the truetype fonts

Below are the 10 steps you need to follow in order to manually install the Microsoft core truetype fonts. Unless otherwise indicated, all commands must be executed inside a shell terminal window. In most *Ubuntu distros, the Ctrl Alt T key combo (keyboard shortcut) is one of the ways you can open a new shell terminal window.

  1. Purge the ttf-mscorefonts-installer package and clean your APT cache of DEB packages:

    sudo apt-get purge ttf-mscorefonts-installer -y ; sudo apt-get update ; sudo apt-get check ; sudo apt-get clean ; sudo apt-get autoremove -y
  2. Install/update the Thunar file manager (it will be further needed to rename all downloaded truetype fonts):

    sudo add-apt-repository ppa:yuri-sucupira/thunar1.6.10-fix ; sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv AF8C7F18 ; sudo apt-get update ; sudo apt-get check ; sudo apt-get install thunar --reinstall -y ; sudo apt-get dist-upgrade -y
  3. Install/update the 7z file archiver (it's a file compactor/compressor and extractor/decompressor required to extract the truetype fonts from inside the EXE files that you'll have to download):

    sudo apt-get install p7zip p7zip-full --reinstall -y
  4. Create a temporary fonts folder by running this shell command:

    mkdir /tmp/fonts
  5. Start a web browser (like Mozilla Firefox, Google Chrome or any other one you might be using), then go to https://sourceforge.net/projects/corefonts/files/the%20fonts/final/ and download all EXE files except wd97vwr32.exe (because wd97vwr32.exe is a Word 97 Viewer: not a truetype font file). All the downloaded EXE files must be placed at /tmp/fonts

  6. Change directory (CD) into that temporary folder:

    cd /tmp/fonts
  7. Extract the contents of all the downloaded EXE files:

    7z e andale32.exe ; 7z e arial32.exe ; 7z e arialb32.exe ; 7z e comic32.exe ; 7z e courie32.exe ; 7z e georgi32.exe ; 7z e impact32.exe ; 7z e times32.exe ; 7z e trebuc32.exe ; 7z e verdan32.exe ; 7z e webdin32.exe
  8. Copy all TTF (truetype font) files into your system's Microsoft truetype fonts folder:

    sudo cp /tmp/fonts/*.TTF /usr/share/fonts/truetype/msttcorefonts/
    • Note: if /usr/share/fonts/truetype/msttcorefonts/ doesn't exist, create it by running the shell command sudo mkdir /usr/share/fonts/truetype/msttcorefonts/
  9. Start Thunar in superuser mode, inside the Microsoft truetype fonts folder:

    sudo thunar /usr/share/fonts/truetype/msttcorefonts/
  10. Now, at the new Thunar window (path: /usr/share/fonts/truetype/msttcorefonts/), go to the Thunar menu and then select the option Edit and then hit Select all files. Then hit the F2 key (or go to the Edit menu option and click on Rename..., or still right-click onto the area where the files were selected and choose the Rename... option), change the first field on the left to Uppercase / Lowercase (if you need an example, take a look at this picture) and then change the right-side field to Name and suffix. Finally, at the Convert to: field, change its parameter to lowercase and then hit the Rename files button.

...and that's it!

If you did everything as explained here, you'll now have all the Microsoft core truetype fonts installed. Start e.g. LibreOffice Writer and check if fonts such as Arial and Comic Sans are available. If they are, the fonts were correctly added to your system.

PS: the leftovers at /tmp/fonts will be eliminated on the next system (re)boot. Hence, you don't need to worry about them.


I encountered the “Failure to download extra data files” problem after running 'sudo apt install ubuntu-restricted-extras' in Ubuntu 18.04.

I fixed the problem with these two terminal commands issued while in ~/Downloads: wget http://httpredir.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.7_all.deb sudo gdebi ttf-mscorefonts-installer_3.7_all.deb

Good Luck. (If gdebi is not already installed then 'sudo apt install gdebi' beforehand.


Uninstall the package ttf-mscorefonts-installer and then install ubuntu-restricted-extras.

Connect to the internet and run this command:

sudo apt-get remove --purge ttf-mscorefonts-installer
sudo apt-get install ubuntu-restricted-extras

After the next start-up of your system, the message will be gone.

(I had the same problem but with even one more package in the message: flashplugin-installer) this is the annoying message I get every start: enter image description here

The whole message is very long, rightklick to download it: this is the annoying message i get every start

Maybe you have to restart the system before install the ubuntu-restricted-extras

  • Why should he uninstall the package ttf-mscorefonts-installer, any reason? note that ubuntu-restricted-extras also install it as a dependency. So, what is the point?
    – Anwar
    Commented Sep 14, 2012 at 17:37
  • yes, there is a reason, becouse it works!
    – rubo77
    Commented Sep 17, 2012 at 0:11
  • 1
    It sounds really strange, but i guess, there is a bug somewhere in apt-get: bcause even if you remove ttf-mscorefonts-installer even with purge, the message that it is missing still stays after a reboot! This is a really strange behaviour, but the only solution is to uninstall all that is related to that bug and reinstall the ubuntu-restricted-extras afterwards after a reboot. I had this strange behaviour on two mashines already
    – rubo77
    Commented Sep 17, 2012 at 0:16
  • @rubo77 I cannot really confirm this...
    – nanofarad
    Commented Sep 19, 2012 at 20:38
  • it only worked, cause on my computer gksudo was installed. i added a new answer, that should work on kubuntu fresh install too
    – rubo77
    Commented Sep 20, 2012 at 12:55

look for the file gksudo

which gksudo

and for kdesudo

which kdesudo

since i use kubuntu, gksudo is missing when the automated script is trying to download the missing files.

that's the bug!!

workaround: i solved it with a symlink:

ln -s /usr/bin/kdesudo /usr/bin/gksudo
sudo apt-get remove --purge ubuntu-restricted-extras ttf-mscorefonts-installer flashplugin-installer
sudo restart

after the restart:

sudo apt-get install ubuntu-restricted-extras flashplugin-installer

later you can remove that ugly workaround-symlink again with:

sudo rm -i /usr/bin/gksudo

Quite a hammermethod but it works

  • Please have a look at this question. Commented Jan 30, 2014 at 11:18
  • I guess, you can uninstall ubuntu-restricted-extras and flashplugin-installer after al problems are solved
    – rubo77
    Commented Jan 31, 2014 at 10:29

You might have trouble getting ttf-mscorefonts-installer to accept the EULA.

These commands will accept the EULA and reinstall the packages (assuming you downloaded the individual font .exes):

echo ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula select true | sudo debconf-set-selections
sudo dpkg-reconfigure ttf-mscorefonts-installer
  • That was not my problem, I've reacepted the EULA after using some other reinstall method, and problem persists. OMG, Ubuntu... Commented Dec 20, 2016 at 19:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .