Over the past few days, I have downloaded both the 32 and 64 bit version of server and desktop to install on an Intel based PC.

It is normal from within OS X to double click on an ISO and it will mount the ISO in the finder as well as within disk utility.

When I attempt to mount any of the Ubuntu ISOs I downloaded, OS X returns the error message The following disk images couldn't be opened. The reason given for the error is no mountable filesystem.

However, I am still able to open the ISO directly from disk utility and burn it to a DVD/CD.

What has changed in this release to cause this? Is there something wrong with the current ISOs?

The OS X machine I am using is only two weeks old and is having no issues with any other ISO.

  • 2
    @EliahKagan The OP appears to be referring to an error message displayed when you attempt to mount any of the 12.04 install ISOs in OS X. I tried mounting validated downloads of ubuntu-12.04-desktop-amd64.iso and ubuntu-12.04-desktop-i386.iso in OS X 10.6.8 (Snow Leopard) and verified you do get the error message the OP describes. I also mounted those images with no problems using the Daemon Tools and IsoBuster utilities in Windows 7. It appears to be a problem with how OS X mounts an ISO. But I don't know what it is about the composition of the ISOs which results in this glitch. Jun 20, 2012 at 22:23
  • @irrationalJohn Can you confirm it doesn't happen with an .iso for an earlier version of Ubuntu? If so, then Fufus Rufus's answer about why this is happening is probably correct. Jun 20, 2012 at 22:26
  • @EliahKagan I tried what I happened to have available without downloading. Both ubuntu-8.04.4-desktop-amd64.iso and ubuntu-10.04.4-desktop-amd64.iso mounted as expected. ubuntu-11.10-desktop-i386.iso did not. I got the same error message as for the 12.04 ISOs. Jun 20, 2012 at 23:12
  • 4
    To the hair-trigger "off-topic" closer: this is an extremely valid and on-topic question. Not every potential Ubuntu user uses Windows.
    – ish
    Jun 20, 2012 at 23:31
  • @irrationalJohn - thanks for your experiments confirming the problem, see detailed answer for reason with workaround.
    – ish
    Jun 21, 2012 at 1:51

7 Answers 7


This is due to a bug (of sorts) in the package used to create the Ubuntu ISOs

  • Since 11.10, Ubuntu ISOs have been "hybrid", meaning that the ISO can also be written bit-for-bit to a USB device to make it a working Live-USB, without having to use StartUp Disk Creator, UNetBootin, etc.

    • Note that this "hybrid" is different from the OS X/Disk Utility definition of "hybrid", which simply refers to an ISO readable on both Mac (HFS+) and Windows (ISO9660).
  • Ubuntu's hybrid functionality is provided by the isohybrid script in the SysLinux bootloader. It works by encapsulating the standard ISO9660 CD filesystem within a partition, so that it will work unmodified if written to a USB/hard disk.

  • This patch/bug report discusses a problem in the way isohybrid sets GPT UUIDs, causing Disk Utility/OS X to fail to recognize the hybrid filesystem and consequently, failing to mount it. Hopefully it will be fixed at some point, making future Ubuntu hybrid ISOs compatible with Disk Utility.

Alternative to extract/explore Ubuntu ISOs on OS X: Keka

  • Keka is an open-source OS X frontend to the p7zip package, which is able to view and extract ISOs in addition to a myriad of other archive management features. While it won't let you "mount" the Ubuntu ISO on its own, it should let you view the ISO filesystem and extract what you need.
  • If you need a command-line alternative for extracting isohybrid ISOs, you could try xorriso. Unlike p7zip and its derivatives, it handles Rock Ridge filesystems, and therefore filenames of over 64 characters.
    – Mike
    Feb 12, 2015 at 20:55

In case anyone else comes here because they were trying to install ubuntu in Vmware Fusion, but couldn't mount the iso, at least in Vmware Fusion 4, you can "Continue without disc" -- then it'll let you choose an iso on the next screen, so OSX never needs to mount it, and Vmware will mount it just fine.

  • I'm using VMWARE fusion pro 11.0 the behaviour is similar, create new vm open the vm settings instead of autodetect choose the iso from disc using the dropdown
    – Roee
    Jun 22, 2019 at 10:44

Maybe because they are now hybrid (DVD/USB) ISOs which can be directly dd'ed to a USB drive and booted.1

1. https://lists.ubuntu.com/archives/ubuntu-devel/2011-June/033495.html

  • @Eliah Kagan I interpreted his post that he could burn and mount but just not as doubleclick action. Jun 20, 2012 at 22:04

The only program extracting works with is the unarchiver for free from the app store. you can repackage it afterwards, but the plan would be to first be able to load any data at all.

  • Clarify your answer. Explain more fully what you mean by "first be able to load any data at all".
    – karel
    Apr 20, 2013 at 14:08

I faced the same error, after reading izx's answer, I used "The Unarchiver" app to extract the iso. It is also nice to know that one can now dd to have a working bootable usb.


I got it done by:

  1. hdiutil attach -verbose -noverify -nomount downloaded_ubuntu.iso

  2. open Diskutil GUI and choose the attached but not mounted ubuntu disk

  3. Diskutil -> File-> New disk image from ubuntu disk

  4. choose readonly or read/write with no encryption and choose the appropriate destination

  5. U get a .dmg file that can be mounted in OS X and also create a bootable usb by dumping it by diskuti or dd


  • This didn't work for me. So tried xorriso (as described above by Mike. I used xorriso -indev XX-YY.iso -osirrox on -extract / outdoor
    – Ben
    Oct 4, 2015 at 20:11
  • This didn't work for me either. It created a .dmg but I get the same "no mountable filesystem" opening that as I do from the source .iso. Using 7zip worked fine to extract the files to disk. Jan 10, 2017 at 0:35

Convert the ISO in to a DMG.

hdiutil convert -format UDRW -o ~/Desktop/ubuntu-12.10-desktop-i386.iso.img ~/Desktop/ubuntu.iso)
  • 2
    The conversion will appear to work, but you won't be able to open the resulting .DMG file. Mar 8, 2013 at 16:24
  • hmmm.. worked for me.
    – jwerre
    Mar 8, 2013 at 18:08
  • 3
    didn't work for me
    – Kem Mason
    Apr 19, 2013 at 0:47
  • Doesn't work, 20.04, and I don't believe that it ever worked for 12.10 either. Gives error no mountable file systems. Sep 13, 2021 at 14:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .